Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Problem when installing or upgrading

  1. #1
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Problem when installing or upgrading

    I am using OpenSuse 13.1 and KDE

    When I try to install software or update the openSUSE I get the following message:
    File './noarch/xorg-x11-libs-7.6-42.1.2.noarch.rpm' not found on medium
    'http://download.opensuse.org/distribution/13.1/repo/oss/'
    What should I do to fix this?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,166
    Blog Entries
    3

    Default Re: Problem when installing or upgrading

    Quote Originally Posted by sergelli View Post
    I am using OpenSuse 13.1 and KDE

    When I try to install software or update the openSUSE I get the following message:


    What should I do to fix this?
    I'm not at all sure why that would happen.

    Checking my own system, I note that the package was not installed. But it did show as being in the oss repo. Perhaps you are connected to a bad mirror.

    In any case, as a test, I installed the package. And that worked without problems.

    As best I can tell, the package is not actually needed. It seems to be there in case you are upgrading from an earlier version where it was needed. If there's an option to ignore this package, then try that.

    The package description says:

    "This package is a compatibility metapackage. It used to contain the X.Org libraries."
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: Problem when installing or upgrading

    On Sun, 06 Jul 2014 23:16:02 +0000, sergelli wrote:

    > What should I do to fix this?


    First, check the ISO checksum, then do a media check on your installation
    media.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,718

    Default Re: Problem when installing or upgrading

    IMHO this is a bit confusing. The two answers above are targeting two completely different actions. One seems to assume that it is about an package patch/update on an existing system. The other seems to assume that this is about a system installation.

    It all derives from the OP not explaning what he is doing. Please @sergelli, be more precise. Do not assume any understanding of things you are doing but not telling/showing. So if are you typing a command, show also what you type, not only the error message. Are you using a GUI (YaST e.g.) do tell what part of YaST, what tabs, menus, etc. you click. Only so can other people advise you about what you may have done wrong or what may be the problem.
    Henk van Velden

  5. #5
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: Problem when installing or upgrading

    Quote Originally Posted by hcvv View Post
    IMHO this is a bit confusing. The two answers above are targeting two completely different actions. One seems to assume that it is about an package patch/update on an existing system. The other seems to assume that this is about a system installation.

    It all derives from the OP not explaning what he is doing. Please @sergelli, be more precise. Do not assume any understanding of things you are doing but not telling/showing. So if are you typing a command, show also what you type, not only the error message. Are you using a GUI (YaST e.g.) do tell what part of YaST, what tabs, menus, etc. you click. Only so can other people advise you about what you may have done wrong or what may be the problem.
    1 - Case with YaST:
    If I open the the "YaST" and I click "Software Manegement"
    A little window pops up saying that it found:
    File './noarch/xorg-x11-libs-7.6-42.1.2.noarch.rpm' not found on medium
    'http://download.opensuse.org/distribution/13.1/repo/non-oss/'
    (media 1)
    2-Case download a RPM file
    If I download an rpm file, directly from any site, a small window will automatically appear with this option:
    "Open white: Apper installer (default)"
    If I click "OK" this error message appears:
    File './noarch/xorg-x11-libs-7.6-42.1.2.noarch.rpm' not found on medium
    'http://download.opensuse.org/distribution/13.1/repo/oss/'
    3-Case with APPER
    If I open the program "Apper" and in the search box I type any name, appears the message below:
    There was a (possibly temporary) problem connecting with the source software.
    Check the detailed error for more details.

    I seem to have trouble connecting or media repository
    But on another computer using the same connection and the same medias, have no problem

    Please, if you need more details, let me know what they are



    Thanks in advance

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,580

    Default Re: Problem when installing or upgrading

    Show use

    zypper lr -d

    Can you connect that machine to the net?

    Did you run media check on the install DVD on that machine?

  7. #7
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: Problem when installing or upgrading

    Quote Originally Posted by gogalthorp View Post
    Show use

    zypper lr -d

    Can you connect that machine to the net?

    Did you run media check on the install DVD on that machine?
    Yes, I can connect this machine to the net !
    And on another computer using the same connection and the same repositorys medias, have no problem

    Yes, I can run media check on the LIVE CD on this machine. I don't want install DVD on this machine! again.

    The result of zypper lr -d bellow

    sergio@linux-jmdp:~> zypper lr -d
    # | Apelido | Nome | Habilitado | Atualizar | Prioridade | Tipo | URI | Serviço
    ---+---------------------------+------------------------------------+------------+-----------+------------+--------+-----------------------------------------------------------------+--------
    1 | Packman Repository | Packman Repository | yes | yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman...openSUSE_13.1/ |
    2 | libdvdcss repository | libdvdcss repository | yes | yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.1/ |
    3 | repo-debug | openSUSE-13.1-Debug | no | yes | 99 | NONE | http://download.opensuse.org/debug/d...13.1/repo/oss/ |
    4 | repo-debug-update | openSUSE-13.1-Update-Debug | No | yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1/ |
    5 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No | yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1-non-oss/ |
    6 | repo-non-oss | openSUSE-13.1-Non-Oss | yes | yes | 99 | rpm-md | http://download.opensuse.org/distrib.../repo/non-oss/ |
    7 | repo-oss | openSUSE-13.1-Oss | yes | yes | 99 | rpm-md | http://download.opensuse.org/distrib...13.1/repo/oss/ |
    8 | repo-source | openSUSE-13.1-Source | No | yes | 99 | NONE | http://download.opensuse.org/source/...13.1/repo/oss/ |
    9 | repo-update | openSUSE-13.1-Update | yes | yes | 99 | rpm-md | http://download.opensuse.org/update/13.1/ |
    10 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | yes | yes | 99 | rpm-md | http://download.opensuse.org/update/13.1-non-oss/ |
    sergio@linux-jmdp:~>

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,718

    Default Re: Problem when installing or upgrading

    Your repo list seems to be OK to me, just standard. But can you please next time post computer text between CODE tags, not QUOTE tag. It is the # button in the tool bar op the post editor.

    Maybe there is something wrong in your RPM database. You coul try
    Code:
    su -c 'rpm --rebuilddb'
    Henk van Velden

  9. #9
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: Problem when installing or upgrading

    Quote Originally Posted by hcvv View Post
    Your repo list seems to be OK to me, just standard. But can you please next time post computer text between CODE tags, not QUOTE tag. It is the # button in the tool bar op the post editor.

    Maybe there is something wrong in your RPM database. You coul try
    Code:
    su -c 'rpm --rebuilddb'
    I did what you suggested and rebooted the machine, but the problem continues.
    What else can I try to do?

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problem when installing or upgrading

    On 2014-07-08 09:16, sergelli wrote:
    >
    > gogalthorp;2652850 Wrote:
    >> Show use
    >>
    >> zypper lr -d
    >>
    >> Can you connect that machine to the net?
    >>
    >> Did you run media check on the install DVD on that machine?

    >
    > *Yes, I can* connect this machine to the net !


    Please, prove it :-)

    Run, in a terminal, this, and paste back here (inside code tags, please):

    Code:
    ping -c 3 google.com

    > *Yes, I can *run media check on the *LIVE CD* on this machine. I don't
    > want install DVD on this machine! again.


    Ok, you can run the media check. But DID you run it? And what was the result? :-)


    > *The result of zypper lr -d* bellow



    Two comments:


    When pasting computer commands and such, please use a CODE BLOCK, so that the forum software doesn't do silly things like converting URLS to tiny urls, parenthesis into smileys, or otherwise hide or alter the commands you entered. You get them by clicking on the '#' button in the forum editor. See photo


    When the system language is not English, you should do,
    in order to post here, like this:

    Code:
    minas-tirith:~ # LANG=C zypper lr --details
    ....
    That way we can all read it, regardless of local languages of sender and
    reader. It is not a permanent change, it only applies to one command.


    I order to read your list, I had to reformat it first.

    Code:
    
    >> sergio@linux-jmdp:~> zypper lr -d
    >> #  | Apelido                   | Nome                               | Habilitado | Atualizar | Prioridade | Tipo   | URI                       | Serviço
    >> ---+---------------------------+------------------------------------+------------+-----------+------------+--------+-----------------------------------------------------------------+--------
    >> 1 | Packman Repository        | Packman Repository                 | yes        | yes       |   99       | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/        |
    >> 2 | libdvdcss repository      | libdvdcss repository               | yes        | yes       |   99       | rpm-md | http://opensuse-guide.org/repo/13.1/                            |
    >> 3 | repo-debug                | openSUSE-13.1-Debug                | no         | yes       |   99       | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/  |
    >> 4 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No         | yes       |   99       | NONE   | http://download.opensuse.org/debug/update/13.1/                 |
    >> 5 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No         | yes       |   99       | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/         |
    >> 6 | repo-non-oss              | openSUSE-13.1-Non-Oss              | yes        | yes       |   99       | rpm-md | http://download.opensuse.org/distribution/13.1/repo/non-oss/    |
    >> 7 | repo-oss                  | openSUSE-13.1-Oss                  | yes        | yes       |   99       | rpm-md | http://download.opensuse.org/distribution/13.1/repo/oss/        |
    >> 8 | repo-source               | openSUSE-13.1-Source               | No         | yes       |   99       | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/ |
    >> 9 | repo-update               | openSUSE-13.1-Update               | yes        | yes       |   99       | rpm-md | http://download.opensuse.org/update/13.1/                       |
    >>10 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | yes        | yes       |   99       | rpm-md | http://download.opensuse.org/update/13.1-non-oss/               |
    >> sergio@linux-jmdp:~>

    The repo list seems ok.


    Try this:

    Code:
    wget -v http://download.opensuse.org/distribution/13.1/repo/oss/suse/noarch/xorg-x11-libs-7.6-42.1.2.noarch.rpm
    and paste it all here, from initial command prompt, to last command prompt, in a single mouse sweep, and please do so inside code tags (the '#' button in the forum editor).
    See photo
    It is preferable to see what the commands have to say about things, than describing them :-)


    Notice that the error you pasted is:

    Code:
    File './noarch/xorg-x11-libs-7.6-42.1.2.noarch.rpm' not found on medium
    'http://download.opensuse.org/distribution/13.1/repo/oss/'
    But that is not the actual location of the file, there is a "suse" missing in the actual URL.


    See how it goes in my machine:


    Code:
    cer@Telcontar:~> wget -v http://download.opensuse.org/distribution/13.1/repo/oss/suse/noarch/xorg-x11-libs-7.6-42.1.2.noarch.rpm
    --2014-07-08 12:39:00--  http://download.opensuse.org/distribution/13.1/repo/oss/suse/noarch/xorg-x11-libs-7.6-42.1.2.noarch.rpm
    Resolving download.opensuse.org (download.opensuse.org)... 195.135.221.134, 2001:67c:2178:8::13
    Connecting to download.opensuse.org (download.opensuse.org)|195.135.221.134|:80... connected.
    HTTP request sent, awaiting response... 302 Found
    Location: http://suse.bifi.unizar.es/opensuse/distribution/13.1/repo/oss/suse/noarch/xorg-x11-libs-7.6-42.1.2.noarch.rpm [following]
    --2014-07-08 12:39:07--  http://suse.bifi.unizar.es/opensuse/distribution/13.1/repo/oss/suse/noarch/xorg-x11-libs-7.6-42.1.2.noarch.rpm
    Resolving suse.bifi.unizar.es (suse.bifi.unizar.es)... 155.210.135.75
    Connecting to suse.bifi.unizar.es (suse.bifi.unizar.es)|155.210.135.75|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 14151 (14K) [application/x-rpm]
    Saving to: ‘xorg-x11-libs-7.6-42.1.2.noarch.rpm’
    
    100%[=================================================================================================================================>] 14.151      56,4KB/s   in 0,2s
    
    2014-07-08 12:39:14 (56,4 KB/s) - ‘xorg-x11-libs-7.6-42.1.2.noarch.rpm’ saved [14151/14151]

    See how the file IS NOT downloaded from download.opensuse.org, despite me writing download.opensuse.org?
    We need to see where the request actually goes, specially if it fails.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •