Results 1 to 4 of 4

Thread: Cannot remove old version of Digikam

  1. #1
    Join Date
    Jun 2008
    Location
    Herefordshire, England
    Posts
    151

    Default Cannot remove old version of Digikam

    Yast seems to have a problem with an old version of digikam. I tell it to remove but it fails with an error:

    Additional rpm output:
    error: rpmdbNextIterator: skipping h# 7014 Header V3 DSA/SHA1 Signature, key ID 9ebd09c4: BAD
    How do I get rid of this problem?

    Thanks

    John F.

  2. #2

    Default Re: Cannot remove old version of Digikam

    Quote Originally Posted by jfarrar View Post
    Yast seems to have a problem with an old version of digikam. I tell it to remove but it fails with an error:



    How do I get rid of this problem?
    First, when asking a question, you should provide more information.
    F.e. at least which openSUSE version you are using, your repos, which digikam version gives you problem on removal...

    In your case, your rpm database seems to be corrupted, though.
    Run:
    Code:
    rpm --rebuilddb

  3. #3
    Join Date
    Jun 2008
    Location
    Herefordshire, England
    Posts
    151

    Default Re: Cannot remove old version of Digikam

    But you knew the answer anyway...

    Seriously, sorry, it was a quick, dashed off question about an irritation as I rarely use Yast, preferring zypper, but I still should have provided the relevant info!

    Anyway, problem solved - thanks very much!

    John F.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,733

    Default Re: Cannot remove old version of Digikam

    Quote Originally Posted by jfarrar View Post
    But you knew the answer anyway...

    Seriously, sorry, it was a quick, dashed off question about an irritation as I rarely use Yast, preferring zypper, but I still should have provided the relevant info!
    Better do not use your fellow users here to get rid of your irritation. You may spoil their joy in trying to help and the result may be that they either do not answer anymore to any post of yours, or worse, decide that helping here is not worth the effort.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •