Yast seems to have a problem with an old version of digikam. I tell it to remove but it fails with an error:

Additional rpm output:
error: rpmdbNextIterator: skipping h# 7014 Header V3 DSA/SHA1 Signature, key ID 9ebd09c4: BAD
How do I get rid of this problem?

Thanks

John F.