Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: Firewall deaktivieren

  1. #11

    Default Re: Firewall deaktivieren

    Habe ich gemacht - das runterladen klappt soweit ganz gut, nur sobald er anfangen will zu installieren kommt bei jedem Paket die Meldung, dass die Installation failed ist.

    Wenn ich mir die Details anzeigen lasse, steht dort:

    Subprocess failed. Error: RPM failed: Can't fork

    Habe versucht über yast, bei den Patterns, den GNOME Desktop zu installieren.

  2. #12

    Default Re: Firewall deaktivieren

    Kurzer Nachtrag: Wenn ich 'startx' eingebe bekomme ich folgende Nachricht:

    hostname: Name or service not known
    xauth: file /root/.serverauth.1245 does not exist

    /etc/X11/xinit/xserverrc: line 59: exec: X: not found
    xinit: giving up
    xinit: unable to connect to X server: Connection refused
    xinit: unexpected signal 2

    xinit failed. /usr/bin/Xorg ist not setuid, maybe that's the reason?
    If so either use a display manager (strongly recommended) or adjust /etc/permissions.local

  3. #13

    Default AW: Firewall deaktivieren

    Quote Originally Posted by ChristianBorn View Post
    Habe ich gemacht - das runterladen klappt soweit ganz gut, nur sobald er anfangen will zu installieren kommt bei jedem Paket die Meldung, dass die Installation failed ist.

    Wenn ich mir die Details anzeigen lasse, steht dort:

    Subprocess failed. Error: RPM failed: Can't fork
    Hm.
    Irgendwie kann er scheinbar RPM nicht starten.
    Kannst du rpm auf der Kommandozeile aufrufen? Z.B.:
    Code:
    rpm --version
    Es hat doch vorher funktioniert, oder?

    Quote Originally Posted by ChristianBorn View Post
    Kurzer Nachtrag: Wenn ich 'startx' eingebe bekomme ich folgende Nachricht:

    hostname: Name or service not known
    xauth: file /root/.serverauth.1245 does not exist

    /etc/X11/xinit/xserverrc: line 59: exec: X: not found
    Klar, wenn die Installation des X Servers fehlgeschlagen ist, kannst du ihn auch nicht starten.

  4. #14

    Default Re: Firewall deaktivieren

    Das mit 'rpm --version' funktioniert: RPM version 4.10.2

    Dann lasse ich das mit dem startx erstmal ausser Acht.

  5. #15

    Default Re: Firewall deaktivieren

    Quote Originally Posted by ChristianBorn View Post
    Das mit 'rpm --version' funktioniert: RPM version 4.10.2
    Hm, dann finde ich die Fehlermeldung umso seltsamer.

    Hat die VM evtl. zuwenig RAM?

    Da die Pakete ja schon runtergeladen sind, könntest du sie probieren manuell mit rpm zu installieren.
    Sie sollten unter /var/cache/zypp/packages/ zu finden sein.
    Poste bitte die Ausgabe von.
    Code:
    ls /var/cache/zypp/packages
    damit ich dir die genauen Befehle schreiben kann.

    Oder probier einfach mal:
    Code:
    zypper in -t pattern gnome
    Last edited by wolfi323; 07-Jul-2014 at 06:45.

  6. #16

    Default Re: Firewall deaktivieren

    Die Ausgabe des Befehls:

    openSUSE_12.3_OSS openSUSE_12.3_Updates


    Die VM hatte nur 1GB RAM - habe ihr jetzt mal 4GB zugewiesen und werd's erneut testen.

  7. #17

    Default Re: Firewall deaktivieren

    Quote Originally Posted by ChristianBorn View Post
    Die VM hatte nur 1GB RAM - habe ihr jetzt mal 4GB zugewiesen und werd's erneut testen.
    1GB sollte locker reichen. Mit "zu wenig" meinte ich eher sowas in der Art von <512MB... (das könnte für YaST zu knapp werden zum Installieren)

    Wie gesagt (hab das im nachhinein dazugeschrieben), probier statt YaST mal:
    Code:
    zypper in -t pattern gnome
    Das verwendet natürlich auch die schon heruntergeladenen Pakete.

    Falls das auch nicht klappt, solltest du die Pakete im Cache folgendermaßen installieren können:
    Code:
    cd /var/cache/zypp
    rpm -ivh openSUSE_12.3_OSS/*/*/* openSUSE_12.3_Updates/*/*

  8. #18

    Default Re: Firewall deaktivieren

    Anscheinend lags doch am RAM - jetzt hat er's wohl installiert.

    Das sagt zumindest das System wenn ich 'zypper in -t pattern gnome' ausführe:

    Loading repository data...
    Reading installed packages...
    'pattern:gnome' is already installed.
    No update candidate for 'gnome-12.3-7.10.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.


    Wenn ich den Befehl mit rpm -ivh ausführe bekomme ich die Meldung dass das 'File not found by glob: Dateiname'


    Und danke übrigens für den Aufwand den du dir machst!

  9. #19

    Default AW: Re: Firewall deaktivieren

    Quote Originally Posted by ChristianBorn View Post
    Anscheinend lags doch am RAM - jetzt hat er's wohl installiert.
    Seltsam.
    Ich teste immer wieder mal eine openSUSE Standardinstallation (meistens mit KDE) in VirtualBox. Dabei gebe ich der VM immer 768MB, und hatte noch nie Probleme... (768MB deshalb, weil bei den 13.1 Beta-Versionen bei nur 512MB die Installation hängen blieb, seither ist das halt Gewohnheit)

    Das sagt zumindest das System wenn ich 'zypper in -t pattern gnome' ausführe:

    Loading repository data...
    Reading installed packages...
    'pattern:gnome' is already installed.
    No update candidate for 'gnome-12.3-7.10.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    Nothing to do.
    Gut, das sagt, dass das Pattern installiert wurde. Heißt jetzt aber nicht, dass auch alle Pakete installiert wurden. (ein Pattern ist im Prinzip nur eine Liste von Paketen die installiert werden sollen)
    Hat er Pakete installiert? Hast du Fehlermeldungen bekommen?

    Könnte sein, dass du das Neuinstallieren des Patterns erzwingen musst.
    Code:
    zypper in -f -t pattern gnome
    Wie du das im Textmodus-YaST machen könntest weiß ich jetzt grade nicht auswendig.

    Wenn allerdings gnome-shell installiert ist, sollte es eigentlich auf jeden Fall passen.
    Code:
    rpm -q gnome-shell
    Wenn ich den Befehl mit rpm -ivh ausführe bekomme ich die Meldung dass das 'File not found by glob: Dateiname'
    Hm, wo kommt den das "Dateiname" her?
    Ist aber ja jetzt eh egal, wenn YaST/zypper funktioniert.

    Tja, also wie gesagt, probier mal "init 5" einzugeben, dann sollte eigentlich ein grafischer Anmelde-Bildschirm erscheinen. (oder vielleicht sogar gleich GNOME, wenn Auto-Login aktiviert ist)

  10. #20

    Default Re: Firewall deaktivieren

    Nach folgendem Befehl kommt dieses Output:

    Code:
    zypper in -f -t pattern gnome


    The following NEW pattern are going to be installed:
    base enhanced_base fonts gnome gnome_basis x11

    Danach kommen noch folgende Abschnitte:

    The following packages are recommended, but will not be installed
    The following patterns are recommended, but will not be installed
    The following packages are suggested, but will not be installed

    Und am Ende kommt 'Nothing to do'.


    Die gnome shell ist installiert, Version 3.6.3.1-1.1.1.x86_64


Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •