Results 1 to 2 of 2

Thread: Getting Chromium Web Browser to Open Citrix Receiver in OpenSuse

  1. #1

    Default Getting Chromium Web Browser to Open Citrix Receiver in OpenSuse

    I had already installed Citrix ICA Client on my OpenSuse machine. You get the software here:

    http://www.citrix.com/downloads/citr...linux-130.html

    This worked on Firefox for awhile, but policies were changed for Windows only at the site. I did noticed that Chromium still used the old standard. When you login into your Citrix launch site with Chromium and click on an icon, it will download a file like "launch.ica" and when I tried to launch it would just open in Kwrite.

    To fix this I followed the instructions for Ubuntu - these instructions mostly work, I'm giving credit to the original poster of the solution in that forum: http://ubuntuforums.org/showthread.php?t=1645173

    Here are the actions that worked for me in OpenSuse 13.1

    Creating MIME types for Citrix ICA Client

    1. Create new file /usr/share/applications/wfica.desktop

    [[Desktop Entry]
    Name=Citrix ICA client
    GenericName=Citrix ICA Client
    Comment=Citrix nFuse session file
    Categories=Application
    Encoding=UTF-8
    Exec=/opt/Citrix/ICAClient/wfica
    Icon=wfica
    Terminal=false
    Type=Application
    MimeType=application/x-ica

    2. Create new file /usr/share/mime/packages/ica.xml

    <?xml version="1.0" encoding="utf-8"?>
    <mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
    <mime-type type="application/x-ica">
    <comment>Citrix ICA launcher</comment>
    <glob pattern="*.ica"/>
    </mime-type>
    </mime-info>

    3. su into root and issue this command

    update-desktop-database && sudo update-mime-database /usr/share/mime


    4. Run the following from the command line:

    xdg-mime install --novendor /usr/share/mime/packages/ica.xml

    xdg-mime default wfica.desktop application/x-ica


    5. At this point, if you click on a browser link that should launch an application using Citrix, it will download a file called something like "launch.ica". If you click on the little arrow next to this file, and choose "Always open files of this type", then choose "Open", it should work.

  2. #2

    Default Re: Getting Chromium Web Browser to Open Citrix Receiver in OpenSuse

    This was very helpful. Thanks for posting it.

    My environment is opensuse 13.1 using the Mate desktop and Firefox web browser. I was researching mimetypes (i.e., where do they come from, defaults, how to add or change them). In KDE this was done via an app in Personal Settings/Configure Desktop -> File Associations.

    I gleamed a lot of info here:
    https://wiki.archlinux.org/index.php...t_Applications

    The way presented here is definitely more advanced. If you wanted to just impact a single user, a right-click "Open With" would do the trick. I suspect all file browsers might operate in a similar fashion. Caja, Mate's file browser, shows first the Default application, a horizontal line, then Other applications that handle the mimetype with the last entry being, "Open With Other Application". This info is also presented when you right-click and select "Properties" -> "Open With". As far as I can tell this creates a X.desktop (where X is the appname) file and updates mimeapps.list in $HOME/.local/share/applications/. Firefox Preferences -> Applications has a similar dialog with the same end results.

    A man -k xdg shows other xdg commands which I'm just starting to read about. xdg-mime query filetype FILE is particularly helpful in this case.

    The nice thing about opensuse is, they put lots of documentation in their files.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •