Results 1 to 2 of 2

Thread: Install, Grub2 error (bootloader)

  1. #1

    Default Install, Grub2 error (bootloader)

    Hi.

    I am trying ti install opensuse on my laptop with win8. I boot from usb and tried to install it. Everything went smoothly until grub error at 93%:

    /usr/sbin/grub2-bios-setup: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible
    /usr/sbin/grub2-bios-setup: error: embeddingis not possible, but this is reqiored for cross-disk install

    Before, I chose defualt option of opensuse to create proposed home partition.
    After error, i tried installing with no bootloader and later also with bootloader on root partition. Both option causes opensuse install menu to appear again, where i can choose Installation, Boot from HDD etc.

    Please help.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,818

    Default Re: Install, Grub2 error (bootloader)

    I guess you have a EFI BIOS, right??

    If so you need to boot the DVD or USB in EFI mode

    You should be installing grub2-efi and check the box to allow secure boot

    The EFI boot partition should be mounted as /boot/efi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •