Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: [help] freezing on start up, how can i fix it ?

  1. #1

    Question [help] freezing on start up, how can i fix it ?

    my computer is dell xps 2720

    (UEFI + GPT) Windows 8.1 + openSUSE 13.1

    the BOOT Secure is Disabled

    when i start up my computer, after the grub2, sometimes it displays the following picture, what is the problem? how can i fix it ? thank you for you help!!!


  2. #2

    Default Re: [help] freezing on start up, how can i fix it ?

    Quote Originally Posted by deropty View Post
    when i start up my computer, after the grub2, sometimes it displays the following picture, what is the problem? how can i fix it ? thank you for you help!!!
    Seems to be a problem with the nouveau graphics driver.
    I would suggest to install the proprietary nvidia driver, see here: http://en.opensuse.org/SDB:NVIDIA_drivers

    What exact graphics card/chipset do you have?
    Code:
    /sbin/lspci -nn | grep VGA

  3. #3

    Default Re: [help] freezing on start up, how can i fix it ?

    Quote Originally Posted by wolfi323 View Post
    Seems to be a problem with the nouveau graphics driver.
    I would suggest to install the proprietary nvidia driver, see here: http://en.opensuse.org/SDB:NVIDIA_drivers

    What exact graphics card/chipset do you have?
    Code:
    /sbin/lspci -nn | grep VGA
    thank you for your suggestion, i have installed the graphic driver, and there is no freezing happened during the start up in my three times' test ! it means a lot for me, thank you !


    but another problems arises ..
    here is my graphic chipsets:
    00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107M [GeForce GT 750M] [10de:0fe4] (rev a1)
    i installed VirtualBox in my computer, after updating the graphic driver, the 3D Acceleration became invalid strange thing!

    ps: when i installed the opensuse13.1, i set my four virtual desktop switch in cube mode, several days later, its amazing switch disappeared, i suppose it would come back after the NVIDIA dirver installed, but it makes me down

    all the way, it is enought for me that the computer can start up into suse rightly

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,745
    Blog Entries
    20

    Default Re: [help] freezing on start up, how can i fix it ?

    FYI
    As far as I know
    Windows 8 with GPT, must have EFI secure boot enabled

    Your hybrid graphics is the problem in openSUSE, but not unsolvable
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: [help] freezing on start up, how can i fix it ?

    Quote Originally Posted by deropty View Post
    but another problems arises ..
    here is my graphic chipsets:
    00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107M [GeForce GT 750M] [10de:0fe4] (rev a1)
    If this is an Optimus system (i.e. switchable hybrid intel+nvidia graphics) you can _not_ use the nvidia driver and should _not_ have it installed.
    On such a system, the intel chip is used normally, but installing the nvidia driver breaks the intel driver's 3D part.
    Installing the nvidia driver fixed your problem none-the-less even in that case, as it prevents the nouveau kernel module from being loaded (and that caused the crashes/freezes in your case).

    Can you please post the file /var/log/Xorg.0.log? (upload it to http://susepaste.org or similar and post a link)
    This should show in any case what's going wrong.

    If this is indeed an Optimus system, you could have a look in the BIOS settings whether you can turn off the intel graphics, the nvidia driver should work then (with full 3D support).

    If that's not possible, you would have to uninstall the nvidia driver again and use Bumblebee instead.

    But let's have a look at the Xorg log first...
    Last edited by wolfi323; 18-Jun-2014 at 01:14.

  6. #6

    Default Re: [help] freezing on start up, how can i fix it ?

    Quote Originally Posted by wolfi323 View Post

    But let's have a look at the Xorg log first...
    here is the Xorg.0.log, thank you for your attention!

    http://susepaste.org/90368244

  7. #7

    Default Re: [help] freezing on start up, how can i fix it ?

    Quote Originally Posted by deropty View Post
    here is the Xorg.0.log, thank you for your attention!

    http://susepaste.org/90368244
    Ok, as suspected. The intel graphics and intel driver is in use.

    If you want to only use the nvidia GPU, have a look into the BIOS settings whether you can turn off the intel chip.
    The nvidia driver should just work then. (but this is not possible on all optimus systems)

    Otherwise you should uninstall the nvidia driver again, i.e. remove those packages with "nvidia" in their name in YaST f.e.:
    nvidia-gfxG03-kmp-xxx, nvidia-uvm-gfxG03-kmp-xxx (where xxx can be desktop or default f.e.), nvidia-computeG03, nvidia-glG03, x11-video-nvidiaG03

    In that case you could install Bumblebee to switch between intel and nvidia and use the nvidia driver from there. I cannot really help with that, but here's a link: http://en.opensuse.org/SDB:NVIDIA_Bumblebee

    Or, if you are fine with just using the intel, you could try to switch off the nvidia card in the BIOS settings.
    If that's not possible prevent the nouveau driver from being loaded by creating a file in /etc/modprobe.d/ with the following content:
    Code:
    blacklist nouveau
    Or add "brokenmodules=nouveau" to the kernel boot options (in YaST->System->Boot Loader->Boot Loader Options f.e., "Optional kernel parameter")
    Last edited by wolfi323; 18-Jun-2014 at 03:17.

  8. #8

    Default Re: [help] freezing on start up, how can i fix it ?

    Quote Originally Posted by caf4926 View Post
    FYI
    As far as I know
    Windows 8 with GPT, must have EFI secure boot enabled
    the secure boot must be disabled, otherwise there will be the signature error even if the openSUSE is in 'secure boot' mode!

    at first Windows 8 says the secure boot is not configured correctly,but after some time, it did not say something any more!
    now it works very well !

  9. #9

    Default Re: [help] freezing on start up, how can i fix it ?

    Quote Originally Posted by wolfi323 View Post
    If this is an Optimus system (i.e. switchable hybrid intel+nvidia graphics) you can _not_ use the nvidia driver and should _not_ have it installed.
    On such a system, the intel chip is used normally, but installing the nvidia driver breaks the intel driver's 3D part.
    Installing the nvidia driver fixed your problem none-the-less even in that case, as it prevents the nouveau kernel module from being loaded (and that caused the crashes/freezes in your case).

    If that's not possible, you would have to uninstall the nvidia driver again and use Bumblebee instead.
    Quote Originally Posted by wolfi323 View Post

    Or, if you are fine with just using the intel, you could try to switch off the nvidia card in the BIOS settings.
    If that's not possible prevent the nouveau driver from being loaded by creating a file in /etc/modprobe.d/ with the following content:
    Code:
    blacklist nouveau
    Or add "brokenmodules=nouveau" to the kernel boot options (in YaST->System->Boot Loader->Boot Loader Options f.e., "Optional kernel parameter")
    i'm very appreciate your attention, i followed your suggestion, uninstall the nvidia driver and add the "brokenmodules=nouveau", but it still freezes in the opensuse picture,
    the way you recommended installing Bumblebee should be the best way, but there is another thing have to be done, so put this down for a moment
    now i install the nvidia drive, you did not suppose that, but it guarantees that the openSUSE is available for me at least, forgive me to be a weaker, i will come back to defeat it, but now!

  10. #10

    Default Re: [help] freezing on start up, how can i fix it ?

    Quote Originally Posted by deropty View Post
    i'm very appreciate your attention, i followed your suggestion, uninstall the nvidia driver and add the "brokenmodules=nouveau", but it still freezes in the opensuse picture,
    Hm, this should work I think.

    Ok, I would suggest this then:
    Leave the nvidia driver installed and only uninstall the package "nvidia-glG03". You should have working 3D acceleration with the intel driver then, so this might be a (easy) solution as well. You could even use CUDA on the nvidia card that way. (that's why the driver is split up in several packages)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •