Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Setting up Postfix

  1. #1

    Default Setting up Postfix

    I am having a bear of a time getting Postfix to work at all.

    Opensuse 13.1 running in a VM. I installed whatever version is in the repos and tried to follow this tutorial: http://tr.opensuse.org/Mail_server_HOWTO

    I get stopped right from the beginning where it says to telnet in. All I get is:

    telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.

    And it hangs, no message from postfix(no 220 example.com ESMTP Postfix). I can even see remotely that port 25 is open, but nmap can not figure out what is running there.

    I did a zypper remove postfix and then deleted every file on the system related to postfix(zypper doesn't remove all the config files and what not) and reinstalled and started postfix.

    Same thing happened.

    Is the postfix in the oss repos broken or is their some magic incantation I need to know to get it to respond to telnet properly.

    Also, what exactly does this translate to:

    myhostname = hostname.example.com

    isn't example.com the hostname in this example and thus redundant. Let's say my domain name is mailla.com and the mx record pointed to mailla.com, would it really be hostname.mailla.com?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,302
    Blog Entries
    15

    Default Re: Setting up Postfix

    On Tue 01 Jul 2014 10:46:02 PM CDT, Mailla wrote:


    I am having a bear of a time getting Postfix to work at all.

    Opensuse 13.1 running in a VM. I installed whatever version is in the
    repos and tried to follow this tutorial:
    http://tr.opensuse.org/Mail_server_HOWTO

    I get stopped right from the beginning where it says to telnet in. All I
    get is:

    telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.

    And it hangs, no message from postfix(no 220 example.com ESMTP Postfix).
    I can even see remotely that port 25 is open, but nmap can not figure
    out what is running there.

    I did a zypper remove postfix and then deleted every file on the system
    related to postfix(zypper doesn't remove all the config files and what
    not) and reinstalled and started postfix.

    Same thing happened.

    Is the postfix in the oss repos broken or is their some magic
    incantation I need to know to get it to respond to telnet properly.

    Also, what exactly does this translate to:

    myhostname = hostname.example.com

    isn't example.com the hostname in this example and thus redundant. Let's
    say my domain name is mailla.com and the mx record pointed to
    mailla.com, would it really be hostname.mailla.com?


    Hi
    Should work OOB from the get go.... Did you setup the hostname via YaST
    Network Devices first, this should set the FQDN eg hostname.mailla.com.

    Code:
    telnet localhost 25
    
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 ernie.gekkota.dyndns.org ESMTP
    HELO ernie.gekkota.dyndns.org
    250 ernie.gekkota.dyndns.org
    MAIL FROM: me@ernie.gekkota.dyndns.org
    250 2.1.0 Ok
    RCPT TO: me@ernie.gekkota.dyndns.org
    250 2.1.5 Ok
    DATA
    354 End data with <CR><LF>.<CR><LF>
    SUBJECT: Email test
    This is a test
    
    ..
    250 2.0.0 Ok: queued as 48F9D3A4
    QUIT
    221 2.0.0 Bye
    Connection closed by foreign host.
    You have mail in /var/spool/mail/me
    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-17-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Setting up Postfix

    On 2014-07-02 00:46, Mailla wrote:
    >
    > I am having a bear of a time getting Postfix to work at all.
    >
    > Opensuse 13.1 running in a VM. I installed whatever version is in the
    > repos and tried to follow this tutorial:
    > http://tr.opensuse.org/Mail_server_HOWTO


    Good grief!

    Look, the English original version of that howto is here:

    [URL]http://old-en.opensuse.org/Mail_server_HOWTO[URL]

    That is, the OLD wiki. And, as you can see, the English version is quite
    longer, which means that the version you were following is an early copy
    of the article, ie, even older than the old English article, which is
    dated 2010 - wait, your page is dated 2006!!


    > Is the postfix in the oss repos broken


    No.

    > or is their some magic
    > incantation I need to know to get it to respond to telnet properly.


    Why do you want to telnet in?

    Look, setting up postfix (at least the initial setup) is as easy as
    starting yast, telling you want to configure mail, and follow your nose.
    Just tell your nose to go easy, not advanced.


    > Also, what exactly does this translate to:
    >
    > myhostname = hostname.example.com
    >
    > isn't example.com the hostname in this example and thus redundant. Let's
    > say my domain name is mailla.com and the mx record pointed to
    > mailla.com, would it really be hostname.mailla.com?


    No, unless you want to. You can use mailla.com, goaway.mailla.com,
    mail.mailla.com, smtp.mailla.com, mx.mailla.com, whatever.mailla.com...
    You choose.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  4. #4

    Default Re: Setting up Postfix

    Dovecot responds appropriately to telnet localhost 143 so I am not sure it is a FQDN issue.

    The hosts file was autogenerated, by openvz I guess. It contains my ipaddress and domain in there already.
    Code:
    ::1             localhost ipv6-localhost ipv6-loopback
    
    fe00::0         ipv6-localnet
    
    ff00::0         ipv6-mcastprefix
    ff02::1         ipv6-allnodes
    ff02::2         ipv6-allrouters
    ff02::3         ipv6-allhosts
    
    127.0.0.1 localhost.localdomain localhost
    # Auto-generated hostname. Please do not remove this comment.
    256.51.232.225 mailla.net  mailla #changed to the first octet and domain name for privacy reasons
    /etc/HOSTNAME is mailla

    Due to Yast using a older version of ruby, which was causing weird issues with my rackup app running over thin using a manually compiled and installed version of ruby in /opt I deleted the system ruby which took all of yast away. Even though I was running /opt/ruby/bin/rackup faye.ru ... it was trying to use the system ruby version.

    I might try another SMTP server, or just install Postfix from source.


    Robin,

    Why would I want to telnet in? Um, so I know that the stupid thing can at least accept connections, which the default install in the oss repo obviously can't.

    The copyright on the page I linked to was 2011. If there is a more up to date wiki page, you can at least pretend you want to helpful and supply the link instead of being snarky and wasting my time. Searching on http://en.opensuse.org yields nothing useful and the best link searching google is what I was trying. None of that is going to help anyway, because postfix isn't responding to the initial connection, even though it is running!

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,302
    Blog Entries
    15

    Default Re: Setting up Postfix

    On Wed 02 Jul 2014 12:16:01 AM CDT, Mailla wrote:


    The hosts file was autogenerated, by openvz I guess. It contains my
    ipaddress and domain in there already.

    Due to Yast using a older version of ruby, which was causing weird
    issues with my rackup app running over thin using a manually compiled
    and installed version of ruby in /opt I deleted the system ruby which
    took all of yast away. Even though I was running /opt/ruby/bin/rackup
    faye.ru ... it was trying to use the system ruby version.
    Hi
    Since in most cases it works OOB without any user interaction, aside
    from setting the hostname, ip address etc (which can be done during
    the install) as your using as a server setup. One would have to assume
    it's specific to your setup with the additional applications.

    I would guess the only way to confirm would be a re-install (or did you
    create a snapshot to roll back to?), set up your mail with the default
    install, test, snapshot, then add your additional components one at a
    time or as required, test and create a snapshot and move on.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-17-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  6. #6

    Default Re: Setting up Postfix

    Thanks for your response. I found an opensuse repo with a functional postfix: http://download.opensuse.org/reposit...rver:mail.repo

    Hopefully, I won't have any more issues. Especially SMTPS. But I will be happy for now if I can connect with established user names.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Setting up Postfix

    On 2014-07-02 02:16, Mailla wrote:

    > Robin,
    >
    > Why would I want to telnet in? Um, so I know that the stupid thing can
    > at least accept connections, which the default install in the oss repo
    > obviously can't.


    Works here:

    Code:
    cer@Telcontar:~> telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 Telcontar.valinor ESMTP

    > The copyright on the page I linked to was 2011.


    http://tr.opensuse.org/index.php?***...action=history

    Which says:

    (fark | son) 13:34, 8 Haziran 2006‎ Toratoraman (Mesaj | katkılar)‎ . .
    (7.940 bayt) (+7.940)‎

    which google translates as:

    (cur | prev) 13:34, 8 June 2006 Koncur (Talk | contribs). . (7940
    bytes) (+7940)


    So last update was done "8 June 2006". You really can not trust
    instructions so old in Linux.


    > If there is a more up to
    > date wiki page, you can at least pretend you want to helpful and supply
    > the link instead of being snarky and wasting my time.


    Then, as you do not want my help, I withdraw. I do not want to waste
    your time, nor do I appreciate being called "snarky".

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  8. #8

    Default Re: Setting up Postfix

    Without any changes, I can get past the HELO and MAIL FROM: but RCPT TO: I get a relay access denied, so even this one doesn't work OOB.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,302
    Blog Entries
    15

    Default Re: Setting up Postfix

    On Wed 02 Jul 2014 02:06:01 AM CDT, Mailla wrote:


    Without any changes, I can get past the HELO and MAIL FROM: but RCPT TO:
    I get a relay access denied, so even this one doesn't work OOB.


    Hi
    Did you setup a hostname via YaST?
    Code:
    cat /etc/postfix/main.cf|grep myhostname
    myhostname = ernie.gekkota.dyndns.org
    The above was populated without my editing main.cf?

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-17-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  10. #10

    Default Re: Setting up Postfix

    Quote Originally Posted by robin_listas View Post
    On 2014-07-02 02:16, Mailla wrote:

    > Robin,
    >
    > Why would I want to telnet in? Um, so I know that the stupid thing can
    > at least accept connections, which the default install in the oss repo
    > obviously can't.


    Works here:

    Code:
    cer@Telcontar:~> telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 Telcontar.valinor ESMTP

    > The copyright on the page I linked to was 2011.


    http://tr.opensuse.org/index.php?***...action=history

    Which says:

    (fark | son) 13:34, 8 Haziran 2006‎ Toratoraman (Mesaj | katkılar)‎ . .
    (7.940 bayt) (+7.940)‎

    which google translates as:

    (cur | prev) 13:34, 8 June 2006 Koncur (Talk | contribs). . (7940
    bytes) (+7940)


    So last update was done "8 June 2006". You really can not trust
    instructions so old in Linux.


    > If there is a more up to
    > date wiki page, you can at least pretend you want to helpful and supply
    > the link instead of being snarky and wasting my time.


    Then, as you do not want my help, I withdraw. I do not want to waste
    your time, nor do I appreciate being called "snarky".

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)
    Just because it works for you doesn't mean I am not having issues with the oss supplied Postfix. You weren't being helpful in the slightest and you were being snarky, if you don't appreciate being called out for your arrogant behavior, there is a simple solution...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •