Results 1 to 9 of 9

Thread: openSUSE 13.1 repository hang

  1. #1
    Join Date
    Jul 2014
    Location
    Round Rock, TX
    Posts
    76

    Default openSUSE 13.1 repository hang

    I am a very new person to Linux, so please forgive my ignorance. I've been having a problem that the PackageKit is not allowing me to install anything. I've followed the directions to kill PackageKit, and I've also been following the directions on the thread linked below to bring up zypper repositories. In zypper, I have two repositories: "repo-debug" and "repo-debug-update". I am in a terminal window, logged on as su, and did the following:

    zypper mr -da
    zypper mr -e 1 (this is the repo-debug repository)
    zypper up

    Works like a champ. Then I do this:

    zypper mr -e 2 (this is the repo-debug-update - no issues)
    zypper up (hangs for very long periods of time - never finishes)

    This is the error I get: File './repodata/d6a4040ad2be25339447b5b97280d5b302907273ae31d53b4c42f3d20e053ea1-primary.xml.gz' not found on medium 'http://download.opensuse.org/debug/update/13.1/'

    I've seen about changing the location of the repository. I did a search about possible repositories for the hanging one, and I've not found any others.

    I would greatly appreciate any and all help. Please understand, that I am very, very, very new to Linux, so please be patient with me.
    Here's the link that I was following: http://forums.opensuse.org/showthrea...n-t-quit/page3

  2. #2

    Default Re: openSUSE 13.1 repository hang

    On 07/01/2014 09:56 AM, mikejazzfan pecked at the keyboard and wrote:
    > I am a very new person to Linux, so please forgive my ignorance. I've
    > been having a problem that the PackageKit is not allowing me to install
    > anything. I've followed the directions to kill PackageKit, and I've
    > also been following the directions on the thread linked below to bring
    > up zypper repositories. In zypper, I have two repositories:
    > "repo-debug" and "repo-debug-update". I am in a terminal window, logged
    > on as su, and did the following:
    >
    > zypper mr -da
    > zypper mr -e 1 (this is the repo-debug repository)
    > zypper up
    >
    > Works like a champ. Then I do this:
    >
    > zypper mr -e 2 (this is the repo-debug-update - no issues)
    > zypper up (hangs for very long periods of time - never finishes)
    >
    > I've seen about changing the location of the repository. I did a search
    > about possible repositories for the hanging one, and I've not found any
    > others.
    >
    > I would greatly appreciate any and all help. Please understand, that I
    > am very, very, very new to Linux, so please be patient with me.
    > Here's the link that I was following: http://tinyurl.com/qhx68eb
    >
    >


    You have all but the two "debug" repos (which you really do not need at
    this point in your linux knowledge) disabled. Show us the list of your
    repos (in code tags) using

    <code>
    zyyper lr
    </code/

    You will need to enable more repoes then the two "debug" repos. You can
    enable all of your repos using

    <code>
    zypper mr ea
    </code>

    Ken

  3. #3
    Join Date
    Jul 2014
    Location
    Round Rock, TX
    Posts
    76

    Default Re: openSUSE 13.1 repository hang

    Quote Originally Posted by kensch View Post
    On 07/01/2014 09:56 AM, mikejazzfan pecked at the keyboard and wrote:
    > I am a very new person to Linux, so please forgive my ignorance. I've
    > been having a problem that the PackageKit is not allowing me to install
    > anything. I've followed the directions to kill PackageKit, and I've
    > also been following the directions on the thread linked below to bring
    > up zypper repositories. In zypper, I have two repositories:
    > "repo-debug" and "repo-debug-update". I am in a terminal window, logged
    > on as su, and did the following:
    >
    > zypper mr -da
    > zypper mr -e 1 (this is the repo-debug repository)
    > zypper up
    >
    > Works like a champ. Then I do this:
    >
    > zypper mr -e 2 (this is the repo-debug-update - no issues)
    > zypper up (hangs for very long periods of time - never finishes)
    >
    > I've seen about changing the location of the repository. I did a search
    > about possible repositories for the hanging one, and I've not found any
    > others.
    >
    > I would greatly appreciate any and all help. Please understand, that I
    > am very, very, very new to Linux, so please be patient with me.
    > Here's the link that I was following: http://tinyurl.com/qhx68eb
    >
    >


    You have all but the two "debug" repos (which you really do not need at
    this point in your linux knowledge) disabled. Show us the list of your
    repos (in code tags) using

    <code>
    zyyper lr
    </code/

    You will need to enable more repoes then the two "debug" repos. You can
    enable all of your repos using

    <code>
    zypper mr ea
    </code>

    Ken
    Hi Ken,

    Thanks for your reply. I have since done some additional playing and searching. I learned where in the GUI one can enable and add repositories. As such, here is what I have:
    # | Alias | Name | Enabled | Refresh
    ---+-----------------------------+-----------------------------------------+---------+--------
    1 | download.opensuse.org-Extra | openSUSE BuildService - KDE:Extra | Yes | Yes
    2 | download.opensuse.org-Wine | openSUSE BuildService - Wine CVS Builds | Yes | Yes
    3 | ftp.gwdg.de-suse | Packman Repository | Yes | Yes
    4 | repo-debug | openSUSE-13.1-Debug | Yes | Yes
    5 | repo-debug-update | openSUSE-13.1-Update-Debug | No | Yes
    6 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No | Yes
    7 | repo-non-oss | openSUSE-13.1-Non-Oss | Yes | Yes
    8 | repo-oss | openSUSE-13.1-Oss | Yes | Yes
    9 | repo-source | openSUSE-13.1-Source | Yes | Yes
    10 | repo-update | openSUSE-13.1-Update | Yes | Yes
    11 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Yes | Yes

    Sorry that the formatting isn't that good. Which of the repositories should I keep/make disabled?

    I also deselected Apper Monitor in the Configure Desktop -> System Administration -> Startup and Shutdown -> Service Manager. Is that also a recommended action to ensure this does not happen? It would be my preference that openSUSE 13.1 be able to update itself until I really learn more.

    Thanks again!
    Mike

  4. #4

    Default Re: openSUSE 13.1 repository hang

    On 07/01/2014 12:56 PM, mikejazzfan pecked at the keyboard and wrote:
    > kensch;2651899 Wrote:
    >> On 07/01/2014 09:56 AM, mikejazzfan pecked at the keyboard and wrote:
    >>> I am a very new person to Linux, so please forgive my ignorance. I've
    >>> been having a problem that the PackageKit is not allowing me to

    >> install
    >>> anything. I've followed the directions to kill PackageKit, and I've
    >>> also been following the directions on the thread linked below to bring
    >>> up zypper repositories. In zypper, I have two repositories:
    >>> "repo-debug" and "repo-debug-update". I am in a terminal window,

    >> logged
    >>> on as su, and did the following:
    >>>
    >>> zypper mr -da
    >>> zypper mr -e 1 (this is the repo-debug repository)
    >>> zypper up
    >>>
    >>> Works like a champ. Then I do this:
    >>>
    >>> zypper mr -e 2 (this is the repo-debug-update - no issues)
    >>> zypper up (hangs for very long periods of time - never finishes)
    >>>
    >>> I've seen about changing the location of the repository. I did a

    >> search
    >>> about possible repositories for the hanging one, and I've not found

    >> any
    >>> others.
    >>>
    >>> I would greatly appreciate any and all help. Please understand, that

    >> I
    >>> am very, very, very new to Linux, so please be patient with me.
    >>> Here's the link that I was following: http://tinyurl.com/qhx68eb
    >>>
    >>>

    >> You have all but the two "debug" repos (which you really do not need at
    >> this point in your linux knowledge) disabled. Show us the list of your
    >> repos (in code tags) using
    >>
    >> <code>
    >> zyyper lr
    >> </code/
    >>
    >> You will need to enable more repoes then the two "debug" repos. You can
    >> enable all of your repos using
    >>
    >> <code>
    >> zypper mr ea
    >> </code>
    >>
    >> Ken

    > Hi Ken,
    >
    > Thanks for your reply. I have since done some additional playing and
    > searching. I learned where in the GUI one can enable and add
    > repositories. As such, here is what I have:
    > # | Alias | Name
    > | Enabled | Refresh
    > ---+-----------------------------+-----------------------------------------+---------+--------
    > 1 | download.opensuse.org-Extra | openSUSE BuildService - KDE:Extra
    > | Yes | Yes
    > 2 | download.opensuse.org-Wine | openSUSE BuildService - Wine CVS
    > Builds | Yes | Yes
    > 3 | ftp.gwdg.de-suse | Packman Repository
    > | Yes | Yes
    > 4 | repo-debug | openSUSE-13.1-Debug
    > | Yes | Yes
    > 5 | repo-debug-update | openSUSE-13.1-Update-Debug
    > | No | Yes
    > 6 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss
    > | No | Yes
    > 7 | repo-non-oss | openSUSE-13.1-Non-Oss
    > | Yes | Yes
    > 8 | repo-oss | openSUSE-13.1-Oss
    > | Yes | Yes
    > 9 | repo-source | openSUSE-13.1-Source
    > | Yes | Yes
    > 10 | repo-update | openSUSE-13.1-Update
    > | Yes | Yes
    > 11 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss
    > | Yes | Yes
    >
    > Sorry that the formatting isn't that good. Which of the repositories
    > should I keep/make disabled?


    The only ones I would disable is 4, 5 and 6.
    As to the formatting there is a button near the bottom to add code tags.
    Since I use ThunderBird for NNTP connection I have to add them manually.
    If you still have trouble with adding the code tags perhaps someone else
    can help that uses the web version.

    >
    > I also deselected Apper Monitor in the Configure Desktop -> System
    > Administration -> Startup and Shutdown -> Service Manager. Is that also
    > a recommended action to ensure this does not happen? It would be my
    > preference that openSUSE 13.1 be able to update itself until I really
    > learn more.


    I understand but it is easy to do yourself. Use Yast-->Online Update to
    do the updates or use zypper up on the CLI.

    Ken

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,649

    Default Re: openSUSE 13.1 repository hang

    Apper by default just notifies you updates are available. Unless you tell it to update automatic. It then allows you to deselect any package you do not wish changed and will then install if told to.

    Nothing wrong with just using Yast or zypper to do updates but then you need to be religious about running them

  6. #6

    Default Re: openSUSE 13.1 repository hang

    An additional note:
    Quote Originally Posted by mikejazzfan View Post
    I also deselected Apper Monitor in the Configure Desktop -> System Administration -> Startup and Shutdown -> Service Manager. Is that also a recommended action to ensure this does not happen? It would be my preference that openSUSE 13.1 be able to update itself until I really learn more.
    Disabling "Apper Monitor" in Configure Desktop -> System Administration -> Startup and Shutdown -> Service Manager will disable Apper's automatic check for updates. So you will not get notified of updates any more.
    IIUYC, this is actually what you do _not_ want.

    Having Apper enabled does not give any problems however.
    You should be fine to use YaST and zypper as well.
    Of course you cannot use those at the same time as Apper, so they won't work when Apper is checking for or installing updates at the moment.
    It only checks for updates once a day though by default, so this shouldn't be a problem. And you will get a warning by YaST/zypper in that case, which will allow you to abort Apper (or packagekitd rather).

    You can easily set up automatic installation of upates in YaST->Online Update Configuration though (you might have to install the package yast2-online-update-configuration first to have this module). Then you could even uninstall Apper and your system should stay up to date by itself...

  7. #7
    Join Date
    Jul 2014
    Location
    Round Rock, TX
    Posts
    76

    Default Re: openSUSE 13.1 repository hang

    Thanks everyone for your feedback! I've re-enabled Apper, as I do want to be notified of updates. The one thing that is still bothering me is the fact that the one repository hung. I've disabled the debug repositories, as I agree that right now I have nothing to debug. I'm just learning how to use openSUSE, which I might add I much prefer over Mint (my brief experience there was not pleasant).

    Is there anything that can be done when a repository hangs like that, besides killing Packagekitd?

    Thanks again folks! You all are helping make this transition much more pleasant!

    Mike

  8. #8

    Default Re: openSUSE 13.1 repository hang

    Quote Originally Posted by mikejazzfan View Post
    Is there anything that can be done when a repository hangs like that, besides killing Packagekitd?
    That hang is absolutely not related to packagekitd at all.

    If packagekitd was busy, you would get a message by zypper about that, and be asked to abort packagekitd, as I already wrote.

    That one repo that hung was repo-debug-update, right?
    Probably that was caused by some bad mirror or something, but you don't need that one anyway.

    About a year ago some people complained about a similar problem (mostly about the update repo), removing the repo and adding it again seemed to help in at least some cases.

  9. #9
    Join Date
    Jul 2014
    Location
    Round Rock, TX
    Posts
    76

    Default Re: openSUSE 13.1 repository hang

    Quote Originally Posted by wolfi323 View Post
    That hang is absolutely not related to packagekitd at all.

    If packagekitd was busy, you would get a message by zypper about that, and be asked to abort packagekitd, as I already wrote.

    That one repo that hung was repo-debug-update, right?
    Probably that was caused by some bad mirror or something, but you don't need that one anyway.

    About a year ago some people complained about a similar problem (mostly about the update repo), removing the repo and adding it again seemed to help in at least some cases.
    Thanks again wolfi323. I missed that part about packagekitd, so my apologies about the redundant question. I think we can conclude this one as solved! You folks all rock!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •