Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: unable to install nvidia 3d driver via 1 click or by compiling (the hard way)

  1. #1

    Default unable to install nvidia 3d driver via 1 click or by compiling (the hard way)

    I have used opensuse for years and never had a problem with installing nvidia drivers until my experience with opensuse 13.1 64 bit. I did the update from 12.2. The stock driver did not like my nvidia geforce 6200 video card, so I had to open a second terminal because as soon as the gui loaded, the screen became useless. In a text terminal, I opened yast and installed the nvidia driver. Now I am trying to install the 3d driver. I tried 1 click install. I goes through the routine of installing fine, but no 3d. I then tried the hard way method of downloading the driver and running it in a root text terminal after booting to run level 3 (init 3). I made sure make, gcc compiler and kernel sources are installed. After running the installer, it stops and generates an error message. The following is a copy/paste from the end of the log file:

    /tmp/selfgz3299/NVIDIA-Linux-x86_64-304.88/kernel/nv-i2c.c: In function ‘nv_i2c_del_adapter’:
    /tmp/selfgz3299/NVIDIA-Linux-x86_64-304.88/kernel/nv-i2c.c:327:14: error: void value not ignored as it ought to be
    osstatus = i2c_del_adapter(pI2cAdapter);
    ^
    make[4]: *** [/tmp/selfgz3299/NVIDIA-Linux-x86_64-304.88/kernel/nv-i2c.o] Error 1
    make[3]: *** [_module_/tmp/selfgz3299/NVIDIA-Linux-x86_64-304.88/kernel] Error 2
    make[2]: *** [sub-make] Error 2
    NVIDIA: left KBUILD.
    nvidia.ko failed to build!
    make[1]: *** [module] Error 1
    make: *** [module] Error 2
    -> Error.
    ERROR: Unable to build the NVIDIA kernel module.
    ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

    Thank you in advance for your help.
    Jeff

  2. #2

    Default Re: unable to install nvidia 3d driver via 1 click or by compiling (the hard way)

    Quote Originally Posted by sailboat57 View Post
    I have used opensuse for years and never had a problem with installing nvidia drivers until my experience with opensuse 13.1 64 bit. I did the update from 12.2. The stock driver did not like my nvidia geforce 6200 video card, so I had to open a second terminal because as soon as the gui loaded, the screen became useless. In a text terminal, I opened yast and installed the nvidia driver. Now I am trying to install the 3d driver. I tried 1 click install. I goes through the routine of installing fine, but no 3d.
    Did you install the correct packages? (especially the correct kmp package for your kernel)
    x11-video-nvidiaG02, nvidia-gfxG02-kmp-desktop (or whatever), nvidia-computeG02

    The driver should work and support your card.

    Maybe setting NO_KMS_IN_INITRD="yes" and runing "sudo /sbin/mkinitrd" might help, although it shouldn't be necessary.
    To have an idea what could be wrong, the /var/log/Xorg.0.log would be helpful though.

    I then tried the hard way method of downloading the driver and running it in a root text terminal after booting to run level 3 (init 3). I made sure make, gcc compiler and kernel sources are installed. After running the installer, it stops and generates an error message. The following is a copy/paste from the end of the log file:

    /tmp/selfgz3299/NVIDIA-Linux-x86_64-304.88/kernel/nv-i2c.c: In function ‘nv_i2c_del_adapter’:
    /tmp/selfgz3299/NVIDIA-Linux-x86_64-304.88/kernel/nv-i2c.c:327:14: error: void value not ignored as it ought to be
    osstatus = i2c_del_adapter(pI2cAdapter);
    ^
    make[4]: *** [/tmp/selfgz3299/NVIDIA-Linux-x86_64-304.88/kernel/nv-i2c.o] Error 1
    make[3]: *** [_module_/tmp/selfgz3299/NVIDIA-Linux-x86_64-304.88/kernel] Error 2
    make[2]: *** [sub-make] Error 2
    NVIDIA: left KBUILD.
    nvidia.ko failed to build!
    make[1]: *** [module] Error 1
    make: *** [module] Error 2
    -> Error.
    ERROR: Unable to build the NVIDIA kernel module.
    ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.
    The 304.88 driver is too old and doesn't work with 13.1's kernel 3.11.

    Download and install the latest version 304.121. But that's the same version as available in the repo.
    So if that driver version does not work with your card, you're out of luck I'm afraid.

    You could try the even older G01 driver (173.14.39) in that case though.
    This should also support your card.
    If you install that driver from the repo and it doesn't work, you should do that "NO_KMS_IN_INITRD" trick though.

  3. #3

    Default Re: unable to install nvidia 3d driver via 1 click or by compiling (the hard way)

    I have to past the xorg.0.log file in two sections due to being rejected as too long. This is the first half:

    [ 44.506]
    This is a pre-release version of the X server from The X.Org Foundation.
    It is not supported in any way.
    Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
    Select the "xorg" product for bugs you find in this release.
    Before reporting bugs in pre-release versions please check the
    latest version in the X.Org Foundation git repository.
    See http://wiki.x.org/wiki/GitPage for git access instructions.
    [ 44.506]
    X.Org X Server 1.14.3.901 (1.14.4 RC 1)
    Release Date: 2013-10-26
    [ 44.506] X Protocol Version 11, Revision 0
    [ 44.506] Build Operating System: openSUSE SUSE LINUX
    [ 44.506] Current Operating System: Linux linux-cl7f 3.11.10-17-desktop #1 SMP PREEMPT Mon Jun 16 15:28:13 UTC 2014 (fba7c1f) x86_64
    [ 44.506] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.11.10-17-desktop root=UUID=bf37f63e-6b53-49b8-9489-6c4016495e38 resume=/dev/disk/by-id/ata-ST3320310CS_9TX3ATVX-part5 splash=silent quiet showopts
    [ 44.506] Build Date: 17 April 2014 05:37:34AM
    [ 44.506]
    [ 44.506] Current version of pixman: 0.30.2
    [ 44.506] Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    [ 44.506] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 44.506] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jun 28 16:41:09 2014
    [ 44.507] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [ 44.507] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [ 44.507] (==) No Layout section. Using the first Screen section.
    [ 44.507] (==) No screen section available. Using defaults.
    [ 44.507] (**) |-->Screen "Default Screen Section" (0)
    [ 44.507] (**) | |-->Monitor "<default monitor>"
    [ 44.508] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
    [ 44.508] (==) Automatically adding devices
    [ 44.508] (==) Automatically enabling devices
    [ 44.508] (==) Automatically adding GPU devices
    [ 44.508] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    [ 44.508] Entry deleted from font path.
    [ 44.508] (==) FontPath set to:
    /usr/share/fonts/misc:unscaled,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/ghostscript/,
    /usr/share/fonts/cyrillic:unscaled,
    /usr/share/fonts/truetype/,
    built-ins
    [ 44.508] (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
    [ 44.508] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
    [ 44.508] (II) Loader magic: 0x803c20
    [ 44.508] (II) Module ABI versions:
    [ 44.508] X.Org ANSI C Emulation: 0.4
    [ 44.508] X.Org Video Driver: 14.1
    [ 44.508] X.Org XInput driver : 19.1
    [ 44.508] X.Org Server Extension : 7.0
    [ 44.509] (--) PCI:*(0:1:0:0) 10de:0161:1682:2142 rev 161, Mem @ 0xfa000000/16777216, 0xd0000000/268435456, 0xfb000000/16777216, BIOS @ 0x????????/131072
    [ 44.509] Initializing built-in extension Generic Event Extension
    [ 44.509] Initializing built-in extension SHAPE
    [ 44.509] Initializing built-in extension MIT-SHM
    [ 44.509] Initializing built-in extension XInputExtension
    [ 44.509] Initializing built-in extension XTEST
    [ 44.509] Initializing built-in extension BIG-REQUESTS
    [ 44.509] Initializing built-in extension SYNC
    [ 44.509] Initializing built-in extension XKEYBOARD
    [ 44.509] Initializing built-in extension XC-MISC
    [ 44.509] Initializing built-in extension SECURITY
    [ 44.509] Initializing built-in extension XINERAMA
    [ 44.509] Initializing built-in extension XFIXES
    [ 44.512] Initializing built-in extension RENDER
    [ 44.512] Initializing built-in extension RANDR
    [ 44.512] Initializing built-in extension COMPOSITE
    [ 44.512] Initializing built-in extension DAMAGE
    [ 44.512] Initializing built-in extension MIT-SCREEN-SAVER
    [ 44.512] Initializing built-in extension DOUBLE-BUFFER
    [ 44.512] Initializing built-in extension RECORD
    [ 44.512] Initializing built-in extension DPMS
    [ 44.512] Initializing built-in extension X-Resource
    [ 44.512] Initializing built-in extension XVideo
    [ 44.512] Initializing built-in extension XVideo-MotionCompensation
    [ 44.512] Initializing built-in extension XFree86-VidModeExtension
    [ 44.512] Initializing built-in extension XFree86-DGA
    [ 44.512] Initializing built-in extension XFree86-DRI
    [ 44.512] Initializing built-in extension DRI2
    [ 44.512] (II) "glx" will be loaded by default.
    [ 44.512] (II) LoadModule: "dri2"
    [ 44.512] (II) Module "dri2" already built-in
    [ 44.512] (II) LoadModule: "glamoregl"
    [ 44.564] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
    [ 45.361] (EE) Failed to load /usr/lib64/xorg/modules/libglamoregl.so: /usr/lib64/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context
    [ 45.361] (II) UnloadModule: "glamoregl"
    [ 45.361] (II) Unloading glamoregl
    [ 45.361] (EE) Failed to load module "glamoregl" (loader failed, 7)
    [ 45.361] (II) LoadModule: "glx"
    [ 45.362] (II) Loading /usr/lib64/xorg/modules/updates/extensions/libglx.so
    [ 45.628] (II) Module glx: vendor="NVIDIA Corporation"
    [ 45.628] compiled for 4.0.2, module version = 1.0.0
    [ 45.628] Module class: X.Org Server Extension
    [ 45.628] (II) NVIDIA GLX Module 304.121 Tue Mar 4 20:08:25 PST 2014
    [ 45.628] Loading extension GLX
    [ 45.628] (==) Matched nvidia as autoconfigured driver 0
    [ 45.628] (==) Matched nouveau as autoconfigured driver 1
    [ 45.628] (==) Matched nv as autoconfigured driver 2
    [ 45.628] (==) Matched modesetting as autoconfigured driver 3
    [ 45.628] (==) Matched fbdev as autoconfigured driver 4
    [ 45.628] (==) Matched vesa as autoconfigured driver 5
    [ 45.628] (==) Assigned the driver to the xf86ConfigLayout
    [ 45.628] (II) LoadModule: "nvidia"
    [ 45.628] (II) Loading /usr/lib64/xorg/modules/updates/drivers/nvidia_drv.so
    [ 45.737] (II) Module nvidia: vendor="NVIDIA Corporation"
    [ 45.737] compiled for 4.0.2, module version = 1.0.0
    [ 45.737] Module class: X.Org Video Driver
    [ 45.757] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
    [ 45.758] (EE) NVIDIA: system's kernel log for additional error messages.
    [ 45.758] (II) UnloadModule: "nvidia"
    [ 45.758] (II) Unloading nvidia
    [ 45.758] (EE) Failed to load module "nvidia" (module-specific error, 0)
    [ 45.758] (II) LoadModule: "nouveau"
    [ 45.758] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
    [ 45.760] (II) Module nouveau: vendor="X.Org Foundation"
    [ 45.760] compiled for 1.14.3, module version = 1.0.9
    [ 45.760] Module class: X.Org Video Driver
    [ 45.760] ABI class: X.Org Video Driver, version 14.1
    [ 45.760] (II) LoadModule: "nv"
    [ 45.761] (II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
    [ 45.761] (II) Module nv: vendor="X.Org Foundation"
    [ 45.761] compiled for 1.14.3, module version = 2.1.20
    [ 45.761] Module class: X.Org Video Driver
    [ 45.761] ABI class: X.Org Video Driver, version 14.1
    [ 45.761] (II) LoadModule: "modesetting"
    [ 45.763] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
    [ 45.764] (II) Module modesetting: vendor="X.Org Foundation"
    [ 45.764] compiled for 1.14.3.901, module version = 0.8.0
    [ 45.764] Module class: X.Org Video Driver
    [ 45.764] ABI class: X.Org Video Driver, version 14.1
    [ 45.764] (II) LoadModule: "fbdev"
    [ 45.766] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
    [ 45.766] (II) Module fbdev: vendor="X.Org Foundation"
    [ 45.766] compiled for 1.14.3, module version = 0.4.3
    [ 45.766] Module class: X.Org Video Driver
    [ 45.766] ABI class: X.Org Video Driver, version 14.1
    [ 45.766] (II) LoadModule: "vesa"
    [ 45.767] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
    [ 45.767] (II) Module vesa: vendor="X.Org Foundation"
    [ 45.767] compiled for 1.14.3, module version = 2.3.3
    [ 45.767] Module class: X.Org Video Driver
    [ 45.767] ABI class: X.Org Video Driver, version 14.1
    [ 45.767] (II) NOUVEAU driver
    [ 45.767] (II) NOUVEAU driver for NVIDIA chipset families :
    [ 45.767] RIVA TNT (NV04)
    [ 45.767] RIVA TNT2 (NV05)
    [ 45.767] GeForce 256 (NV10)
    [ 45.767] GeForce 2 (NV11, NV15)
    [ 45.767] GeForce 4MX (NV17, NV18)
    [ 45.767] GeForce 3 (NV20)
    [ 45.767] GeForce 4Ti (NV25, NV28)
    [ 45.767] GeForce FX (NV3x)
    [ 45.767] GeForce 6 (NV4x)
    [ 45.767] GeForce 7 (G7x)
    [ 45.767] GeForce 8 (G8x)
    [ 45.767] GeForce GTX 200 (NVA0)
    [ 45.767] GeForce GTX 400 (NVC0)
    [ 45.767] (II) NOUVEAU driver
    [ 45.767] (II) NOUVEAU driver for NVIDIA chipset families :

  4. #4

    Default Re: unable to install nvidia 3d driver via 1 click or by compiling (the hard way)

    This is the second half of the log file:

    [ 45.767] RIVA TNT (NV04)
    [ 45.767] RIVA TNT2 (NV05)
    [ 45.767] GeForce 256 (NV10)
    [ 45.767] GeForce 2 (NV11, NV15)
    [ 45.768] GeForce 4MX (NV17, NV18)
    [ 45.768] GeForce 3 (NV20)
    [ 45.769] GeForce 4Ti (NV25, NV28)
    [ 45.769] GeForce FX (NV3x)
    [ 45.769] GeForce 6 (NV4x)
    [ 45.769] GeForce 7 (G7x)
    [ 45.769] GeForce 8 (G8x)
    [ 45.769] GeForce GTX 200 (NVA0)
    [ 45.769] GeForce GTX 400 (NVC0)
    [ 45.769] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [ 45.769] (II) FBDEV: driver for framebuffer: fbdev
    [ 45.769] (II) VESA: driver for VESA chipsets: vesa
    [ 45.769] (++) using VT number 7

    [ 45.769] (EE) [drm] KMS not enabled
    [ 45.769] (EE) [drm] KMS not enabled
    [ 45.769] (EE) open /dev/dri/card0: No such file or directory
    [ 45.769] (WW) Falling back to old probe method for modesetting
    [ 45.769] (EE) open /dev/dri/card0: No such file or directory
    [ 45.769] (II) Loading sub module "fbdevhw"
    [ 45.769] (II) LoadModule: "fbdevhw"
    [ 45.776] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
    [ 45.776] (II) Module fbdevhw: vendor="X.Org Foundation"
    [ 45.776] compiled for 1.14.3.901, module version = 0.0.2
    [ 45.776] ABI class: X.Org Video Driver, version 14.1
    [ 45.776] (**) FBDEV(1): claimed PCI slot 1@0:0:0
    [ 45.776] (II) FBDEV(1): using default device
    [ 45.777] (WW) Falling back to old probe method for vesa
    [ 45.777] (EE) Screen 0 deleted because of no matching config section.
    [ 45.777] (II) UnloadModule: "modesetting"
    [ 45.777] (II) FBDEV(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
    [ 45.777] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
    [ 45.777] (==) FBDEV(0): RGB weight 888
    [ 45.777] (==) FBDEV(0): Default visual is TrueColor
    [ 45.777] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
    [ 45.777] (II) FBDEV(0): hardware: VESA VGA (video memory: 5120kB)
    [ 45.777] (II) FBDEV(0): checking modes against framebuffer device...
    [ 45.777] (II) FBDEV(0): checking modes against monitor...
    [ 45.777] (--) FBDEV(0): Virtual size is 1280x1024 (pitch 1280)
    [ 45.777] (**) FBDEV(0): Built-in mode "current": 131.1 MHz, 80.3 kHz, 76.6 Hz
    [ 45.777] (II) FBDEV(0): Modeline "current"x0.0 131.09 1280 1312 1472 1632 1024 1028 1032 1048 -hsync -vsync -csync (80.3 kHz b)
    [ 45.777] (==) FBDEV(0): DPI set to (96, 96)
    [ 45.777] (II) Loading sub module "fb"
    [ 45.777] (II) LoadModule: "fb"
    [ 45.777] (II) Loading /usr/lib64/xorg/modules/libfb.so
    [ 45.777] (II) Module fb: vendor="X.Org Foundation"
    [ 45.777] compiled for 1.14.3.901, module version = 1.0.0
    [ 45.777] ABI class: X.Org ANSI C Emulation, version 0.4
    [ 45.777] (**) FBDEV(0): using shadow framebuffer
    [ 45.777] (II) Loading sub module "shadow"
    [ 45.777] (II) LoadModule: "shadow"
    [ 45.778] (II) Loading /usr/lib64/xorg/modules/libshadow.so
    [ 45.778] (II) Module shadow: vendor="X.Org Foundation"
    [ 45.778] compiled for 1.14.3.901, module version = 1.1.0
    [ 45.778] ABI class: X.Org ANSI C Emulation, version 0.4
    [ 45.778] (II) UnloadModule: "vesa"
    [ 45.778] (II) Unloading vesa
    [ 45.778] (==) Depth 24 pixmap format is 32 bpp
    [ 45.778] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    [ 45.778] (==) FBDEV(0): Backing store disabled
    [ 45.779] (==) FBDEV(0): DPMS enabled
    [ 45.779] (==) RandR enabled
    [ 45.825] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
    [ 46.076] (II) config/udev: Adding input device Power Button (/dev/input/event3)
    [ 46.076] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [ 46.076] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [ 46.076] (**) Power Button: Applying InputClass "LocalKeyboard"
    [ 46.076] (II) LoadModule: "evdev"
    [ 46.076] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
    [ 46.077] (II) Module evdev: vendor="X.Org Foundation"
    [ 46.077] compiled for 1.14.3, module version = 2.8.2
    [ 46.077] Module class: X.Org XInput Driver
    [ 46.077] ABI class: X.Org XInput driver, version 19.1
    [ 46.077] (II) Using input driver 'evdev' for 'Power Button'
    [ 46.077] (**) Power Button: always reports core events
    [ 46.077] (**) evdev: Power Button: Device: "/dev/input/event3"
    [ 46.077] (--) evdev: Power Button: Vendor 0 Product 0x1
    [ 46.077] (--) evdev: Power Button: Found keys
    [ 46.077] (II) evdev: Power Button: Configuring as keyboard
    [ 46.077] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3/event3"
    [ 46.077] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
    [ 46.077] (**) Option "xkb_rules" "evdev"
    [ 46.077] (**) Option "xkb_model" "pc104"
    [ 46.077] (**) Option "xkb_layout" "us"
    [ 46.118] (II) config/udev: Adding input device Power Button (/dev/input/event2)
    [ 46.118] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [ 46.118] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [ 46.118] (**) Power Button: Applying InputClass "LocalKeyboard"
    [ 46.118] (II) Using input driver 'evdev' for 'Power Button'
    [ 46.118] (**) Power Button: always reports core events
    [ 46.118] (**) evdev: Power Button: Device: "/dev/input/event2"
    [ 46.118] (--) evdev: Power Button: Vendor 0 Product 0x1
    [ 46.118] (--) evdev: Power Button: Found keys
    [ 46.118] (II) evdev: Power Button: Configuring as keyboard
    [ 46.118] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input2/event2"
    [ 46.118] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
    [ 46.118] (**) Option "xkb_rules" "evdev"
    [ 46.118] (**) Option "xkb_model" "pc104"
    [ 46.118] (**) Option "xkb_layout" "us"
    [ 46.119] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
    [ 46.119] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
    [ 46.119] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
    [ 46.119] (**) AT Translated Set 2 keyboard: Applying InputClass "LocalKeyboard"
    [ 46.119] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
    [ 46.119] (**) AT Translated Set 2 keyboard: always reports core events
    [ 46.119] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
    [ 46.119] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
    [ 46.119] (--) evdev: AT Translated Set 2 keyboard: Found keys
    [ 46.119] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
    [ 46.119] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
    [ 46.119] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 8)
    [ 46.119] (**) Option "xkb_rules" "evdev"
    [ 46.119] (**) Option "xkb_model" "pc104"
    [ 46.119] (**) Option "xkb_layout" "us"
    [ 46.120] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/event1)
    [ 46.120] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "evdev pointer catchall"
    [ 46.120] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "evdev pointer catchall"
    [ 46.120] (II) Using input driver 'evdev' for 'ImExPS/2 Generic Explorer Mouse'
    [ 46.120] (**) ImExPS/2 Generic Explorer Mouse: always reports core events
    [ 46.120] (**) evdev: ImExPS/2 Generic Explorer Mouse: Device: "/dev/input/event1"
    [ 46.120] (--) evdev: ImExPS/2 Generic Explorer Mouse: Vendor 0x2 Product 0x6
    [ 46.120] (--) evdev: ImExPS/2 Generic Explorer Mouse: Found 9 mouse buttons
    [ 46.120] (--) evdev: ImExPS/2 Generic Explorer Mouse: Found scroll wheel(s)
    [ 46.120] (--) evdev: ImExPS/2 Generic Explorer Mouse: Found relative axes
    [ 46.120] (--) evdev: ImExPS/2 Generic Explorer Mouse: Found x and y relative axes
    [ 46.120] (II) evdev: ImExPS/2 Generic Explorer Mouse: Configuring as mouse
    [ 46.120] (II) evdev: ImExPS/2 Generic Explorer Mouse: Adding scrollwheel support
    [ 46.120] (**) evdev: ImExPS/2 Generic Explorer Mouse: YAxisMapping: buttons 4 and 5
    [ 46.120] (**) evdev: ImExPS/2 Generic Explorer Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    [ 46.120] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input1/event1"
    [ 46.120] (II) XINPUT: Adding extended input device "ImExPS/2 Generic Explorer Mouse" (type: MOUSE, id 9)
    [ 46.120] (II) evdev: ImExPS/2 Generic Explorer Mouse: initialized for relative axes.
    [ 46.120] (**) ImExPS/2 Generic Explorer Mouse: (accel) keeping acceleration scheme 1
    [ 46.120] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration profile 0
    [ 46.121] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration factor: 2.000
    [ 46.121] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration threshold: 4
    [ 46.121] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/mouse0)
    [ 46.121] (II) No input driver specified, ignoring this device.
    [ 46.121] (II) This device may have been added with another device file.
    [ 46.121] (II) config/udev: Adding input device PC Speaker (/dev/input/event4)
    [ 46.121] (II) No input driver specified, ignoring this device.
    [ 46.121] (II) This device may have been added with another device file.
    [ 46.126] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    [ 58.827] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    [ 58.827] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    [ 58.982] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    [ 1797.828] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    [ 1797.828] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    [ 1797.831] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    [ 2235.684] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    [ 2235.684] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)

  5. #5

    Default Re: unable to install nvidia 3d driver via 1 click or by compiling (the hard way)

    Well, you're not using the nvidia driver. Reason:
    Quote Originally Posted by sailboat57 View Post
    [ 45.757] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
    [ 45.758] (EE) NVIDIA: system's kernel log for additional error messages.
    [ 45.758] (II) UnloadModule: "nvidia"
    [ 45.758] (II) Unloading nvidia
    [ 45.758] (EE) Failed to load module "nvidia" (module-specific error, 0)
    Is this now with the packages from the repo, or with the .run installer?

    In the first case, please post a list of all nvidia and kernel packages you have installed:
    Code:
    rpm -qa | egrep "(kernel|nvidia)"
    Check that the nvidia kernel module is there:
    Code:
    find /lib/modules -name nvidia.ko
    This should hopefully tell why the module cannot be loaded:
    Code:
    dmesg | grep -iA5 nvidia
    You might try to set NO_KMS_IN_INITRD="yes" in /etc/sysconfig/kernel and run "sudo /sbin/mkinitrd" as mentioned. Maybe the nouveau module is being loaded by the initrd already (by plymouth f.e.) which would prevent nvidia from being loaded.

  6. #6

    Default Re: unable to install nvidia 3d driver via 1 click or by compiling (the hard way)

    I have the copy/paste as per your request:

    jeffrey@linux-cl7f:~> rpm -qa | egrep "(kernel|nvidia)"
    kernel-devel-3.11.10-17.2.noarch
    kernel-syms-3.11.10-17.1.x86_64
    kernel-default-devel-3.11.10-17.2.x86_64
    kernel-desktop-3.11.10-17.2.x86_64
    nvidia-computeG02-304.121-32.1.x86_64
    x11-video-nvidiaG02-304.121-32.1.x86_64
    nvidia-gfxG02-kmp-default-304.119_k3.11.6_4-33.1.x86_64
    patterns-openSUSE-devel_kernel-13.1-13.6.1.x86_64
    kernel-desktop-devel-3.11.10-17.2.x86_64
    kernel-desktop-devel-3.11.10-11.1.x86_64
    kernel-source-3.11.10-11.1.noarch
    kernel-devel-3.11.10-11.1.noarch
    nvidia-gfxG02-kmp-default-304.121_k3.11.6_4-31.1.x86_64
    kernel-source-3.11.10-17.2.noarch
    kernel-xen-devel-3.11.10-17.2.x86_64
    kernel-desktop-3.11.10-11.1.x86_64
    kernel-default-devel-3.11.10-11.1.x86_64
    kernel-firmware-20130714git-2.17.1.noarch
    jeffrey@linux-cl7f:~>


    jeffrey@linux-cl7f:~> find /lib/modules -name nvidia.ko
    /lib/modules/3.11.6-4-default/updates/nvidia.ko
    jeffrey@linux-cl7f:~>

    jeffrey@linux-cl7f:~> dmesg | grep -iA5 nvidia
    jeffrey@linux-cl7f:~>


    I also did a kernel update and kernel source update via yast prior to this copy/paste.

  7. #7

    Default Re: unable to install nvidia 3d driver via 1 click or by compiling (the hard way)

    Quote Originally Posted by sailboat57 View Post
    kernel-desktop-3.11.10-17.2.x86_64
    nvidia-gfxG02-kmp-default-304.121_k3.11.6_4-31.1.x86_64
    kernel-desktop-3.11.10-11.1.x86_64


    jeffrey@linux-cl7f:~> find /lib/modules -name nvidia.ko
    /lib/modules/3.11.6-4-default/updates/nvidia.ko
    jeffrey@linux-cl7f:~>
    You only have kernel-desktop installed, but the kmp for kernel-default.

    Do this to install the correct one:
    Code:
    sudo zypper in nvidia-gfxG02-kmp-desktop -nvidia-gfxG02-kmp-default

  8. #8

    Default Re: unable to install nvidia 3d driver via 1 click or by compiling (the hard way)

    I used the sudo zypper command. All went well. It recommended I run zypper ps to check for running programs that use the deleted files. This is my copy/paste from the shell:

    linux-cl7f:~ # zypper ps
    The following running processes use deleted files:

    PID | PPID | UID | Login | Command | Service | Files
    ----+------+-----+-------+---------------+---------+----------------------------------------------------
    254 | 1 | 0 | root | systemd-udevd | | /lib/modules/3.11.10-17-desktop/modules.builtin.bin
    | | | | | | /lib/modules/3.11.10-17-desktop/modules.alias.bin
    | | | | | | /lib/modules/3.11.10-17-desktop/modules.dep.bin
    | | | | | | /lib/modules/3.11.10-17-desktop/modules.symbols.bin

    You may wish to restart these processes.
    See 'man zypper' for information about the meaning of values in the above table.


    I also need to know if a system reboot is going to solve the driver issue or do I need to reboot in init 3 and configure x window? (my next step?)

  9. #9

    Default Re: unable to install nvidia 3d driver via 1 click or by compiling (the hard way)

    Quote Originally Posted by sailboat57 View Post
    I used the sudo zypper command. All went well. It recommended I run zypper ps to check for running programs that use the deleted files. This is my copy/paste from the shell:

    linux-cl7f:~ # zypper ps
    The following running processes use deleted files:

    PID | PPID | UID | Login | Command | Service | Files
    ----+------+-----+-------+---------------+---------+----------------------------------------------------
    254 | 1 | 0 | root | systemd-udevd | | /lib/modules/3.11.10-17-desktop/modules.builtin.bin
    | | | | | | /lib/modules/3.11.10-17-desktop/modules.alias.bin
    | | | | | | /lib/modules/3.11.10-17-desktop/modules.dep.bin
    | | | | | | /lib/modules/3.11.10-17-desktop/modules.symbols.bin

    You may wish to restart these processes.
    See 'man zypper' for information about the meaning of values in the above table.
    Hm, I never saw those particular files in a zypper "file in use" warning.
    Anyway, zypper just wants to tell you that some running processes (systemd-udev in this case) use files that have been changed on disk. So you should restart those processes so that they get aware of the changes and/or use the changed files. Or reboot, which you need to do anyway to use the nvidia driver.

    I also need to know if a system reboot is going to solve the driver issue or do I need to reboot in init 3 and configure x window? (my next step?)
    You don't have to configure anything.
    Just reboot (to runlevel 5/graphical.target) and the nvidia driver should be used.

    If not, please post the Xorg.0.log as before, and/or try with NO_KMS_IN_INITRD="yes" as mentioned.
    For posting the log, better use a sharing/pasting site like http://susepaste.org and only post the link here.
    Last edited by wolfi323; 29-Jun-2014 at 12:46.

  10. #10

    Default Re: unable to install nvidia 3d driver via 1 click or by compiling (the hard way)

    The 3d driver works! Thank you for your help! I learned from the experience, but not sure what the difference between the old and new drivers was that would cause the issue with the video card.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •