Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Localization & Clock Not Displaying Properly Questions...

  1. #11

    Default Re: Localization & Clock Not Displaying Properly Questions...

    Quote Originally Posted by holden87 View Post
    Oh my, yes, sl_SI.utf8 worked. All correct now.
    Well, actually "sl_SI.UTF-8" should work as well.
    But your error message talked about "sl_SI-UTF.8" (notice that the '-' and '.' are swapped)...

    Any way, any idea about the clock? thanks!
    Yes, what I wrote already.
    Is the default set to "local time" in the clock's settings?
    Is the correct country set in KDE's Locale settings?

    What does the clock show when you hover over it with the mouse?

    Does "date" show the correct time now?
    If not, adjust the time (in YaST->System->Date and Time f.e.). Does it work for KDE's clock then as well?

  2. #12
    Join Date
    Nov 2013
    Location
    Ljubljana, Slovenia
    Posts
    465

    Default Re: Localization & Clock Not Displaying Properly Questions...

    Hey.

    Now I won't be much of a help. I meddled around with the clock settings, not sure what i did, but it works now.

  3. #13
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Localization & Clock Not Displaying Properly Questions...

    On 2014-06-26 12:46, holden87 wrote:
    >
    > Code:
    > --------------------
    > nenad@openSUSE:~> date
    > Thu Jun 26 14:40:57 CEST 2014
    > nenad@openSUSE:~> date --utc
    > Thu Jun 26 12:41:17 UTC 2014


    > nenad@openSUSE:~> su -
    > Password:
    > -bash: warning: setlocale: LC_TIME: cannot change locale (sl_SI-UTF.8): No such file or directory
    >


    > openSUSE:~ # hwclock --debug
    > hwclock from util-linux 2.23.2


    > Hardware clock is on UTC time
    > Assuming hardware clock is kept in UTC time.
    > Waiting for clock tick...
    >
    > ...got clock tick
    > Time read from Hardware Clock: 2014/06/26 12:43:19
    > Hw clock time : 2014/06/26 12:43:19 = 1403786599 seconds since 1969
    > Thu Jun 26 14:43:19 2014 -0.531985 seconds


    > openSUSE:~ # date
    > Thu Jun 26 14:44:08 CEST 2014


    > openSUSE:~ # date --utc
    > Thu Jun 26 12:44:31 UTC 2014
    >
    >
    > --------------------


    Well, both root and user get the same clock time, and the local to utc
    time difference is correct, 2 hours. Cmos clock is consistent with the
    settings.

    What was the clock on the kitchen wall showing? 12:44?

    My guess at this point is that you simply have set the time wrong on the
    computer and that you have to correct it, simple as that.

    DO NOT SET IT UP USING KDE.

    Use YaST - I don't remember this moment if you can "write" the hour in
    there. If not, use the command "date" to set the hour, on the command
    line, as root. "man date" says how. (1)

    Once done, run:

    Code:
    rm /etc/adjtime
    hwclock --systohc --utc
    hwclock --debug
    date
    The last two commands should sow the correct time and date.


    (1) Alternative:

    Code:
    rcntp ntptimeset

    .... assuming there are some time servers defined in /etc/ntp.conf, like
    this:

    Code:
    server 0.pool.ntp.org
    server 1.pool.ntp.org
    server 2.pool.ntp.org
    server 3.pool.ntp.org
    and that Internet works.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  4. #14
    Join Date
    Nov 2013
    Location
    Ljubljana, Slovenia
    Posts
    465

    Default Re: Localization & Clock Not Displaying Properly Questions...


    Code:
    rm /etc/adjtime
    hwclock --systohc --utc
    hwclock --debug
    date
    Hey Robin. The problem reappeared upon boot, but this fixed it (and YaST).

    Thank you once again!

  5. #15
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Localization & Clock Not Displaying Properly Questions...

    On 2014-06-27 08:26, holden87 wrote:

    > Code:
    > --------------------
    > > >

    > > rm /etc/adjtime
    > > hwclock --systohc --utc
    > > hwclock --debug
    > > date
    > >

    > --------------------


    >
    > Hey Robin. The problem reappeared upon boot, but this fixed it (and
    > YaST).


    Ha!

    I knew :-)

    You are not the first one to have that problem.

    The "/etc/adjtime" keeps track of the adjustment that has to be done on
    boot. If you adjust the clock manually one hour forward, it may think
    that it has to speed up the clock one hour per day (quite incorrect
    explanation, but approximate enough). So delete the file, then create it
    again blank (second line). Then verify (next two lines).

    > Thank you once again!


    Welcome.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •