Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

  1. #1
    Join Date
    Dec 2008
    Location
    Chicago
    Posts
    12

    Default How do I set the CPU Frequency Governor In Opensuse 13.1 ?

    In Opensuse 13.1, How do I set the CPU Frequency Governor to 'performance' ?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,824
    Blog Entries
    15

    Default Re: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

    Hi
    As root user;
    Code:
    zypper in cpupower
    cpupower --cpu 0-n frequency-set -g performance
    Where n is the last core (if you want to set to all cores).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Dec 2008
    Location
    Chicago
    Posts
    12

    Default Re: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

    thanks,

    I should have said it is just a single core athlon 64 2800 - an old one

    thanks again

  4. #4
    Join Date
    Dec 2008
    Location
    Chicago
    Posts
    12

    Default Re: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

    so i did...

    Code:
    cpupower --cpu 0 frequency-set -g performance
    does that set it permanently? (it's a desktop, only used occasionally.)

    or will I have to do that every time I login?
    I'ld like it to be set just the once, and have it just that way

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,824
    Blog Entries
    15

    Default Re: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

    Quote Originally Posted by TakeIT2 View Post
    so i did...

    Code:
    cpupower --cpu 0 frequency-set -g performance
    does that set it permanently? (it's a desktop, only used occasionally.)

    or will I have to do that every time I login?
    I'ld like it to be set just the once, and have it just that way
    Hi
    It can be set with the pm-profiler command;
    Code:
    pm-profiler -e low_latency
    Run the pm-profiler command by itself to see the options etc.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6
    Join Date
    Dec 2008
    Location
    Chicago
    Posts
    12

    Default Re: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

    this good stuff, and I don't want to be a pest, how do I confirm that governor is running now?
    Proudly using SuSE LINUX since Version 6.3
    Now using OpenSuSE x86_64/12.2/KDE & 3x x86_64/13.1/KDE

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,824
    Blog Entries
    15

    Default Re: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

    Quote Originally Posted by TakeIT2 View Post
    this good stuff, and I don't want to be a pest, how do I confirm that governor is running now?
    Hi
    Run the command;
    Code:
    cpupower frequency-info
    This will show the current policy is performance.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8
    Join Date
    Dec 2008
    Location
    Chicago
    Posts
    12

    Thumbs up Re: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

    ok, so I rebooted then ran the check and got...

    Code:
    takeit2@neo:~> cpupower frequency-info
    analyzing CPU 0:
      driver: powernow-k8
      CPUs which run at the same hardware frequency: 0
      CPUs which need to have their frequency coordinated by software: 0
      maximum transition latency: 109 us.
      hardware limits: 1000 MHz - 1.80 GHz
      available frequency steps: 1.80 GHz, 1000 MHz
      available cpufreq governors: ondemand, performance
      current policy: frequency should be within 1000 MHz and 1.80 GHz.
                      The governor "ondemand" may decide which speed to use
                      within this range.
      current CPU frequency is 1000 MHz.
      boost state support:
        Supported: no
        Active: no
    takeit2@neo:~>
    but I kinda knew that would be the case. I have been through some parts of this over the past 2 weeks. I think you have to have pm-profiler running first. I've not tried undoing it all and testing it.

    But what did work this time after starting pm-profiler in the old yast module "System Services (Runlevel)" was to go to the Yast module "/etc/sysconfig/ Editor" navigating to Hardware/Power/PM_Profiler_Profile and adding low_lantency there, saving, then rebooted.

    I then checked, and it worked...

    Code:
    takeit2@neo:~> cpupower frequency-info
    analyzing CPU 0:
      driver: powernow-k8
      CPUs which run at the same hardware frequency: 0
      CPUs which need to have their frequency coordinated by software: 0
      maximum transition latency: 109 us.
      hardware limits: 1000 MHz - 1.80 GHz
      available frequency steps: 1.80 GHz, 1000 MHz
      available cpufreq governors: ondemand, performance
      current policy: frequency should be within 1000 MHz and 1.80 GHz.
                      The governor "performance" may decide which speed to use
                      within this range.
      current CPU frequency is 1.80 GHz.
      boost state support:
        Supported: no
        Active: no
    takeit2@neo:~>
    Thanks for your help Malcome, I'm not good at all with the CL tools
    Proudly using SuSE LINUX since Version 6.3
    Now using OpenSuSE x86_64/12.2/KDE & 3x x86_64/13.1/KDE

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,824
    Blog Entries
    15

    Default Re: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

    On Mon 23 Jun 2014 11:26:02 PM CDT, TakeIT2 wrote:


    ok, so I rebooted then ran the check and got...


    Code:
    --------------------
    takeit2@neo:~> cpupower frequency-info
    analyzing CPU 0:
    driver: powernow-k8
    CPUs which run at the same hardware frequency: 0
    CPUs which need to have their frequency coordinated by software: 0
    maximum transition latency: 109 us.
    hardware limits: 1000 MHz - 1.80 GHz
    available frequency steps: 1.80 GHz, 1000 MHz
    available cpufreq governors: ondemand, performance
    current policy: frequency should be within 1000 MHz and 1.80 GHz.
    The governor "ondemand" may decide which speed to use
    within this range.
    current CPU frequency is 1000 MHz.
    boost state support:
    Supported: no
    Active: no
    takeit2@neo:~>

    --------------------


    but I kinda knew that would be the case. I have been through some parts
    of this over the past 2 weeks. I think you have to have pm-profiler
    running first. I've not tried undoing it all and testing it.

    But what did work this time after starting pm-profiler in the old yast
    module "System Services (Runlevel)" was to go to the Yast module
    "/etc/sysconfig/ Editor" navigating to
    Hardware/Power/PM_Profiler_Profile and adding low_lantency there,
    saving, then rebooted.

    I then checked, and it worked...


    Code:
    --------------------
    takeit2@neo:~> cpupower frequency-info
    analyzing CPU 0:
    driver: powernow-k8
    CPUs which run at the same hardware frequency: 0
    CPUs which need to have their frequency coordinated by software: 0
    maximum transition latency: 109 us.
    hardware limits: 1000 MHz - 1.80 GHz
    available frequency steps: 1.80 GHz, 1000 MHz
    available cpufreq governors: ondemand, performance
    current policy: frequency should be within 1000 MHz and 1.80 GHz.
    The governor "performance" may decide which speed to use
    within this range.
    current CPU frequency is 1.80 GHz.
    boost state support:
    Supported: no
    Active: no
    takeit2@neo:~>

    --------------------

    Thanks for your help Malcome, I'm not good at all with the CL tools


    Hi
    No problem, the other way is to create a simple systemd service;

    Code:
    # /etc/systemd/system/cpupower.service
    #
    
    [Unit]
    Description=Set cpupower to performance for cpu0
    
    [Service]
    Type=oneshot
    ExecStart=/bin/sh -c "/usr/bin/cpupower --cpu 0 frequency-set -g performance"
    
    [Install]
    WantedBy=multi-user.target
    Save the above as /etc/systemd/system/cpupower.service

    Then run as root user;
    Code:
    systemctl status cpupower.service
    systemctl start cpupower.service
    cpupower frequency-info
    systemctl enable cpupower.service
    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-11-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  10. #10
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

    I turned off Intel SpeedStep in BIOS.

    Code:
    user@machine:~> cpupower frequency-info
    analyzing CPU 0:
      driver: intel_pstate
      CPUs which run at the same hardware frequency: 0
      CPUs which need to have their frequency coordinated by software: 0
      maximum transition latency: 0.97 ms.
      hardware limits: 800 MHz - 3.40 GHz
      available cpufreq governors: performance, powersave
      current policy: frequency should be within 800 MHz and 3.40 GHz.
                      The governor "powersave" may decide which speed to use
                      within this range.
      boost state support:
        Supported: no
    Active: no
    Howcome I don't get "current CPU frequency is" ?

    Code:
    user@machine:~> powersave -c
    POWERSAVE
    Ok. Why isn't it at PERFORMANCE as I turned off SpeedStep in BIOS?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •