Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

  1. #11
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,520
    Blog Entries
    15

    Default Re: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

    On Thu 26 Jun 2014 08:56:01 AM CDT, DJViking wrote:


    I turned off Intel SpeedStep in BIOS.


    Code:
    --------------------

    user@machine:~> cpupower frequency-info
    analyzing CPU 0:
    driver: intel_pstate
    CPUs which run at the same hardware frequency: 0
    CPUs which need to have their frequency coordinated by software: 0
    maximum transition latency: 0.97 ms.
    hardware limits: 800 MHz - 3.40 GHz
    available cpufreq governors: performance, powersave
    current policy: frequency should be within 800 MHz and 3.40 GHz.
    The governor "powersave" may decide which speed to use
    within this range.
    boost state support:
    Supported: no
    Active: no

    --------------------


    Howcome I don't get "current CPU frequency is" ?


    Code:
    --------------------

    user@machine:~> powersave -c
    POWERSAVE

    --------------------


    Ok. Why isn't it at PERFORMANCE as I turned off SpeedStep in BIOS?


    Hi
    Disable the driver via the grub option;
    Code:
    intel_pstate=disable
    The acpi-freq module should then allow you to set the max speed.

    On this machine, it does switch to performance, however it's still
    speed stepping, probably since I don't have it disabled.

    [CODE]
    # cpupower -c 0-1 frequency-set -g powersave
    Setting cpu: 0
    Setting cpu: 1
    # powersave -c
    POWERSAVE
    # cpupower -c 0-1 frequency-set -g performance
    Setting cpu: 0
    Setting cpu: 1
    # powersave -c
    PERFORMANCE
    # cpupower frequency-info
    analyzing CPU 0:
    driver: intel_pstate
    CPUs which run at the same hardware frequency: 0
    CPUs which need to have their frequency coordinated by software: 0
    maximum transition latency: 0.97 ms.
    hardware limits: 800 MHz - 1.90 GHz
    available cpufreq governors: performance, powersave
    current policy: frequency should be within 800 MHz and 1.90 GHz.
    The governor "performance" may decide which speed to
    use within this range.
    current CPU frequency is 1.71 GHz (asserted by call to hardware).
    boost state support:
    Supported: no
    Active: no
    1900 MHz max turbo 4 active cores
    1900 MHz max turbo 3 active cores
    1900 MHz max turbo 2 active cores
    1900 MHz max turbo 1 active cores
    [.CODE]

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-11-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  2. #12
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,191

    Default Re: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    As root user;
    Code:
    zypper in cpupower
    cpupower --cpu 0-n frequency-set -g performance
    Where n is the last core (if you want to set to all cores).
    I'm looking for the docs on this command. Found a man page, but I think it's different software because it didn't use this format...

  3. #13
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,520
    Blog Entries
    15

    Default Re: How do I set the CPU Frequency Governor In Opensuse 13.1 ?

    Quote Originally Posted by PattiMichelle View Post
    I'm looking for the docs on this command. Found a man page, but I think it's different software because it didn't use this format...
    Hi
    A lot happens in a year....

    What is not valid? You can either use all or 0-n still when n is the last core your wanting to set with --cpu? The governers a now only 2 if it's an intel cpu, unless you disable the p_state kernel module, it may not work. For AMD (APU/CPU) it works, for boost on an APU you will need to install the fglrx driver.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •