Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: updated > rebooted > "Welcome to rescue mode!"

  1. #1

    Default updated > rebooted > "Welcome to rescue mode!"

    Hello.
    All was good on my opensuse 13.1 system.
    The software updater did its thing. I rebooted and now.... dead!
    on boot I get "Welcome to rescue mode!" (never seen before!)

    I can put in a password for root and I can see a bunch of stuff in journalctl-xb but I dont see any flags.

    Where is this file located and how can I get it so that I can do a pastebin?

    If I put in a password for root and then do "systemctl default" it seems to hang at the green gecko screen!....it stays there if I hit escape I only get a blinking "_" in the upper right of the screen, if I hit escape again it goes back to the green gecko.

    is there a way to undo the last update?
    if on a reboot I go to advanced I see the following:
    openSUSE 13.1, with linux 3.11.10-11-desktop
    openSUSE 13.1, with linux 3.11.10-11-desktop (recovery mode)
    openSUSE 13.1, with linux 3.11.10-7-desktop
    openSUSE 13.1, with linux 3.11.10-7-desktop (recovery mode)


    all of them seem to do the same thing.... take me to rescue mode




    please help...
    qu1nn
    Pentium D 820, 2.80GHz, Intel D945PSN ATX, PowerColor Radeon HD7870, Geil DDR2, (1GB x 2) Dual Channel 667MHz Suse 13.2, KDE
    Haswell i4771, 3.5GHz, Asus Z87-WS ATX, Club3d R9 280X RoyalQueen, Corsair 8GBx2, Corsair AX860 PS, openSuse 13.1, KDE

  2. #2

    Default Re: updated > rebooted > "Welcome to rescue mode!"

    unless others chime in ...
    i had a similar thing happen today

    but it was a " not found" error about selinux.so.1
    and the / partition would not mount during boot

    odd thing it SE is used on my Scientificlinux 6.5 install ( second drive)

    now this was a experimental dist upgrade from 12.3 to 13.1 ( yes not recommended )

    i had to reformat /boot and / then reinstall

    repairing it worked until i UPDATED again
    then the same error
    so a reinstall


    one of the Mods around here might know a different way
    me , i do not



  3. #3

    Default Re: updated > rebooted > "Welcome to rescue mode!"

    I had the same issue no matter how hard I tried
    to install 13.1 the bootloader woudnt finish installing
    and so i had to install 13.2, the graphical installer
    looked newer and more polished to me and it did
    the job, now i'm running 13.2 factory and i added the
    debug repositories in case something happens i can
    send in debug reports. So far so good 13.2 factory
    seems really good and I do not need to fiddle with
    repositories just have the 13.2 ones because I saw
    on anouther forum the only command that is the safest
    is Zypper dup, because the is the cutting-bleeding edge
    and i might break stuff if i try to install old stuff into new
    stuff, SO my recommendation is install 13.2 if you need
    it because it seems really running good so far for me.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,742
    Blog Entries
    20

    Default Re: updated > rebooted > "Welcome to rescue mode!"

    13.2 is a long way from being ready
    Expect bigger issues
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: updated > rebooted > "Welcome to rescue mode!"

    Quote Originally Posted by qu1nn View Post
    all of them seem to do the same thing.... take me to rescue mode
    Well, the system goes to rescue mode if some necessary service cannot be started.
    You can see the last updates with "rpm -qa --last | less" f.e., or in YaST->Software Management->Extra->History.

    The latest official update was an update to systemd, but that only added necessary additional permissions for nvidia cards.

    Can you post the last lines before you go into rescue mode maybe?

    I don't see how the latest official updates should cause something like this, so please post your repo list:
    Code:
    zypper lr -d
    Try to run this in rescue mode:
    Code:
    systemctl --failed
    This should show you _what_ failed.

    Maybe /var/log/boot.log or /var/log/messages would tell more as well.

    Quote Originally Posted by JohnVV View Post
    but it was a " not found" error about selinux.so.1
    and the / partition would not mount during boot

    odd thing it SE is used on my Scientificlinux 6.5 install ( second drive)
    The message is about libselinux.so.1 not found, and this library is needed even if you do _not_ use SELinux, because basic system programs are linked against it like libmount, udev and systemd.
    So no wonder that your system doesn't boot without it.

    now this was a experimental dist upgrade from 12.3 to 13.1 ( yes not recommended )
    A dist upgrade from 12.3 to 13.1 should work fine, and is actually supported. But you should make sure your 12.3 system has all updates installed before you do that.

    But I hope you do realize that your problem is completely different from the OP's?
    So better open a new thread about _your_ problem.

    But it seems that your initrd is somehow corrupted and missing that libselinux. Check that there's enough space on your /boot partition for an additional kernel and initrd which get installed by the updates.
    Last edited by wolfi323; 20-Jun-2014 at 01:58.

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: updated > rebooted > "Welcome to rescue mode!"

    On 2014-06-20 04:56, qu1nn wrote:

    > Where is this file located and how can I get it so that I can do a
    > pastebin?


    It is a binary file, so you can not paste that easily, and if you, it is
    not easy for anybody else to peruse it. Further, by default in openSUSE
    the journal lives in a ram disk.

    So you have to use commands to display the corresponding text and post that.

    Besides that, do what wolfi323 advised.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  7. #7
    Join Date
    Sep 2012
    Posts
    5,325

    Default Re: updated > rebooted > "Welcome to rescue mode!"

    Quote Originally Posted by wolfi323 View Post
    Well, the system goes to rescue mode if some necessary service cannot be started.
    The only reason system goes in rescue mode is when some filesystem could not be mounted. At least in standard configuration as shipped with openSUSE.

  8. #8

    Default Re: updated > rebooted > "Welcome to rescue mode!"

    Quote Originally Posted by arvidjaar View Post
    The only reason system goes in rescue mode is when some filesystem could not be mounted. At least in standard configuration as shipped with openSUSE.
    Well, a filesystem mount is a "service" (a systemd unit actually) as well, isn't it?

    And I thought there might be other services/units as well that might cause rescue mode when they cannot be started.

    But I just tried to specify an invalid partition to mount in /etc/fstab, and the system tried to switch to _emergency_ mode, not rescue mode.
    And it failed to do so because of a bug you might be aware of... (endlessly printing "Welcome to emergency mode..." on and on without ever presenting a prompt)

    So when exactly does systemd enter rescue mode then? The OP clearly stated he sees "Welcome to rescue mode!".

    Anyway, I still think "systemctl --failed" should tell _what_ failed, even if it's a failed mount. Or not?
    Last edited by wolfi323; 20-Jun-2014 at 10:02.

  9. #9
    Join Date
    Sep 2012
    Posts
    5,325

    Default Re: updated > rebooted > "Welcome to rescue mode!"

    Quote Originally Posted by wolfi323 View Post
    and the system tried to switch to _emergency_ mode, not rescue mode.
    Sorry, I used them interchangeably. What do you call "rescue mode" then?

  10. #10

    Default Re: updated > rebooted > "Welcome to rescue mode!"

    Quote Originally Posted by arvidjaar View Post
    Sorry, I used them interchangeably. What do you call "rescue mode" then?
    I don't know what's the difference, but systemd has a "rescue mode" and an "emergency mode".

    Again, the OP clearly states he sees the words "Welcome to rescue mode!", whereas after a failed mount the words "Welcome to emergency mode!" appear (at least in my test).
    And there is indeed /usr/lib/systemd/system/rescue.target _and_ /usr/lib/systemd/system/emergency.target.

    And even http://freedesktop.org/wiki/Software/systemd/Debugging/ speaks of both distinctively:
    Booting into Rescue or Emergency Targets
    To boot directly into rescue target add systemd.unit=rescue.target or just 1 to the kernel command line. This target is useful if the problem occurs somewhere after the basic system is brought up, during the starting of "normal" services. If this is the case, you should be able to disable the bad service from here. If the rescue target will not boot either, the more minimal emergency target might.

    To boot directly into emergency shell add systemd.unit=emergency.target or emergency to the kernel command line. Note that in the emergency shell you will have to remount the root filesystem read-write by yourself before editing any files:
    So rescue.target is equivalent to runlevel1, and actually runlevel1.target is only a symlink to rescue.target.
    Whereas emergency.target is even more minimal.

    Which gives me an idea: maybe just the default target is set wrong?
    @OP, can you please post the output of:
    Code:
    systemctl get-default
    This would of course also explain why "systemctl default" did not work either (see the original post).

    Try "systemctl isolate graphical.target" or "init 5" instead.
    Last edited by wolfi323; 20-Jun-2014 at 11:31.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •