Results 1 to 5 of 5

Thread: trying to install application - Error: cannot fit Qt 4.x

  1. #1

    Default trying to install application - Error: cannot fit Qt 4.x

    Hello, im trying to install avogadro (with one click install it does not work), so i have to do it via cmake.

    Had troubles to install cmake, but now it works.
    but hten i tryiong to install avogadro via cmake and following error message appears:


    Code:
    -- The build type is ReleaseCMake Error at /usr/bin/cmake/share/cmake-3.0/Modules/FindQt4.cmake:1316 (message):
      Found unsuitable Qt version "" from NOTFOUND, this code requires Qt 4.x
    Call Stack (most recent call first):
      CMakeLists.txt:226 (find_package)
    
    
    
    
    -- Configuring incomplete, errors occurred!
    See also "/home/tk/Downloads/avogadro-1.1.1/build/CMakeFiles/CMakeOutput.log".
    See also "/home/tk/Downloads/avogadro-1.1.1/build/CMakeFiles/CMakeError.log".
    with regards

  2. #2

    Default Re: trying to install application - Error: cannot fit Qt 4.x

    Quote Originally Posted by carborane View Post
    Hello, im trying to install avogadro (with one click install it does not work), so i have to do it via cmake.
    Which one click install does not work? And what error message do you get?

    Btw, you don't need any 1-click install for installing avogadro as it is in the standard repos.
    Just search for it in YaST->Software Management and install it there. Or run:
    Code:
    sudo zypper in avogadro
    Had troubles to install cmake, but now it works.
    but hten i tryiong to install avogadro via cmake and following error message appears:


    Code:
    -- The build type is ReleaseCMake Error at /usr/bin/cmake/share/cmake-3.0/Modules/FindQt4.cmake:1316 (message):
    What's this strange path?
    How exactly did you install cmake?

    It is also available in the standard repos, just install the package.


    Code:
      Found unsuitable Qt version "" from NOTFOUND, this code requires Qt 4.x
    Call Stack (most recent call first):
      CMakeLists.txt:226 (find_package)
    You need to install libqt4-devel.

  3. #3

    Default Re: trying to install application - Error: cannot fit Qt 4.x

    Quote Originally Posted by wolfi323 View Post
    Which one click install does not work? And what error message do you get?

    Btw, you don't need any 1-click install for installing avogadro as it is in the standard repos.
    Just search for it in YaST->Software Management and install it there. Or run:
    Code:
    sudo zypper in avogadro

    What's this strange path?
    How exactly did you install cmake?

    It is also available in the standard repos, just install the package.




    You need to install libqt4-devel.

    apparently

    Code:
    zypper in avogadro
    does work, today.

    i think i tried once, but it didnt work

    maybe i thought i tried

    anyway. thx, program works

  4. #4

    Default Re: trying to install application - Error: cannot fit Qt 4.x

    I'm also attempting to install an application, and also get essentially a very similar error message:

    Code:
    CMake Error at /usr/share/cmake/Modules/FindQt4.cmake:1316 (message):
      Found unsuitable Qt version "" from NOTFOUND, this code requires Qt 4.x
    Call Stack (most recent call first):
      CMake/cdat_modules/qt4_pkg.cmake:2 (find_package)
      CMakeLists.txt:563 (include)
    The application I am trying to install does not implicitly support openSUSE, which is why I am attempting to install it from source.

    I have installed libqt4-devel, and I believe my PATH is pointing towards usr/bin, where qmake is.

    PS: I am new to this forum, and if it in any way is inappropriate to "revive" an old thread please tell me

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,255
    Blog Entries
    15

    Default Re: trying to install application - Error: cannot fit Qt 4.x

    Quote Originally Posted by miktoki View Post
    I'm also attempting to install an application, and also get essentially a very similar error message:

    Code:
    CMake Error at /usr/share/cmake/Modules/FindQt4.cmake:1316 (message):
      Found unsuitable Qt version "" from NOTFOUND, this code requires Qt 4.x
    Call Stack (most recent call first):
      CMake/cdat_modules/qt4_pkg.cmake:2 (find_package)
      CMakeLists.txt:563 (include)
    The application I am trying to install does not implicitly support openSUSE, which is why I am attempting to install it from source.

    I have installed libqt4-devel, and I believe my PATH is pointing towards usr/bin, where qmake is.

    PS: I am new to this forum, and if it in any way is inappropriate to "revive" an old thread please tell me
    Hi
    Yes, since you don't say what version of openSUSE your on, always better to start a new thread

    Anyway, just check the qmake is not a softlink a different version (eg qmake-5.1), if still and issue please start a new thread.

    Closing this thread.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •