Results 1 to 6 of 6

Thread: VirtualBox on Kernel 3.15

  1. #1
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default VirtualBox on Kernel 3.15

    I have installed two linux kernels on OpenSUSE 13.1 running KDE 4.13.2.
    kernel-desktop-3.11.10-11
    kernel-desktop-3.15.0-1

    I have installed VirtualBox from repository http://download.opensuse.org/reposit...openSUSE_13.1/
    virtualbox-guest-kmp-desktop-4.3.12_k3.11.10_11-116.3
    virtualbox-host-kmp-desktop-4.3.12_k3.11.10_11-116.3

    Does this mean I cannot use VirtualBox with the latest stable kernel?

    I tried running /etc/init.d/vboxdrv setup
    While running on kernel 3.15, but VirtualBox only runs if I boot the 3.11 kernel.

    I can happily run kernel-3.11, because I don't notice anything better with kernel-3.15 (perhaps much under the hood changes). However I would like to get it working with the latest kernel if possible.

  2. #2

    Default Re: VirtualBox on Kernel 3.15

    Quote Originally Posted by DJViking View Post
    I have installed two linux kernels on OpenSUSE 13.1 running KDE 4.13.2.
    kernel-desktop-3.11.10-11
    kernel-desktop-3.15.0-1

    I have installed VirtualBox from repository http://download.opensuse.org/reposit...openSUSE_13.1/
    virtualbox-guest-kmp-desktop-4.3.12_k3.11.10_11-116.3
    virtualbox-host-kmp-desktop-4.3.12_k3.11.10_11-116.3

    Does this mean I cannot use VirtualBox with the latest stable kernel?
    Yes. Those KMP packages are only intended to be used with the kernel shipped with openSUSE 13.1.
    And they don't contain the kernel module's source code, only a precompiled module, so "/etc/init.d/vboxdrv setup" to recompile the kernel module won't work either.

    If you want to use VirtualBox with kernel 3.15, you would have to install it from http://virtualbox.org/.
    But remove the openSUSE packages first before you do that.

    OTOH, those KMP packages _are_ actually available for the Kernel:stable repo (where you have kernel 3.15 from) as well:
    http://download.opensuse.org/reposit...able_standard/
    So add that repo and install the ones for kernel 3.15.
    Last edited by wolfi323; 18-Jun-2014 at 06:35.

  3. #3
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: VirtualBox on Kernel 3.15

    Quote Originally Posted by wolfi323 View Post

    OTOH, those KMP packages _are_ actually available for the Kernel:stable repo (where you have kernel 3.15 from) as well:
    http://download.opensuse.org/reposit...able_standard/
    So add that repo and install the ones for kernel 3.15.
    Excellent. Fantastic. Didn't think to check if there was a repo for that. It makes life so much more easier.

  4. #4

    Default Re: VirtualBox on Kernel 3.15

    Quote Originally Posted by DJViking View Post
    Excellent. Fantastic. Didn't think to check if there was a repo for that. It makes life so much more easier.
    Well, I didn't know either until now.
    The last time I looked (1 or 2 months ago) it failed to build and therefore an ancient (and therefore useless) version was in that repo only.

  5. #5
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: VirtualBox on Kernel 3.15

    Quote Originally Posted by wolfi323 View Post
    Well, I didn't know either until now.
    The last time I looked (1 or 2 months ago) it failed to build and therefore an ancient (and therefore useless) version was in that repo only.
    They where built 17-Jun-2014 14:04, for kernel-3.15.0-1
    That's fortuitous

    If only there was a kernel-stable repo for Nvidia also...
    The kernel is advancing so fast these days. Staying on 3.11 feels like ancient...

  6. #6

    Default Re: VirtualBox on Kernel 3.15

    Quote Originally Posted by DJViking View Post
    They where built 17-Jun-2014 14:04, for kernel-3.15.0-1
    That's fortuitous
    Not quite. They get rebuilt regularly, especially whenever there is a new kernel in Kernel:stable of course (this happens automatically).

    Somebody fixed the build recently though it seems (I don't know when exactly), because as I said they were not available when I last looked because of build failures.

    If only there was a kernel-stable repo for Nvidia also...
    The kernel is advancing so fast these days. Staying on 3.11 feels like ancient...
    Well, the problem is that the nvidia driver may not be hosted on OBS.

    So somebody at openSUSE builds the driver packages, sends them to nvidia, and somebody there has to copy them to the repo. (I don't know the exact workflow though... )

    And apparently the involved people don't want to do this every few days whenever there is a new kernel in Kernel:stable...

    But as the nouveau driver is getting better all the time (especially with Kernel 3.15/16), the nvidia driver might not even be that mandatory any more.
    You might want to consider upgrading to the latest Xorg/Mesa/nouveau packages in X11:XOrg as well for best results I suppose.

    OTOH you can of course also install and setup dkms, this will rebuild the nvidia kernel module automatically whenever there is a kernel update.
    But I don't know whether the nvidia driver works at all on kernel 3.15 yet. In the past it always took some weeks for nvidia to catch up when a new major kernel version was released.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •