Results 1 to 2 of 2

Thread: yast/yast2 issues (specifically installing/removing programs module)

  1. #1

    Angry yast/yast2 issues (specifically installing/removing programs module)

    Ok. Got a "weird" issue with OpenSuSE 13.1: doesn't matter which desktop I use (lxde or xfce4 for example), when i click on menu>settings>install/remove software nothing happens. however, when i run the command: xdg-su -c "/sbin/yast2 --gtk" and run software management that way, again nothing happens (neither when i click on menu>settings>yast) HOWEVER: when i run xdg-su -c "/sbin/yast2 --qt" I am able and successfully able to run software management. Can anyone explain to me why and how to fix this so that Install/Remove programs works "correctly" from ANY desktop environment?

    output of xdg-su -c "/sbin/yast2 --gtk" command:
    ** (gnomesu:4786): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    W: [pulseaudio] core-util.c: Failed to open configuration file '/home/jeff/.config/pulse//daemon.conf': Permission denied
    W: [pulseaudio] daemon-conf.c: Failed to open configuration file: Permission denied
    terminate called after throwing an instance of 'YUIPluginException'
    what(): Couldn't load plug-in gtk
    YaST got signal 6 at YCP file /usr/share/YaST2/modules/Wizard.rb:817
    /sbin/yast2: line 378: 4861 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    output of xdg-su -c "/sbin/yast2 --qt" command:
    ** (gnomesu:4891): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    W: [pulseaudio] core-util.c: Failed to open configuration file '/home/jeff/.config/pulse//daemon.conf': Permission denied
    W: [pulseaudio] daemon-conf.c: Failed to open configuration file: Permission denied
    Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
    Run command: /sbin/yast2 sw_single &

    Help? Suggestions? Fixes?

  2. #2

    Default AW: yast/yast2 issues (specifically installing/removing programs module)

    Quote Originally Posted by proteanthread View Post
    Ok. Got a "weird" issue with OpenSuSE 13.1: doesn't matter which desktop I use (lxde or xfce4 for example), when i click on menu>settings>install/remove software nothing happens. however, when i run the command: xdg-su -c "/sbin/yast2 --gtk" and run software management that way, again nothing happens (neither when i click on menu>settings>yast) HOWEVER: when i run xdg-su -c "/sbin/yast2 --qt" I am able and successfully able to run software management. Can anyone explain to me why and how to fix this so that Install/Remove programs works "correctly" from ANY desktop environment?
    So, to put it simple, the Qt version works, but the Gtk version does not?
    You could set the default GUI to Qt in /etc/sysconfig/yast2 (WANTED_SHELL="qt" and WANTED_GUI="qt"), then it should use the Qt version in any desktop environment.

    output of xdg-su -c "/sbin/yast2 --gtk" command:
    ** (gnomesu:4786): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    W: [pulseaudio] core-util.c: Failed to open configuration file '/home/jeff/.config/pulse//daemon.conf': Permission denied
    W: [pulseaudio] daemon-conf.c: Failed to open configuration file: Permission denied
    terminate called after throwing an instance of 'YUIPluginException'
    what(): Couldn't load plug-in gtk
    YaST got signal 6 at YCP file /usr/share/YaST2/modules/Wizard.rb:817
    /sbin/yast2: line 378: 4861 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    Do you actually have the necessary gtk plugins installed?
    Please post the output of:
    Code:
    rpm -qa | grep yui
    For the Gtk version you need in particular the packages libyui-gtk5 and libyui-gtk-pkg5.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •