Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: KDE glitchy graphics

  1. #1

    Default KDE glitchy graphics

    Greetings

    I've just installed openSUSE 13.1 and I'm having an usual issue with my graphics here. When I move a window it seems... clunky. Like, it's not redrawing smoothly. The issue becomes more noticeable when I have desktop effects disabled, and most noticeable (with effects enabled or not) when it's the only window open. I thought it was weird, that when the window is overlaying other windows, it behaves just fine.

    I've messed around with almost every setting I could find, but came up empty handed.
    Any help resolving this would be greatly appreciated.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: KDE glitchy graphics

    Video card and driver????

  3. #3

    Default Re: KDE glitchy graphics

    Hopefully this is what you're asking for. I found it on another thread while trying to figure this out.

    /sbin/lspci -nnk | grep VGA -A2

    00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0106] (rev 09)
    Subsystem: Toshiba America Info Systems Device [1179:fc50]
    Kernel driver in use: i915

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: KDE glitchy graphics

    Try advanced boot option then select safe or rescue boot option Then do the updates there was a problem with some Intel chips sets on 13.1 but the update will fix

  5. #5

    Default Re: KDE glitchy graphics

    Okay, I tried that. I had installed the updates previously, but figured I would do the recovery mode as you suggested. However, I found that it never booted into the system when I tried doing so. It just stopped at a point and when ever I hit an arrow key, it would start over and stop at the same point. It said it had reached the graphical interface or something. After that, my wifi went wonky. So, maybe I botched my install somehow?

    I did it on an ubuntu system using the live-fat-disk method and remember it was doing something weird like trying to erase and mount sda5 during the first attempt. There was no sda5 though, so naturally it could not.

    I've loaded up a new usb using the suse studio image writer. Think I just need to reinstall?

  6. #6

    Default Re: KDE glitchy graphics

    Update. networking got sorted out, and I found out it just won't boot from a usb unless I use live-fat-stick. So, I'll just keep this install and try sorting through it.

  7. #7

    Default Re: KDE glitchy graphics

    Quote Originally Posted by guppykiller View Post
    Hopefully this is what you're asking for. I found it on another thread while trying to figure this out.

    /sbin/lspci -nnk | grep VGA -A2

    00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0106] (rev 09)
    Subsystem: Toshiba America Info Systems Device [1179:fc50]
    Kernel driver in use: i915
    Try this then:
    https://en.opensuse.org/SDB:Switch_x...o-intel_to_UXA

  8. #8

    Default Re: KDE glitchy graphics

    Thanks. I tried that, but it didn't make any differences. I'll keep looking around and be on the lookout for updates that may resolve it.

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: KDE glitchy graphics

    Did you manage the updates? It is not clear that should get a fixed Intel drive among many other things.

    Note if the GUI is really bad you can run yast from the command line as root to do the update or type zypper up

  10. #10

    Default Re: KDE glitchy graphics

    Quote Originally Posted by guppykiller View Post
    Thanks. I tried that, but it didn't make any differences. I'll keep looking around and be on the lookout for updates that may resolve it.
    You might also have a play with the settings in "Configure Desktop"->"Desktop Effects".
    Try to disable the "Blur" effect in "All effects", that is known to have caused problems in the past.

    And also check the settings on the "Advanced" tab.
    The recommended settings nowadays are "Composite Type" OpenGL, "Qt graphics system" Raster, but try other combinations as well.

    And try to set the scaling method to "crisp" or "smooth" there. The Lanczos filter ("accurate") can also slow down your system considerably, depending on the graphics card.

    Of course those won't change anything with desktop effects turned off, but maybe you'll be able to get a nicer experience with them turned on.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •