Results 1 to 10 of 10

Thread: Recovery standard icons from the installation DVD?

  1. #1

    Default Recovery standard icons from the installation DVD?

    Hi,
    I played with opensuse 13.1 KDE and I have done some damage...
    in particular, there's no way to get back the default icons, both Crystal and Oxygen are missing icons and some icons are still present from a theme (http://kde-look.org/content/show.php...content=165154) deleted. I've also removed font cache, but nothing change.
    It's possible to extract the standard icons from the installation DVD?
    I would try to fix those in /usr/share/icons/ with the one from DVD.
    Regards

  2. #2

    Default AW: Recovery standard icons from the installation DVD?

    Quote Originally Posted by Mahler View Post
    I've also removed font cache, but nothing change.
    The font cache?
    You should remove the icon cache, preferably when KDE is not running.
    /var/tmp/kdecache-$USER/icon-cache.kcache

    It's possible to extract the standard icons from the installation DVD?
    I would try to fix those in /usr/share/icons/ with the one from DVD.
    Installing an icon theme as _user_ should not break/change any files from the system icon theme.

    But you can of course re-install it, the package is called "oxygen-icon-theme", there's also "oxygen-icon-theme-large" and "oxygen-icon-theme-scalable". I don't know which of those you have installed, but enter YaST->Software Management, right-click on those packages (the installed ones) and choose "Update Unconditionally".

  3. #3

    Default Re: AW: Recovery standard icons from the installation DVD?

    Quote Originally Posted by wolfi323 View Post
    The font cache?
    You should remove the icon cache, preferably when KDE is not running.
    /var/tmp/kdecache-$USER/icon-cache.kcache


    Installing an icon theme as _user_ should not break/change any files from the system icon theme.

    But you can of course re-install it, the package is called "oxygen-icon-theme", there's also "oxygen-icon-theme-large" and "oxygen-icon-theme-scalable". I don't know which of those you have installed, but enter YaST->Software Management, right-click on those packages (the installed ones) and choose "Update Unconditionally".
    Thanks, I've delete icon-cache.kcache in var/tmp and in home.

    I've reinstalled via Yast Oxygen with "Update Unconditionally".

    The majority of the icons is back in its place, but not the folders icons, those are always from the theme deleted.

  4. #4

    Default Re: Recovery standard icons from the installation DVD?

    Quote Originally Posted by Mahler View Post
    The majority of the icons is back in its place, but not the folders icons, those are always from the theme deleted.
    Hm, that sounds familiar.
    I think that's related to the folder preview feature, but I'm not sure how to fix it.

    Does it help if you disable folder previews as a test? (deselect the "Preview" button in the toolbar)
    Maybe try to remove ~/.cache/thumbnails/ as well.

    PS: the icon for a folder is stored in a file ".desktop" in the corresponding folder.
    So check whether such a file exists in a folder that has a wrong icon and try to remove it.
    Last edited by wolfi323; 12-Jun-2014 at 01:48.

  5. #5

    Default Re: Recovery standard icons from the installation DVD?

    Quote Originally Posted by wolfi323 View Post
    Hm, that sounds familiar.
    I think that's related to the folder preview feature, but I'm not sure how to fix it.

    Does it help if you disable folder previews as a test? (deselect the "Preview" button in the toolbar)
    Maybe try to remove ~/.cache/thumbnails/ as well.

    PS: the icon for a folder is stored in a file ".desktop" in the corresponding folder.
    So check whether such a file exists in a folder that has a wrong icon and try to remove it.

    Sorry, I do not have this path ~/.cache/thumbnails/

  6. #6

    Default Re: Recovery standard icons from the installation DVD?

    PS: the icon for a folder is stored in a file ".desktop" in the corresponding folder.
    So check whether such a file exists in a folder that has a wrong icon and try to remove it.
    I've done, nothing happens

  7. #7

    Default Re: Recovery standard icons from the installation DVD?

    Quote Originally Posted by wolfi323 View Post
    Hm, that sounds familiar.
    I think that's related to the folder preview feature, but I'm not sure how to fix it.

    Does it help if you disable folder previews as a test? (deselect the "Preview" button in the toolbar)
    Maybe try to remove ~/.cache/thumbnails/ as well.

    PS: the icon for a folder is stored in a file ".desktop" in the corresponding folder.
    So check whether such a file exists in a folder that has a wrong icon and try to remove it.
    Ok, works!! But the thumbnails path is ~/.thumbnails/ !!
    Now works!! I've delete cache stored in ~/.thumbnails/ and ".desktop" files !! And works!!

  8. #8

    Default Re: Recovery standard icons from the installation DVD?

    Quote Originally Posted by Mahler View Post
    Sorry, I do not have this path ~/.cache/thumbnails/
    But you should have a .cache folder in your home directory, which should include a thumbnails folder.
    As this starts with a '.' it is hidden though, you have to enable "Show hidden files/folders" in dolphin to see it.

    And have you tried to disable the preview?

  9. #9

    Default Re: Recovery standard icons from the installation DVD?

    Quote Originally Posted by wolfi323 View Post
    But you should have a .cache folder in your home directory, which should include a thumbnails folder.
    As this starts with a '.' it is hidden though, you have to enable "Show hidden files/folders" in dolphin to see it.

    And have you tried to disable the preview?
    Ok, works!! But the thumbnails path is ~/.thumbnails/ !!
    Now works!! I've delete cache stored in ~/.thumbnails/ and ".desktop" files !! And works!!

  10. #10

    Default Re: Recovery standard icons from the installation DVD?

    Quote Originally Posted by Mahler View Post
    Ok, works!! But the thumbnails path is ~/.thumbnails/ !!
    Ah yes. Sorry.
    KDE4 still uses ~/.thumbnails/, but I have ~/.cache/thumbnails/ as well on my system, that confused me.
    I think GNOME3 and KDE5 use the latter one.
    Last edited by wolfi323; 12-Jun-2014 at 02:13.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •