Results 1 to 9 of 9

Thread: FreeCAD does not start anymore due to missing libboost_program_options

  1. #1
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    84

    Default FreeCAD does not start anymore due to missing libboost_program_options

    Hello altogether,

    after some time I wanted to use FreeCAD today but it refused to start. A start from the commandline results in the following error:
    Code:
    FreeCAD: error while loading shared libraries: libboost_program_options.so.1.49.0: cannot open shared object file: No such file or directory
    But I have "libboost_program_options.so.1.49.0" installed under "/usr/lib/". For testing purposes I created a symlink under "/usr/" but it has not resolved the problem.

    I tried both FreeCAD version 0.12.5284 from software.opensuse.org and the current build version 0.13.99 from freecadweb.org

    Any help is welcome!

    Thank you
    Simon

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,166

    Default AW: FreeCAD does not start anymore due to missing libboost_program_options

    And the openSUSE version is ...?
    Henk van Velden

  3. #3
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    84

    Default Re: FreeCAD does not start anymore due to missing libboost_program_options

    Oh sorry, I'm on opensuse 13.1 of course.

  4. #4

    Default Re: FreeCAD does not start anymore due to missing libboost_program_options

    Quote Originally Posted by SimonHeimbach View Post
    Oh sorry, I'm on opensuse 13.1 of course.
    Are you sure that you have libboost_program_options.so.1.49.0 in /usr/lib/ then?
    13.1 comes with boost 1.54 only.

    Also do you have a 32bit or 64bit system, is the FreeCAD you installed the 32bit or 64bit version?
    The 64bit version would expect the libraries in /usr/lib64/ instead.

    But if FreeCAD requires boost 1.49, the package is definitely not intended for 13.1.

    Btw, the latest version (0.13.99+git20140610.1336) is available on Packman. Install that and it should work, it is available as 32bit and 64bit package.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,166

    Default Re: FreeCAD does not start anymore due to missing libboost_program_options

    Quote Originally Posted by SimonHeimbach View Post
    ..... of course.
    Henk van Velden

  6. #6
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    84

    Default Re: FreeCAD does not start anymore due to missing libboost_program_options

    I'm running opensuse 13.1-64bit.
    I noticed the version bump of libboost. And I perhaps haven't used FreeCAD since the upgrade from 12.3.

    I installed a version 1.49 of libboost_program_options that I found on software.opensuse.org. It is however 32 bit only as I noticed now.

    I removed FreeCAD and reinstalled the newest version of FreeCAD (0.13.99) from packman. I tried both 64bit and 32 bit. Unfortunately they have the same dependency and still require 1.49. Is there a chance to get FreeCAD running on opensuse 13.1?

  7. #7

    Default AW: Re: FreeCAD does not start anymore due to missing libboost_program_options

    Quote Originally Posted by SimonHeimbach View Post
    I removed FreeCAD and reinstalled the newest version of FreeCAD (0.13.99) from packman. I tried both 64bit and 32 bit. Unfortunately they have the same dependency and still require 1.49. Is there a chance to get FreeCAD running on opensuse 13.1?
    The package for 13.1 requires boost 1.53, _not_ 1.49:
    Code:
    # zypper info --requires FreeCAD
    ...
    libboost_program_options.so.1.53.0()(64bit)
    ...
    Probably you have the Packman repo for 12.3 or earlier?
    Please post your repo list:
    Code:
    zypper lr -d

  8. #8
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    84

    Default Re: FreeCAD does not start anymore due to missing libboost_program_options

    ok, I got the problem.

    I somehow have a second FreeCAD-install. Can't remember. I might have once installed it from source long ago. Running "FreeCAD" from bash wants to start the old installation.
    When I run the full path "/usr/bin/FreeCAD" or start it from KDE the program runs fine.

    Thank you anyway for your help.
    Simon

  9. #9

    Default Re: FreeCAD does not start anymore due to missing libboost_program_options

    Quote Originally Posted by SimonHeimbach View Post
    ok, I got the problem.

    I somehow have a second FreeCAD-install. Can't remember. I might have once installed it from source long ago. Running "FreeCAD" from bash wants to start the old installation.
    When I run the full path "/usr/bin/FreeCAD" or start it from KDE the program runs fine.
    Run "which FreeCAD" to find out where the old executable is located. Most likely below /usr/local/ though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •