Results 1 to 2 of 2

Thread: Cinnamon crashes

  1. #1

    Default Cinnamon crashes

    Hi there, this is my first time using openSUSE (I'm comming from another distro) and I just installed 13.1 from network. After doing this, the first time I did was setting up fglrx amd catalyst 14.4 since I have an ATI HD 5400 card, it works perfect with Gnome-Shell classic version, but to be honest I just don't like it, so I wanted to swtich to Cinnamon. So I went to https://en.opensuse.org/Portal:Cinnamon and tried the One Click Install, it installed with no problems, but when I try to login with Cinnamon, I get this error message:

    Do you want to restart Cinnamon? Connamon just crashed. You are corrently running in Fallback Mode.

    Doesn't matter what I choose (Yes/No), the desktop just doesn't work and I have to reboot the system, because even if I change to another terminal and restart the graphics daemon I just lost the entire image in my display.

    The next thing I did was to remove all the cinnamon related packages using YaST, and then I installed back the packaged listen in the https://en.opensuse.org/Portal:Cinnamon site, but exactly same result. Does anyone knows about this issue?

    Looks that this post ( https://forums.opensuse.org/showthre...-OpenSuSE-13-1 ) has the same problem, but there's no fix in it but switch to gnome classic, which I personally think is a terribly bad fork of gnome2. And I know cinnamon is not official for openSUSE, but I hope there's a chance that I can use it, since I've never liked KDE and GNOME-Shell su*.

    Thank you!

    Here is my .xsession-errors-:0 file: http://pastebin.com/PdTs6dFs

    Here is my /var/log/Xorg.0.log: http://pastebin.com/TtCh4JVx

  2. #2

    Default Re: Cinnamon crashes

    Hi. I ran into this myself tonight as I upgraded to Cinnamon 2.3 from 2.x (seems home:/cyberorg:/cinnamon no longer exists so I had to move to X11:/Cinnamon:/Factory).

    After a few minutes I realized that the problem this: The Cinnamon 2.3 packages in X11:/Cinnamon:/Factory install new schema files in /usr/share/glib-2.0/schemas but for some reason they don't bother to actually compile them. Oops.

    So, in my case, my /usr/share/glib-2.0/schemas/gschemas.compiled still contained the old Cinnamon 2.0 schemas which are missing some things that Cinnamon 2.3 needs. In your case, since you're installing Cinnamon for the first time, I'll venture a guess that your compiled schemas don't contain any Cinnamon stuff.

    The solution is easy:

    > glib-compile-schemas /usr/share/glib-2.0/schemas

    (you might want to make a backup copy of /usr/share/glib-2.0/schemas/gschemas.compiled before you do this just in case things go sideways)

    Give it a shot and see what happens...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •