Results 1 to 6 of 6

Thread: OpenSuse 13.1 no bulgarian keyboard?

  1. #1

    Default OpenSuse 13.1 no bulgarian keyboard?

    Guys hello, and thank you for your time. I just did a fresh install of OpenSuse 13.1 x64, but there is no Bulgarian keyboard. I was able to change the OS language to Bulgarian but there is no Bulgarian keyboard in System Keyboard layout and i really need bulgarian keyboard in my daytime work. Can you good lads please help? Thanks again.

  2. #2

    Default Re: OpenSuse 13.1 no bulgarian keyboard?

    Guys I don't know what to say. I was able to get my bulgarian keyboard, but i didn't know its like a widget i need to add to the taskbar. Thanks.

  3. #3

    Default Re: OpenSuse 13.1 no bulgarian keyboard?

    You're right. Apparently there doesn't seem to be a bulgarian keyboard layout available in YaST.
    You might try to configure it directly in /etc/sysconfig/keyboard (variable "KEYTABLE"). I see those bulgarian keyboard files in /usr/share/kbd/keymaps/:
    Code:
    wolfi@amiga:~> find /usr/share/kbd/keymaps/ -name bg*/usr/share/kbd/keymaps/i386/qwerty/bg_bds-utf8.map.gz
    /usr/share/kbd/keymaps/i386/qwerty/bg_pho-cp1251.map.gz
    /usr/share/kbd/keymaps/i386/qwerty/bg_pho-utf8.map.gz
    /usr/share/kbd/keymaps/i386/qwerty/bg_bds-cp1251.map.gz
    /usr/share/kbd/keymaps/i386/qwerty/bg-cp1251.map.gz
    
    /usr/share/kbd/keymaps/i386/qwerty/bg-cp855.map.gz
    You should put only the part after the last '/' into the file, f.e. "bg-cp1251.map.gz".
    This should not only apply to text mode, but also taken over to Xorg by the xdm init script. (I cannot tell you whether this works with the bulgarian layouts though)

    Other ideas:
    - Use a keymap that's similar enough to bulgarian. As I don't know how the bulgarian layout would look like, I cannot advise there.
    - Your Desktop Environment might provide a bulgarian keyboard layout in its settings. F.e. in KDE I do see "Bulgarian" in the list (Systemsettings/"Configure Desktop"->Input Devices->Keyboard->Layouts. Enable "Configure Layouts" and click on "Add".)
    This is user-specific then though, so would not apply to the login screen f.e.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,978

    Default Re: OpenSuse 13.1 no bulgarian keyboard?

    Quote Originally Posted by catsado View Post
    Guys hello, and thank you for your time. I just did a fresh install of OpenSuse 13.1 x64, but there is no Bulgarian keyboard. I was able to change the OS language to Bulgarian but there is no Bulgarian keyboard in System Keyboard layout and i really need bulgarian keyboard in my daytime work. Can you good lads please help? Thanks again.
    And next time please tell what desktop environment you use. This typicaly depends on the desktop, KDE, Gnome, ...
    Henk van Velden

  5. #5

    Default Re: OpenSuse 13.1 no bulgarian keyboard?

    Quote Originally Posted by hcvv View Post
    And next time please tell what desktop environment you use. This typicaly depends on the desktop, KDE, Gnome, ...
    Sorry I'm using KDE. Btw dear moderator i have looked up the forum and i really think your too harsh on the members. Thanks again.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,699

    Default Re: OpenSuse 13.1 no bulgarian keyboard?

    You have to realize that people post using all sorts of different versions and desktops. Most of the time it is critical to know which of the many available the person is using to help solve the problem. All our crystal balls are broken so we can only guess what a given person has running on their machine unless they tell us.

    In your case we may have had you look in the KDE setup which may have your needed keyboard. The instruction on how are different between KDE and Gnome and may be different again for other desktops.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •