Results 1 to 4 of 4

Thread: Can't find date localisation settings

  1. #1
    Join Date
    May 2014
    Location
    Taranaki, New Zealand
    Posts
    11

    Default Can't find date localisation settings

    Window Manager: Xfce

    Hi,
    This laptop was set up by my boss, but he can't remember where he configured his.
    Apps such as LibreOffice are interpreting date input as MM/DD/YY, whereas I always use DD/MM/YY
    I can't see an option in Libreoffice (which uses the user's system settings on most platforms), but I also can't find any option in YaST or in Settings manager.

    My Keyboard is US English and timezone is Pacific/NZST

    TIA
    Richard

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Can't find date localisation settings

    On 2014-06-10 00:46, taranakicathedral wrote:
    >
    > Window Manager: Xfce
    >
    > Hi,
    > This laptop was set up by my boss, but he can't remember where he
    > configured his.
    > Apps such as LibreOffice are interpreting date input as MM/DD/YY,
    > whereas I always use DD/MM/YY
    > I can't see an option in Libreoffice (which uses the user's system
    > settings on most platforms), but I also can't find any option in YaST or
    > in Settings manager.
    >
    > My Keyboard is US English and timezone is Pacific/NZST


    The global configuration is in YaST -> System -> Language module and
    Date & Time settings module.

    Language, or rather, locale for each user should be defined by creating
    an "~/.i18n" file. For instance, I use:

    Code:
    LC_TIME=en_DK.UTF-8

    which results I me having US locale definitions, except for time, that I
    use DK settings, which happens to be YYYY-MM-DD.

    However, the .i18n is not honored by all desktops, so I turned to do
    them in "~/.profile" instead:

    Code:
    export LC_TIME=en_DK.UTF-8
    So you need to find a language that happens to print the date in the
    format you want; you can not simply define it, in Linux, to an arbitrary
    format, unless you create your own locale files.


    However, LibreOffice has its own definitions.

    Menu Tools, Options, Language settings.

    There is a box for entering "date acceptance patterns", and other
    settings. They can apply to the current document or to all of them.
    Well, new files, that is.


    I don't know of a place to define in LO the default date format,
    different from the one predefined for your country, though. I think you
    have to fiddle with the styles.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,385

    Default Re: Can't find date localisation settings

    And of course there are the settings for the user. Never forget that settings prefered by the system manager may not be those oprefered by all the individual users, who may e.g. login from all time zones of the world (and like to see their local time). Thus the desktop has also settings.

    But as you failed to tell which desktop environment you use (KDE, Gnome, ...), people assumed that you talk of system settings. And they answered you roughly. Roughly, because you also failed to tell which version of openSUSE you use.
    Henk van Velden

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Can't find date localisation settings

    On 2014-06-10 09:36, hcvv wrote:
    >
    > And of course there are the settings for the user. Never forget that
    > settings prefered by the system manager may not be those oprefered by
    > all the individual users, who may e.g. login from all time zones of the
    > world (and like to see their local time). Thus the desktop has also
    > settings.
    >
    > But as you failed to tell which desktop environment you use (KDE, Gnome,
    > ...), people assumed that you talk of system settings. And they answered
    > you roughly. Roughly, because you also failed to tell which version of
    > openSUSE you use.


    Gnome/xfce honours the console localization settings. I use that method
    to modify the en-US settings of the desktop with other settings for Spain:

    Code:
    cer@Telcontar:~> locale
    LANG=en_US.utf8
    LC_CTYPE="en_US.utf8"
    LC_NUMERIC=es_ES@euro
    LC_TIME=en_DK.UTF-8
    LC_COLLATE=POSIX
    LC_MONETARY=es_ES@euro
    LC_MESSAGES="en_US.utf8"
    LC_PAPER=es_ES@euro
    LC_NAME=es_ES@euro
    LC_ADDRESS="en_US.utf8"
    LC_TELEPHONE=es_ES@euro
    LC_MEASUREMENT=es_ES@euro
    LC_IDENTIFICATION="en_US.utf8"
    LC_ALL=
    cer@Telcontar:~>
    That level of customization is not offered by the desktop. At least, not
    by gnome or xfce.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •