Results 1 to 5 of 5

Thread: Gimp print preview opens pdf in inkscape instead of evince / okular

  1. #1
    Join Date
    May 2011
    Posts
    11

    Default Gimp print preview opens pdf in inkscape instead of evince / okular

    Hi,

    on openSUSE 13.1 in Gimp with any image open, using File -> Print -> Print preview, Gimp creates a temporary pdf file and then launches inkscape to view it. Why inkscape instead of okular or evince? I thought it might have to do with the default file associations but I can't find the culprit there:

    Code:
    ~ > cat ~/.local/share/applications/defaults.list
    cat: ~/.local/share/applications/defaults.list: No such file or directory
    ~ > cat ~/.local/share/applications/mimeapps.list
    [Default Applications]
    x-scheme-handler/mailto=thunderbird.desktop
    message/rfc822=thunderbird.desktop
    application/x-extension-eml=thunderbird.desktop
    
    [Added Associations]
    x-scheme-handler/mailto=thunderbird.desktop;
    message/rfc822=thunderbird.desktop;
    application/x-extension-eml=thunderbird.desktop;
    So no reference to pdf or acrobat. There's nothing to that effect in /etc/gnome_defaults.conf either.

    What to do? I really don't want to import my pdf's into inkscape as a print preview.

    Cheers.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,544
    Blog Entries
    1

    Default Re: Gimp print preview opens pdf in inkscape instead of evince / okular

    If you're a KDE user, right-click on a pdf file and click on 'File Type Options'. Change as you like. (Mine has Okular set as first in preference order.)

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,240

    Default Re: Gimp print preview opens pdf in inkscape instead of evince / okular

    As Gimp is a GUI program, you are using a GUI with a desktop environment. Thus please explain which one (KDE, Gnome, ...) you are using. Please do not let us do all that guessing.
    Henk van Velden

  4. #4
    Join Date
    May 2011
    Posts
    11

    Default Re: Gimp print preview opens pdf in inkscape instead of evince / okular

    I use Windowmaker, not a desktop environment. Your suggestions made me try, however, to set the file associations of the two desktop environments from within konqueror and nautilus. And bingo, under nautilus I found that gnome had registered inkscape as the default program for pdf's. Don't know why. Anyway, setting that to okular fixed my problem for gimp. I still don't know where gnome stores the file association information but at least it seems to be fixed now. Cheers.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,240

    Default Re: Gimp print preview opens pdf in inkscape instead of evince / okular

    Within KDE it is set from the main Kmenu > System Settings > Common ... (sorry I do not have the English translation begfore my eyes) > File associations. It may be that doing it through Konqueror ends up setting it in the same general KDE config files though. But using the general KDE settings when you want to set something for all KDE inegrated programs looks more logical to me then setting it in a individual program.

    I do not know anything about the Windowmaker you use, so maybe it does not have a built in "file type recogniser" (neither by giving value to the suffix of a file name as most DEs do, or by checking inside the file for a magical number). In any case Linux itself hasn't such a feature, it is purely an application that may offer this.
    Last edited by hcvv; 07-Jun-2014 at 04:02.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •