Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Installing zoneminder

  1. #11

    Arrow Re: Installing zoneminder

    Hi Rasputin,

    Quote Originally Posted by suse_rasputin View Post
    Hi! I installed Zoneminder yesterday on an openSUSE 12.3 without any problems, today, same procedure (same WIKI-page) via YAsT on an openSUSE 13.1 x64, I end up with the very same error, system does not start the Apache...

    Did you succeed in resolving the issue?

    Rasputin
    Sadly I got bogged down and went back to real work :-/

    I also got bitten as when re-installing the zoneminder RPM it triggered a write to /var/run/nologin and locked me out of the machine for a few days until I could get back to the console . That was another episode of tail chasing, before I realised what had caused it. systemd/nologin seems to be an issue that affects many distros.

    I also realised I made a mistake in my original description, I was using the same RPM packages from monex that the OP was (I had missed the repo subscription in zypper). I think the php_admin_flag is specific to earlier versions of apache/php5 modules and so the pre-built RPM is incompatible with 13.1 x64.

    I was also unsure of the correct file ownership/group for /srv/www/htdocs/zm, it seemed sensible for wwwrun:www but think they defaulted to root:root.

    Daniel

  2. #12

    Default Re: Installing zoneminder

    test for reply, otherwise it doesn't work... strange

  3. #13

    Default Re: Installing zoneminder

    I'm in dozends of forumsens, but this software here is nightmare... BOT

    The command line resulting in the error when starting Apache is:

    "php_admin_flag short_open_tag On"

    I simply commented it out and Apache apparently started without problems.

    However, I get an Error 403 when trying to access localhost/zm

    No access rights or index file (there is an index.php in /srv/www/htdocs/zm as in the other installations of zm I have)...

    Really strange...

  4. #14
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,305
    Blog Entries
    2

    Default Re: Installing zoneminder

    A FYI
    I will be opening up a thread on the specific error I'm running into, but following up on the content of this thread...
    I am running the private RPM Monex package(v 1.27.0) at
    https://build.opensuse.org/package/s...age=ZoneMinder

    - I also found that simply commenting out line 3 in /etc/apache2/conf.d/zm.conf resolves the "Invalid command 'php_admin_flag' " error. Based on my research, this command was required when PHP was loaded as an external module in <=PHP3. That's how old the code is...

    But, this RPM package sets up external MySQL authentication without configuring in Apache
    I've posted this issue in a separate Forum thread
    https://forums.opensuse.org/showthre...26#post2653826

    TSU

  5. #15
    Join Date
    May 2010
    Location
    Sunny Greece, Thassos Island
    Posts
    31

    Red face Απ: Re: Installing zoneminder

    Hi,
    I have this same problem here.

    Code:
    linux-5kek:~ # systemctl status apache2.service
    apache2.service - The Apache Webserver
       Loaded: loaded (/usr/lib/systemd/system/apache2.service; enabled)
       Active: failed (Result: exit-code) since Fri 2014-10-10 21:44:46 EEST; 24min ago
      Process: 1520 ExecStop=/usr/sbin/start_apache2 -D SYSTEMD -DFOREGROUND -k graceful-stop (code=exited, status=1/FAILURE)
      Process: 875 ExecStart=/usr/sbin/start_apache2 -D SYSTEMD -DFOREGROUND -k start (code=exited, status=1/FAILURE)
     Main PID: 875 (code=exited, status=1/FAILURE)
       CGroup: /system.slice/apache2.service
    
    Oct 10 21:44:44 linux-5kek start_apache2[875]: AH00526: Syntax error on line 5 of /etc/apache2/conf.d/zm.conf:
    Oct 10 21:44:44 linux-5kek start_apache2[875]: Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server ...iguration
    Oct 10 21:44:44 linux-5kek systemd[1]: apache2.service: main process exited, code=exited, status=1/FAILURE
    Oct 10 21:44:46 linux-5kek start_apache2[1520]: AH00526: Syntax error on line 5 of /etc/apache2/conf.d/zm.conf:
    Oct 10 21:44:46 linux-5kek start_apache2[1520]: Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server...iguration
    Oct 10 21:44:46 linux-5kek systemd[1]: apache2.service: control process exited, code=exited status=1
    Oct 10 21:44:46 linux-5kek systemd[1]: Failed to start The Apache Webserver.
    Oct 10 21:44:46 linux-5kek systemd[1]: Unit apache2.service entered failed state.
    Hint: Some lines were ellipsized, use -l to show in full.
    and
    Code:
    linux-5kek:~ # systemctl status zm.service
    zm.service - ZoneMinder Video Surveillance System
       Loaded: loaded (/usr/lib/systemd/system/zm.service; disabled)
       Active: inactive (dead)



    after reading this last post,
    Quote Originally Posted by tsu2 View Post
    But, this RPM package sets up external MySQL authentication without configuring in Apache
    I've posted this issue in a separate Forum thread
    https://forums.opensuse.org/showthre...26#post2653826
    TSU
    I noticed
    Quote Originally Posted by fburzler View Post
    php5 modules must be enabled !!! (seems php5 is required --- php alone is not working)

    So, I edited /etc/sysconfig/apache2 and on line 109 I added php5 among the others (as adviced in /usr/share/doc/packages/php5/README.SUSE). Saved and restarted apache (rcapache2 restart). After started zm (systemctl start zm.service)
    Now zoneminder works fine!


    Code:
    linux-5kek:~ # systemctl status apache2.service
    apache2.service - The Apache Webserver
       Loaded: loaded (/usr/lib/systemd/system/apache2.service; enabled)
       Active: active (running) since Fri 2014-10-10 22:22:43 EEST; 6s ago
      Process: 1520 ExecStop=/usr/sbin/start_apache2 -D SYSTEMD -DFOREGROUND -k graceful-stop (code=exited, status=1/FAILURE)
     Main PID: 5855 (httpd2-prefork)
       Status: "Processing requests..."
       CGroup: /system.slice/apache2.service
               ├─5855 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -DFOREGROUND -k start
               ├─5872 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -DFOREGROUND -k start
               ├─5873 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -DFOREGROUND -k start
               ├─5874 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -DFOREGROUND -k start
               ├─5875 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -DFOREGROUND -k start
               └─5877 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -DFOREGROUND -k start
    
    Oct 10 22:22:43 linux-5kek systemd[1]: Started The Apache Webserver.
    linux-5kek:~ # systemctl start zm.service
    A really big THANK YOU fburzler, from my heart.
    Dirty Deeds Done Dirt Cheap

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •