Results 1 to 8 of 8

Thread: Upgrade kaffeine

  1. #1

    Default Upgrade kaffeine

    I tried to upgrade kaffeine to play .mp4 files, but it stays at a screen that says configured software repositories. When I click ok, it checks for additional software and just goes back and forth.

    Am I doing something wrong ?
    Thanks, Andy

    openSUSE 13.1 KDE (x86_64)
    Puppy Slacko 5.6.0
    Occasionally Windows XP

  2. #2
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: Upgrade kaffeine

    andy77586 wrote:

    >
    > I tried to upgrade kaffeine to play .mp4 files, but it stays at a screen
    > that says configured software repositories. When I click ok, it checks
    > for additional software and just goes back and forth.
    >
    > Am I doing something wrong ?
    >
    >


    Have you added the packman repos yet?

    For 13.1:
    https://forums.opensuse.org/entry.ph...allation-Guide

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,379
    Blog Entries
    1

    Default Re: Upgrade kaffeine

    Quote Originally Posted by andy77586 View Post
    I tried to upgrade kaffeine to play .mp4 files, but it stays at a screen that says configured software repositories. When I click ok, it checks for additional software and just goes back and forth.

    Am I doing something wrong ?
    Maybe you need to read this guide:

    https://forums.opensuse.org/entry.ph...allation-Guide

    Or if you don't mind '1-click' installs

    http://opensuse-community.org/

  4. #4

    Default Re: Upgrade kaffeine

    One click resulted in this.

    #### YaST2 conflicts list - generated 2014-06-02 06:07:46 ####

    k3b-codecs-2.0.2-18.66.x86_64 requires k3b = 2.0.2-18.66, but this requirement cannot be provided
    uninstallable providers: k3b-2.0.2-18.66.x86_64[Packman Repository]
    [ ] do not install k3b-codecs-2.0.2-18.66.x86_64

    [ ] break k3b-codecs-2.0.2-18.66.x86_64 by ignoring some of its dependencies

    [ ] Following actions will be done:
    downgrade of k3b-2.0.2-29.1.3.x86_64 to k3b-2.0.2-18.66.x86_64
    install k3b-2.0.2-18.66.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de


    ffmpeg-2.2-1.7.x86_64 requires libswscale2 = 2.2, but this requirement cannot be provided
    uninstallable providers: libswscale2-2.2-1.7.i586[Packman Repository]
    libswscale2-2.2-1.7.x86_64[Packman Repository]
    [ ] install libswscale2-2.2-1.7.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de

    [ ] do not install ffmpeg-2.2-1.7.x86_64

    [ ] do not install ffmpeg-2.2-1.7.x86_64

    [ ] break ffmpeg-2.2-1.7.x86_64 by ignoring some of its dependencies



    libxine2-codecs-1.2.5-90.5.x86_64 requires libxine2 = 1.2.5, but this requirement cannot be provided
    uninstallable providers: libxine2-1.2.5-90.5.i586[Packman Repository]
    libxine2-1.2.5-90.5.x86_64[Packman Repository]
    [ ] Following actions will be done:
    install libxine2-1.2.5-90.5.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    install libxine2-pulse-1.2.5-90.5.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    [ ] do not install libxine2-codecs-1.2.5-90.5.x86_64

    [ ] break libxine2-codecs-1.2.5-90.5.x86_64 by ignoring some of its dependencies

    [ ] do not install libxine2-codecs-1.2.5-90.5.x86_64




    #### YaST2 conflicts list END ###
    Thanks, Andy

    openSUSE 13.1 KDE (x86_64)
    Puppy Slacko 5.6.0
    Occasionally Windows XP

  5. #5

    Default AW: Re: Upgrade kaffeine

    Quote Originally Posted by andy77586 View Post
    One click resulted in this.
    You have to choose all the "vendor change"/"openSUSE --> http://packman.links2linux.de" options:

    #### YaST2 conflicts list - generated 2014-06-02 06:07:46 ####

    k3b-codecs-2.0.2-18.66.x86_64 requires k3b = 2.0.2-18.66, but this requirement cannot be provided
    uninstallable providers: k3b-2.0.2-18.66.x86_64[Packman Repository]
    [ ] do not install k3b-codecs-2.0.2-18.66.x86_64

    [ ] break k3b-codecs-2.0.2-18.66.x86_64 by ignoring some of its dependencies

    [x] Following actions will be done:
    downgrade of k3b-2.0.2-29.1.3.x86_64 to k3b-2.0.2-18.66.x86_64
    install k3b-2.0.2-18.66.x86_64 (with vendor change)
    openSUSE -->
    http://packman.links2linux.de


    ffmpeg-2.2-1.7.x86_64 requires libswscale2 = 2.2, but this requirement cannot be provided
    uninstallable providers: libswscale2-2.2-1.7.i586[Packman Repository]
    libswscale2-2.2-1.7.x86_64[Packman Repository]
    [x] install libswscale2-2.2-1.7.x86_64 (with vendor change)
    openSUSE -->
    http://packman.links2linux.de

    [ ] do not install ffmpeg-2.2-1.7.x86_64

    [ ] do not install ffmpeg-2.2-1.7.x86_64

    [ ] break ffmpeg-2.2-1.7.x86_64 by ignoring some of its dependencies



    libxine2-codecs-1.2.5-90.5.x86_64 requires libxine2 = 1.2.5, but this requirement cannot be provided
    uninstallable providers: libxine2-1.2.5-90.5.i586[Packman Repository]
    libxine2-1.2.5-90.5.x86_64[Packman Repository]
    [x] Following actions will be done:
    install libxine2-1.2.5-90.5.x86_64 (with vendor change)
    openSUSE -->
    http://packman.links2linux.de
    install libxine2-pulse-1.2.5-90.5.x86_64 (with vendor change)
    openSUSE -->
    http://packman.links2linux.de
    [ ] do not install libxine2-codecs-1.2.5-90.5.x86_64

    [ ] break libxine2-codecs-1.2.5-90.5.x86_64 by ignoring some of its dependencies

    [ ] do not install libxine2-codecs-1.2.5-90.5.x86_64




    #### YaST2 conflicts list END ###

  6. #6

    Default Re: Upgrade kaffeine

    And this with the second link.

    zypper install libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2 flash-player dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux k3b-codecs gecko-mediaplayer vlc smplayer h264enc x264 gstreamer-plugins-libav vlc-codecs
    Loading repository data...
    Reading installed packages...
    'gstreamer-plugins-base' is already installed.
    There is an update candidate for 'gstreamer-plugins-base', but it is from a different vendor. Use 'zypper install gstreamer-plugins-base-1.2.4-2.10.x86_64' to install this candidate.
    'vlc' is already installed.
    No update candidate for 'vlc-2.1.4-211.2.x86_64'. The highest available version is already installed.
    'gstreamer-0_10-plugins-good' is already installed.
    There is an update candidate for 'gstreamer-0_10-plugins-good', but it is from a different vendor. Use 'zypper install gstreamer-0_10-plugins-good-0.10.31-17.14.x86_64' to install this candidate.
    'gstreamer-0_10-plugins-ffmpeg' is already installed.
    No update candidate for 'gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.4.x86_64'. The highest available version is already installed.
    'flash-player' is already installed.
    No update candidate for 'flash-player-11.2.202.359-50.1.x86_64'. The highest available version is already installed.
    'libdvdcss2' is already installed.
    No update candidate for 'libdvdcss2-1.2.13-5.2.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    7 Problems:
    Problem: gstreamer-plugins-ugly-1.2.4-2.1.x86_64 requires gstreamer >= 1.2.0, but this requirement cannot be provided
    Problem: gstreamer-plugins-good-1.2.4-2.3.x86_64 requires gstreamer-plugins-base >= 1.2.3, but this requirement cannot be provided
    Problem: k3b-codecs-2.0.2-18.66.x86_64 requires k3b = 2.0.2-18.66, but this requirement cannot be provided
    Problem: ffmpeg-2.2-1.7.x86_64 requires libavutil52 = 2.2, but this requirement cannot be provided
    Problem: gstreamer-plugins-bad-1.2.4-6.15.x86_64 requires gstreamer >= 1.2.0, but this requirement cannot be provided
    Problem: h264enc-10.0.5-245.1.noarch requires gpac, but this requirement cannot be provided
    Problem: libxine2-codecs-1.2.5-90.5.x86_64 requires libxine2 = 1.2.5, but this requirement cannot be provided

    Problem: gstreamer-plugins-ugly-1.2.4-2.1.x86_64 requires gstreamer >= 1.2.0, but this requirement cannot be provided
    uninstallable providers: gstreamer-1.2.4-3.7.i586[Packman Repository]
    gstreamer-1.2.4-3.7.x86_64[Packman Repository]
    gstreamer-1.2.4-3.7.i586[packman]
    gstreamer-1.2.4-3.7.x86_64[packman]
    Solution 1: Following actions will be done:
    do not install gstreamer-plugins-ugly-1.2.4-2.1.x86_64
    do not install gstreamer-plugins-good-extra-1.2.4-2.3.x86_64
    do not install gstreamer-plugins-bad-orig-addon-1.2.4-6.15.x86_64
    Solution 2: Following actions will be done:
    do not installr'. [1/2/3/4/s/r/c] (c): xtra-1.2.4-2.3.x86_64
    do not install gstreamer-plugins-ugly-1.2.4-2.1.x86_64
    do not install gstreamer-plugins-bad-orig-addon-1.2.4-6.15.x86_64
    Solution 3: install gstreamer-1.2.4-3.7.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    Solution 4: break gstreamer-plugins-ugly-1.2.4-2.1.x86_64 by ignoring some of its dependencies
    Thanks, Andy

    openSUSE 13.1 KDE (x86_64)
    Puppy Slacko 5.6.0
    Occasionally Windows XP

  7. #7

    Default AW: Re: Upgrade kaffeine

    Quote Originally Posted by andy77586 View Post
    And this with the second link.
    Again, you have to choose the "vendor change"/"openSUSE --> http://packman.links2linux.de" option in _each_ case:

    zypper install libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2 flash-player dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux k3b-codecs gecko-mediaplayer vlc smplayer h264enc x264 gstreamer-plugins-libav vlc-codecs
    Loading repository data...
    Reading installed packages...
    'gstreamer-plugins-base' is already installed.
    There is an update candidate for 'gstreamer-plugins-base', but it is from a different vendor. Use 'zypper install gstreamer-plugins-base-1.2.4-2.10.x86_64' to install this candidate.
    'vlc' is already installed.
    No update candidate for 'vlc-2.1.4-211.2.x86_64'. The highest available version is already installed.
    'gstreamer-0_10-plugins-good' is already installed.
    There is an update candidate for 'gstreamer-0_10-plugins-good', but it is from a different vendor. Use 'zypper install gstreamer-0_10-plugins-good-0.10.31-17.14.x86_64' to install this candidate.
    'gstreamer-0_10-plugins-ffmpeg' is already installed.
    No update candidate for 'gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.4.x86_64'. The highest available version is already installed.
    'flash-player' is already installed.
    No update candidate for 'flash-player-11.2.202.359-50.1.x86_64'. The highest available version is already installed.
    'libdvdcss2' is already installed.
    No update candidate for 'libdvdcss2-1.2.13-5.2.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    7 Problems:
    Problem: gstreamer-plugins-ugly-1.2.4-2.1.x86_64 requires gstreamer >= 1.2.0, but this requirement cannot be provided
    Problem: gstreamer-plugins-good-1.2.4-2.3.x86_64 requires gstreamer-plugins-base >= 1.2.3, but this requirement cannot be provided
    Problem: k3b-codecs-2.0.2-18.66.x86_64 requires k3b = 2.0.2-18.66, but this requirement cannot be provided
    Problem: ffmpeg-2.2-1.7.x86_64 requires libavutil52 = 2.2, but this requirement cannot be provided
    Problem: gstreamer-plugins-bad-1.2.4-6.15.x86_64 requires gstreamer >= 1.2.0, but this requirement cannot be provided
    Problem: h264enc-10.0.5-245.1.noarch requires gpac, but this requirement cannot be provided
    Problem: libxine2-codecs-1.2.5-90.5.x86_64 requires libxine2 = 1.2.5, but this requirement cannot be provided

    Problem: gstreamer-plugins-ugly-1.2.4-2.1.x86_64 requires gstreamer >= 1.2.0, but this requirement cannot be provided
    uninstallable providers: gstreamer-1.2.4-3.7.i586[Packman Repository]
    gstreamer-1.2.4-3.7.x86_64[Packman Repository]
    gstreamer-1.2.4-3.7.i586[packman]
    gstreamer-1.2.4-3.7.x86_64[packman]
    Solution 1: Following actions will be done:
    do not install gstreamer-plugins-ugly-1.2.4-2.1.x86_64
    do not install gstreamer-plugins-good-extra-1.2.4-2.3.x86_64
    do not install gstreamer-plugins-bad-orig-addon-1.2.4-6.15.x86_64
    Solution 2: Following actions will be done:
    do not installr'. [1/2/3/4/s/r/c] (c): xtra-1.2.4-2.3.x86_64
    do not install gstreamer-plugins-ugly-1.2.4-2.1.x86_64
    do not install gstreamer-plugins-bad-orig-addon-1.2.4-6.15.x86_64
    Solution 3: install gstreamer-1.2.4-3.7.x86_64 (with vendor change)
    openSUSE -->
    http://packman.links2linux.de
    Solution 4: break gstreamer-plugins-ugly-1.2.4-2.1.x86_64 by ignoring some of its dependencies
    So in this case it's option 3.
    But this is completely unrelated to Kaffeine.
    Last edited by wolfi323; 02-Jun-2014 at 04:29.

  8. #8

    Default Re: Upgrade kaffeine

    Thanks, Kafeine was successfully upgraded.
    Thanks, Andy

    openSUSE 13.1 KDE (x86_64)
    Puppy Slacko 5.6.0
    Occasionally Windows XP

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •