Results 1 to 4 of 4

Thread: Apache init script vanished afetr kernel update

  1. #1

    Default Apache init script vanished afetr kernel update

    Upon kernel update kernel-default-3.11.10-11.1 on Opensuse 13.1, Apache init script just disappeared and obviously Apache didn't start after reboot.

  2. #2

    Default Re: Apache init script vanished afetr kernel update

    Quote Originally Posted by ronin77 View Post
    Upon kernel update kernel-default-3.11.10-11.1 on Opensuse 13.1, Apache init script just disappeared and obviously Apache didn't start after reboot.
    What do you mean exactly with "disappear"?

    Is there no /etc/init.d/apache2 any more, or what?
    That's definitely _not_ related to the kernel update, I'd say, but there was an Apache2 update as well.

    And Apache2 is not started via that init script any more anyway, it contains a native systemd service file (/usr/lib/systemd/system/apache2.service).
    But that change is not new. This already was the case when 13.1 was released. Only the latest update _removed_ that init file, as it was not used anyway.

    So what exactly is your problem?
    That apache2 suddenly doesn't start any more at boot?

    Please post the output of:
    Code:
    sudo systemctl status apache2.service
    This works fine here, btw. Nothing has changed here after the latest updates, apache is started without problems during boot.

    Try to enable apache2.service, either in YaST->System->Services Manager, or by running:
    Code:
    sudo systemctl enable apache2.service
    It should be started at boot then.
    Last edited by wolfi323; 28-May-2014 at 02:41.

  3. #3

    Default Re: Apache init script vanished after kernel update

    here's the output you requested:

    Code:
    # systemctl status apache2.service
    apache2.service - The Apache Webserver
       Loaded: loaded (/usr/lib/systemd/system/apache2.service; enabled)
       Active: active (running) since Wed 2014-05-28 10:50:51 CEST; 1h 16min ago
      Process: 6187 ExecStop=/usr/sbin/start_apache2 -D SYSTEMD -DFOREGROUND -k graceful-stop (code=exited, status=0/SUCCESS)
     Main PID: 6207 (httpd2-worker)
       Status: "Total requests: 14; Current requests/sec: 0; Current traffic:   0 B/sec"
       CGroup: /system.slice/apache2.service
               ├─6207 /usr/sbin/httpd2-worker -f /etc/apache2/httpd.conf -DSSL -DFPM -D SYSTEMD -DFOREGROUND -k start
               ├─6223 /usr/sbin/httpd2-worker -f /etc/apache2/httpd.conf -DSSL -DFPM -D SYSTEMD -DFOREGROUND -k start
               ├─6224 /usr/sbin/httpd2-worker -f /etc/apache2/httpd.conf -DSSL -DFPM -D SYSTEMD -DFOREGROUND -k start
               └─6225 /usr/sbin/httpd2-worker -f /etc/apache2/httpd.conf -DSSL -DFPM -D SYSTEMD -DFOREGROUND -k start
    
    May 28 10:50:51 merkur-appsrv-1 systemd[1]: Started The Apache Webserver.
    and yes,

    Code:
    systemctl enable apache2.service
    did work...

  4. #4

    Default Re: Apache init script vanished after kernel update

    Quote Originally Posted by ronin77 View Post
    here's the output you requested:
    Apache is running now.

    So your problem is solved?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •