Hi there. I have a problem with Autoyast installation, and I am hoping that someone can help me. Here i t is:

Autoyast installs system successfully, but it fails to create additional users, and to change the root password. Here's the autoyast file:

Code:
<?xml version="1.0"?>
<!DOCTYPE profile>
<profile xmlns="http://www.suse.com/1.0/yast2ns" xmlns:config="http://www.suse.com/1.0/configns">
  <add-on>
    <add_on_products config:type="list">
      <listentry>
        <media_url><![CDATA[http://mirror/opensuse/distribution/13.1/repo/oss/]]></media_url>
        <product>openSUSE</product>
        <product_dir>/</product_dir>
      </listentry>
      <listentry>
        <media_url><![CDATA[http://mirror/opensuse/distribution/13.1/repo/non-oss/]]></media_url>
        <product>openSUSE 13.1 NonOSS Add on</product>
        <product_dir>/</product_dir>
      </listentry>
      <listentry>
        <media_url><![CDATA[http://mirror/opensuse/update/13.1/]]></media_url>
        <product>Update</product>
        <product_dir>/</product_dir>
      </listentry>
      <listentry>
        <media_url><![CDATA[http://mirror/opensuse/update/13.1-non-oss/]]></media_url>
        <product>Update Non-oss</product>
        <product_dir>/</product_dir>
      </listentry>
    </add_on_products>
  </add-on>
  <bootloader config:type="boolean">false</bootloader>
  <deploy_image>
    <image_installation config:type="boolean">false</image_installation>
  </deploy_image>
  <firewall>
    <start_firewall config:type="boolean">false</start_firewall>
  </firewall>
  <general>
    <ask-list config:type="list"/>
    <mode>
      <confirm config:type="boolean">false</confirm>
      <final_halt config:type="boolean">false</final_halt>
      <final_reboot config:type="boolean">true</final_reboot>
      <halt config:type="boolean">false</halt>
      <second_stage config:type="boolean">true</second_stage>
    </mode>
    <proposals config:type="list"/>
    <signature-handling>
      <accept_file_without_checksum config:type="boolean">true</accept_file_without_checksum>
      <accept_non_trusted_gpg_key config:type="boolean">true</accept_non_trusted_gpg_key>
      <accept_unknown_gpg_key config:type="boolean">true</accept_unknown_gpg_key>
      <accept_unsigned_file config:type="boolean">true</accept_unsigned_file>
      <accept_verification_failed config:type="boolean">true</accept_verification_failed>
      <import_gpg_key config:type="boolean">true</import_gpg_key>
    </signature-handling>
    <storage/>
  </general>
  <groups config:type="list"/>
  <keyboard>
    <keymap>english-us</keymap>
  </keyboard>
  <login_settings/>
  <networking>
    <dns>
      <dhcp_hostname config:type="boolean">false</dhcp_hostname>
      <domain>office.sw4i.com</domain>
      <hostname>filip</hostname>
      <resolv_conf_policy>auto</resolv_conf_policy>
      <write_hostname config:type="boolean">false</write_hostname>
    </dns>
    <ipv6 config:type="boolean">true</ipv6>
    <keep_install_network config:type="boolean">false</keep_install_network>
    <managed config:type="boolean">true</managed>
    <routing>
      <ip_forward config:type="boolean">false</ip_forward>
    </routing>
  </networking>
  <partitioning config:type="list">
    <drive>
      <initialize config:type="boolean">true</initialize>
      <partitions config:type="list">
        <partition>
          <create config:type="boolean">true</create>
          <crypt_fs config:type="boolean">false</crypt_fs>
          <filesystem config:type="symbol">swap</filesystem>
          <filesystem_id config:type="integer">131</filesystem_id>
          <format config:type="boolean">true</format>
          <loop_fs config:type="boolean">false</loop_fs>
          <mountby config:type="symbol">device</mountby>
          <partition_id config:type="integer">131</partition_id>
          <partition_nr config:type="integer">1</partition_nr>
          <pool config:type="boolean">false</pool>
          <resize config:type="boolean">false</resize>
          <size>1G</size>
        </partition>
        <partition>
          <create config:type="boolean">true</create>
          <crypt_fs config:type="boolean">false</crypt_fs>
          <filesystem config:type="symbol">ext4</filesystem>
          <filesystem_id config:type="integer">131</filesystem_id>
          <format config:type="boolean">true</format>
          <loop_fs config:type="boolean">false</loop_fs>
          <mount>/</mount>
          <mountby config:type="symbol">device</mountby>
          <partition_id config:type="integer">131</partition_id>
          <partition_nr config:type="integer">2</partition_nr>
          <pool config:type="boolean">false</pool>
          <resize config:type="boolean">false</resize>
          <size>max</size>
        </partition>
      </partitions>
      <type config:type="symbol">CT_DISK</type>
      <use>all</use>
    </drive>
  </partitioning>
  <scripts>
    <init-scripts config:type="list">
      <script>
        <filename>zzz_reboot</filename>
        <source><![CDATA[chkconfig autoyast off
shutdown -r now]]></source>
      </script>
      <script>
        <filename>zzz_reboot</filename>
        <source><![CDATA[chkconfig autoyast off
shutdown -r now]]></source>
      </script>
    </init-scripts>
  </scripts>
  <software>
    <instsource>http://mirror/opensuse/distribution/13.1/repo/oss/</instsource>
    <packages config:type="list">
      <package>htop</package>
      <package>autoyast2-installation</package>
    </packages>
    <patterns config:type="list">
      <pattern>base</pattern>
    </patterns>
  </software>
  <timezone>
    <hwclock>UTC</hwclock>
    <timezone>Europe/Belgrade</timezone>
  </timezone>
  <user_defaults>
    <group>100</group>
    <groups/>
    <home>/home</home>
    <inactive>-1</inactive>
    <no_groups config:type="boolean">true</no_groups>
    <shell>/bin/bash</shell>
    <skel>/etc/skel</skel>
    <umask>022</umask>
  </user_defaults>
  <users config:type="list">
    <user>
      <encrypted config:type="boolean">true</encrypted>
      <fullname>sw4iadmin</fullname>
      <gid>100</gid>
      <home>/home/sw4iadmin</home>
      <password_settings>
        <inact>-1</inact>
        <max>99999</max>
        <min>0</min>
        <warn>7</warn>
      </password_settings>
      <shell>/bin/bash</shell>
      <uid>100</uid>
      <user_password>$6$zP/1GHaWvav5$mBhpzzAgiA30hX4KsmfA/NTvS07Ue22OpW7ijV0Up79rouuhmwhbPWl5FWYkfnGUt1u5r/A1VXtqUJ1Vdo.l1/</user_password>
      <username>sw4iadmin</username>
    </user>
    <user>
      <encrypted config:type="boolean">true</encrypted>
      <fullname>root</fullname>
      <gid>0</gid>
      <home>/root</home>
      <password_settings>
        <inact>-1</inact>
        <max>-1</max>
        <min>-1</min>
        <warn>-1</warn>
      </password_settings>
      <shell>/bin/bash</shell>
      <uid>0</uid>
      <user_password>$6$jaJT8c5eGNsY$vlCXAZRkpHYzc/15wXldvOTgq9iQ.KHwBHE1xXZQweyIq/lkX/toXQTFMgRsbyJYUIZKuh90ZVJDUyikVYf6K1</user_password>
      <username>root</username>
    </user>
  </users>
</profile>