Results 1 to 9 of 9

Thread: ifup managed network service boot delay

  1. #1

    Default ifup managed network service boot delay

    When I start my computer, something called
    starting ifup managed network service
    takes as much time as starting all the other services combined. I have openSUSE installed on a SSD drive, and my CPU is a modern amd 8core so I'm sure my computer is supposed to be able to start faster. This comp was originally built as a gaming rig, but now I'm using it as my main programming workstation.

    So my questions are: Is there possibly a problem with the service? What does it do? Can I replace it with something else? Is is supposed to take that long? etc.

    Basically I just want to speed up my boot time, and the ifup network service is causing the biggest delay, so I will appreciate any suggestions, thank you very much.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,469

    Default Re: ifup managed network service boot delay

    First, please tell which version of openSUSE you use.
    Henk van Velden

  3. #3

    Default Re: ifup managed network service boot delay

    Quote Originally Posted by hcvv View Post
    First, please tell which version of openSUSE you use.
    Code:
    OS: openSUSE 13.1 Bottle
    Kernel: x86_64 Linux 3.11.10-11-desktop
    CPU: AMD FX-8120 Eight-Core @ 3.1GHz
    GPU: AMD/ATI Cayman XT [Radeon HD 6970]
    RAM: 1946MB / 7981MB

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,310

    Default Re: ifup managed network service boot delay

    ifup is the basic network service. Without that you do not have a network.

    If this is to be used on a wireless network you might want to change to networkmanager. This can be done in Yast-Network

    In any case it may indicate the network is slow to connect. In any case do not just remove it if you want the machine networked.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,469

    Default Re: ifup managed network service boot delay

    And how is your network. Cable or Wifi, using DHCP or not. When you want to find out why starting the network takes so much time, you must study the details. When you want our help, you must provide the details.
    Henk van Velden

  6. #6

    Default Re: ifup managed network service boot delay

    Quote Originally Posted by gogalthorp View Post
    In any case it may indicate the network is slow to connect. In any case do not just remove it if you want the machine networked.
    I'm pretty confident the problem has something to do with my opensuse installation. I used Ubuntu before moving to this, and that booted faster. Of course, I'm not 100% sure of anything.

    Quote Originally Posted by hcvv View Post
    And how is your network. Cable or Wifi, using DHCP or not. When you want to find out why starting the network takes so much time, you must study the details. When you want our help, you must provide the details.
    No problem!

    It's cable, dhcp.

  7. #7

    Default Re: ifup managed network service boot delay

    Quote Originally Posted by MikkoFinell View Post
    I'm pretty confident the problem has something to do with my opensuse installation. I used Ubuntu before moving to this, and that booted faster. Of course, I'm not 100% sure of anything.
    You could try to switch to NetworkManager (that's what Ubuntu uses I suppose) in YaST->Network Devices->Network Settings->Global Options.

    NetworkManager should not delay the boot until the network connection is established, which might give you a faster boot time.
    But you might run into troubles of course if the network is not available in time for services that need it.

  8. #8

    Default Re: ifup managed network service boot delay

    I think I managed to fix it myself. Here is what I did:

    I didn't touch the network settings since installation, because I'm not into that stuff enough yet to really know what anything is. For some reason, there was two connections, one with IP 0.0.0.0, and the other a DHCP bridged connection ("why didn't you mention that from the start!?"). I don't understand why that's the default set up, or really what a bridged connection is. Anyway, I deleted the bridge connection and set the other one to DHCP. Now there is no pause when starting the service, and my computer boot time increased probably 3x (there was a big delay as I originally mentioned in OP, and another delay when setting up the br0 bridge.)

    Thank you guys anyway for helping me troubleshoot, I'm really enjoying this very quick boot up that I knew was supposed to be happening.

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,469

    Default Re: ifup managed network service boot delay

    Very good you solved it yourself

    Indeed, in a "normal" installation there shouldn't be a bridge of course. Something went wrong there, but it is a bit difficult to guess what. Except when you took notes about what you did during installation (not a bad idea IMHO).
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •