Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Restarted PC and now can't boot in

  1. #1

    Default Restarted PC and now can't boot in

    I did a few changes and also installed Nvidia drivers and ran the program which said:

    "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

    this gives the following

    Code:
    linux-31zr:/home/ross # nvidia-xconfig
    
    Using X configuration file: "/etc/X11/xorg.conf".
    Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
    New X configuration file written to '/etc/X11/xorg.conf'
    and now when I boot into Linux all I get is the loading screen and then after a while it goes to a konsole and says

    Code:
    Welcome to Opensuse 13.1 "Bottle" - Kernel 3.11.10-11-desktop (tty1)
    
    Linux-31zr login:
    What just happened and how can I get back into my desktop!? Whether that was the cause of the problem I'm not sure.

    Many thanks in advance

  2. #2

    Default Re: Restarted PC and now can't boot in

    Quote Originally Posted by thestig View Post
    I did a few changes and also installed Nvidia drivers and ran the program which said:

    "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

    this gives the following

    Code:
    linux-31zr:/home/ross # nvidia-xconfig
    
    Using X configuration file: "/etc/X11/xorg.conf".
    Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
    New X configuration file written to '/etc/X11/xorg.conf'
    You should _not_ need to run nvidia-xconfig.

    and now when I boot into Linux all I get is the loading screen and then after a while it goes to a konsole and says

    Code:
    Welcome to Opensuse 13.1 "Bottle" - Kernel 3.11.10-11-desktop (tty1)
    
    Linux-31zr login:
    What just happened and how can I get back into my desktop!? Whether that was the cause of the problem I'm not sure.

    Many thanks in advance
    Apparently the nvidia driver cannot be loaded. But the xorg.conf you created (with nvidia-xconfig) tells Xorg to use the nvidia driver, so it fails to start.

    Boot to "Recovery Mode". And remove the file /etc/X11/xorg.conf to get Xorg working again. Or maybe even copy back the /etc/X11/xorg.conf.backup

    Then we can take a look at why the nvidia driver didn't/doesn't work:

    How exactly did you install the nvidia driver? (via the repo or by downloading it from nvidia's homepage)
    What version did you install? What graphics card do you have?

    Please post the output of:
    Code:
    rpm -qa | egrep "kernel|nvidia"

  3. #3

    Default Re: Restarted PC and now can't boot in

    I think I added the repo but looks like I only downloaded a config file or something, I've just downloaded from here

    http://www.nvidia.com/content/Driver...s&type=GeForce

    But when I try to run it I get the following

    Code:
    There is no specialized application for files of the type shell script (application/x-shellscript).The file can be opened in a more generic application as file type plain text document (text/plain), or you can try to install a specialized application for file type shell script (application/x-shellscript).
    Do you want to try to install a specialized application?
    Hitting yes leads to:

    Code:
    The software to install could not be found in the currently enabled software repositories.It may be located in other repositories.
    See http://help.opensuse.org/ksuseinstall for details.
    Do you want to configure your repositories?
    It's a nvidia GForce GT630

    Code:
    ross@linux-31zr:~> rpm -qa | egrep "kernel|nvidia"x11-video-nvidiaG02-304.119-34.1.x86_64
    kernel-devel-3.11.10-11.1.noarch
    nvidia-computeG02-304.119-34.1.x86_64
    kernel-desktop-3.11.10-11.1.x86_64
    kernel-desktop-devel-3.11.10-11.1.x86_64
    kernel-firmware-20130714git-2.13.1.noarch
    nvidia-gfxG02-kmp-desktop-304.119_k3.11.6_4-33.1.x86_64
    kernel-desktop-3.11.6-4.1.x86_64
    ross@linux-31zr:~>

  4. #4

    Default Re: Restarted PC and now can't boot in

    Quote Originally Posted by thestig View Post
    I used the 1click install from here

    http://en.opensuse.org/SDB:NVIDIA_drivers

    and clicking the 2nd one down. It's a nvidia GForce GT630
    The GT630 is supported by the latest driver G03 (i.e. the first 1click install). The G02 driver is mainly needed for GeForce 6 (and 7) series, not 600.
    But the G02 driver should actually work as well with your card.

    Your package list looks ok.
    Could you please post your /var/log/Xorg.0.log (from a normal boot, i.e. when the system tries to load the nvidia driver)?
    If normal boot doesn't work, please boot to recovery mode and post /var/log/Xorg.0.log.old then.
    Upload it to http://susepaste.org or similar and post a link.

    As the GT630 is relatively new, it might be the G02 driver which causes the problem.
    So you might try to install the G03 one. But better do _not_ use the 1-click install (this could cause _both_ drivers installed which wouldn't work either).
    Uninstall the three nvidia packages (nvidia-gfxG02-kmp-desktop, nvidia-computeG02, x11-video-nvidiaG02) in YaST, then enter YaST again and install those 4:
    nvidia-gfxG03-kmp-desktop, nvidia-computeG03, x11-video-nvidiaG03, nvidia-glG03

    Or run this on the command line:
    Code:
    sudo rpm -envidia-gfxG02-kmp-desktop nvidia-computeG02 x11-video-nvidiaG02
    sudo zypper in nvidia-gfxG03-kmp-desktop nvidia-computeG03x11-video-nvidiaG03 nvidia-glG03

  5. #5
    Join Date
    Nov 2010
    Location
    Texas, USA
    Posts
    97

    Default Re: Restarted PC and now can't boot in

    For a GT 630 you want the G03 driver (331.67) as stated in the
    "Supported Products" Tab of the Nvidia Linux Driver page

    http://www.nvidia.com/download/drive...px/75019/en-us

    I use that driver with my GT 610 card. It works just fine.

  6. #6

    Default Re: Restarted PC and now can't boot in

    Thanks again guys....right

    I didn't use the 1click but manually went to nvidia and downloaded the correct drivers (331.67) and ran it in console but got the following error

    Code:
      ERROR: You appear to be running an X server; please exit X before installing.  For further               details, please see the section INSTALLING THE NVIDIA DRIVER in the README available on  
             the Linux driver download page at www.nvidia.com.

    and then after I click enter for "OK"

    Code:
      ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for                 details.  You may find suggestions on fixing installation problems in the README         
             available on the Linux driver download page at www.nvidia.com.
    Running "/var/log/Xorg.0.log" gives this (even as SU)

    Code:
    ross@linux-31zr:~> su
    Password: 
    linux-31zr:/home/ross # /var/log/Xorg.0.log
    bash: /var/log/Xorg.0.log: Permission denied


    I sense we're nearly there!

  7. #7

    Default Re: Restarted PC and now can't boot in

    edit - since installing the drivers I ran nvidia-xconfig again and rebooted and nvidia appears to be "running the show" but it certainly needs configuring! The fonts are massive and the icons are quite small. As SU in a konsole I open the nvidia settings program but can't seem to figure out how to get the correct size? It's even worse than before now lol

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,167
    Blog Entries
    3

    Default Re: Restarted PC and now can't boot in

    Quote Originally Posted by thestig View Post
    Code:
      ERROR: You appear to be running an X server; please exit X before installing.  For further               details, please see the section INSTALLING THE NVIDIA DRIVER in the README available on  
             the Linux driver download page at www.nvidia.com.
    I get that when installing the hard way.

    I use ALT-CTRL-F1 to get a console, and login as root.

    I then use
    Code:
    # telinit 3
    to shutdown the X-server.

    I then install the drivers (304.121 in my case). Then I reboot, and it usually works.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9

    Default Re: Restarted PC and now can't boot in

    Quote Originally Posted by nrickert View Post
    I get that when installing the hard way.

    I use ALT-CTRL-F1 to get a console, and login as root.

    I then use
    Code:
    # telinit 3
    to shutdown the X-server.

    I then install the drivers (304.121 in my case). Then I reboot, and it usually works.
    Here is a screenshot I took to give you an idea. It actually puts the full desktop on, but some is cut off from what i actually see. Basically, I can JUST see the botton of the characters for the word "Desktop" at the top right of the screen (you see such a small amount you can't tell it reads Desktop", and at the bottom, the same is the case for the taskbar, you can't make out any of it in reality. You also see the fonts are absolutely massive.



    Any ideas?

  10. #10

    Default Re: Restarted PC and now can't boot in

    Quote Originally Posted by thestig View Post
    I didn't use the 1click but manually went to nvidia and downloaded the correct drivers (331.67) and ran it in console but got the following error
    Why?
    I gave the exact zypper command line.

    This complicates things further.
    And did you completely remove the G02 driver first?

    Code:
      ERROR: You appear to be running an X server; please exit X before installing.  For further               details, please see the section INSTALLING THE NVIDIA DRIVER in the README available on  
             the Linux driver download page at www.nvidia.com.

    and then after I click enter for "OK"

    Code:
      ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for                 details.  You may find suggestions on fixing installation problems in the README         
             available on the Linux driver download page at www.nvidia.com.
    You have to install this in text mode.
    Or use a command line switch to ignore the running Xorg.

    Running "/var/log/Xorg.0.log" gives this (even as SU)

    Code:
    ross@linux-31zr:~> su
    Password: 
    linux-31zr:/home/ross # /var/log/Xorg.0.log
    bash: /var/log/Xorg.0.log: Permission denied

    You are trying to _run_ the log file.
    This doesn't work, it is just a normal text file.

    Open it with a text editor or simething. And you don't even need root permissions for that.
    But at the moment it won't be of much help anyway I suppose.

    I sense we're nearly there!

    Not really.
    Last edited by wolfi323; 24-May-2014 at 07:16.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •