Results 1 to 7 of 7

Thread: Window focus problem entering password for printer

  1. #1

    Default Window focus problem entering password for printer

    I need to change the error policy on a printer queue. I can't seem to find a way to do that in the CUPS web interface. Is there a way?

    The alternative, using "System Settings"->Hardware->Printers won't work for me. It first asks for the root password, which I enter. Then I go to Configure->"Banners, Policies and Allowed Users" and select the error policy. When I click "Apply" I get another prompt for the root password, but the password dialogue box won't take the focus, so I can't enter it.

    I've tried setting special window properties and disabling focus stealing prevention, etc. Although I can then get the dialogue to accept the focus, nothing happens when I type. So I'm stuck. I've tried from several accounts - all the same.

    Final possibility?? Is there a config file somewhere I can edit?

    Thanks for any help getting the error policy changed, but ideally I'd also like to fix the password focus problem as it'll be getting in the way whenever I need to to printer things...

    I'm on openSUSE 13.1, KDE 4.11.5 & CUPS 1.5.4

  2. #2

    Default AW: Window focus problem entering password for printer

    Quote Originally Posted by xanti View Post
    I need to change the error policy on a printer queue. I can't seem to find a way to do that in the CUPS web interface. Is there a way?

    The alternative, using "System Settings"->Hardware->Printers won't work for me. It first asks for the root password, which I enter. Then I go to Configure->"Banners, Policies and Allowed Users" and select the error policy. When I click "Apply" I get another prompt for the root password, but the password dialogue box won't take the focus, so I can't enter it.

    I've tried setting special window properties and disabling focus stealing prevention, etc. Although I can then get the dialogue to accept the focus, nothing happens when I type. So I'm stuck. I've tried from several accounts - all the same.
    This is a bug.
    See also https://forums.opensuse.org/showthre...dow-priorities
    https://bugs.kde.org/show_bug.cgi?id=328014

    Final possibility?? Is there a config file somewhere I can edit?
    Run systemsettings or the printer configuration module as root:
    Code:
    kdesu systemsettings
    or
    Code:
    kdesu kcmshell4 kcm_printer_manager

  3. #3

    Default AW: Window focus problem entering password for printer

    PS:
    Quote Originally Posted by xanti View Post
    I need to change the error policy on a printer queue. I can't seem to find a way to do that in the CUPS web interface. Is there a way?
    Yes, this is indeed possible.
    Go to "http://localhost:631/", click on "Printers", click on your printer, and choose "Set Default Options" in the chooser that originally displays "Administration".
    When asked for username and password, enter "root" as username and the root password.
    Then click on "Policies" there to change the error policy.

  4. #4

    Default Re: Window focus problem entering password for printer

    Wow. Thanks for those speedy replies... they seem to cover everything... policy now changed!

  5. #5

    Default Re: Window focus problem entering password for printer

    Hmm. I tried using:

    Code:
    kdesu kcmshell4 kcm_printer_manager

    and it worked. So I set up a desktop icon for this. But when I used it a second time, the "Configure" button in the printer config dialogue didn't do anything, although all the other buttons seemed to still work.

    Playing around, it seems you can only get into the "Configure" part the first time. After that, you need to log out and back in before you can use it again. Any idea why that might be?

  6. #6

    Default Re: Window focus problem entering password for printer

    Quote Originally Posted by xanti View Post
    Hmm. I tried using:

    Code:
    kdesu kcmshell4 kcm_printer_manager

    and it worked. So I set up a desktop icon for this. But when I used it a second time, the "Configure" button in the printer config dialogue didn't do anything, although all the other buttons seemed to still work.
    If you setup a desktop icon for this, don't use "kdesu".
    Just set "Run as a different user" in the icons properties.

    But I can reproduce the problem you mention. It only works once, but I have no idea why.
    Must be another bug.

  7. #7

    Default Re: Window focus problem entering password for printer

    Quote Originally Posted by wolfi323 View Post
    If you setup a desktop icon for this, don't use "kdesu".
    Just set "Run as a different user" in the icons properties.
    Thanks, that's a useful tip to know.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •