Results 1 to 5 of 5

Thread: Can't update via apper

  1. #1
    Join Date
    Dec 2008
    Location
    Montevideo, Uruguay
    Posts
    453

    Question Can't update via apper

    I'm using opensuse 13.1 and I have 2 pending updates to do but both of them give me some error:

    libavcodec55 when trying to update:

    A package dependency could not be found.

    More information is available in the detailed report.

    Detail:

    There is no update candidate for libavcodec55-2.1.1-2.1.x86_64

    libavformat55 when trying to to update:
    A package dependency could not be found.

    More information is available in the detailed report.

    Detail:

    There is no update candidate for libavformat55-2.1.1-2.1.x86_64


    Any clue ?

    thanks in advance for any feedback

    agunet
    agunet74

  2. #2

    Default Re: Can't update via apper

    Please post your repo list.
    Code:
    zypper lr -d
    Probably this is related to the ffmpeg update to 2.2.
    Run "sudo zypper up" in a terminal window and post the error messages.
    If you get a conflict about libavfilter, select "deinstall libavfilter3" and the update should work.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,749
    Blog Entries
    3

    Default Re: Can't update via apper

    Quote Originally Posted by agunet74 View Post
    Ilibavcodec55 when trying to update:

    A package dependency could not be found.
    Apper is poor at handling conflicts -- it just aborts.

    Whenever that happens, use either zypper (at the command line), or Yast online update (if you prefer a GUI). Either way gives you suggestions and a menu to deal with the problem.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Can't update via apper

    Quote Originally Posted by nrickert View Post
    Whenever that happens, use either zypper (at the command line), or Yast online update (if you prefer a GUI). Either way gives you suggestions and a menu to deal with the problem.
    YaST Online Update only does official updates/patches from Updates repo. You need YaST Software Management to include Packman's repos.
    Leap 42.3 (ext4, KDE Plasma 5.8.7) ~ stable
    Manjaro (ext4, Xfce) ~ rolling updates
    Tumbleweed (ext4, KDE Plasma5) ~ managed updates via "Tumbleweed Snapshots" service.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,749
    Blog Entries
    3

    Default Re: Can't update via apper

    Quote Originally Posted by consused View Post
    YaST Online Update only does official updates/patches from Updates repo. You need YaST Software Management to include Packman's repos.
    Yes, that's true. Thanks for the correction.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •