Results 1 to 3 of 3

Thread: mount shared folder in fstab using Vbox 4.2.18 opensuse 13.1 guest machine = FAIL

  1. #1

    Default mount shared folder in fstab using Vbox 4.2.18 opensuse 13.1 guest machine = FAIL

    this failure is at boot with systemd warnings then a complete hang.

    remove the fstab entry in the guest and the guest starts fine and the share folder can be mounted without incident...and yes the fstab entry is proper and works perfectly in other guest machines i.e. two other opensuse 12.3 guests, both having vitrualbox guest tools 4.2.18.

    some investigation at virtualbox.org suggests that there is a problem with the 3.11 kernel and versions previous to 4.2.22 but the way i read the bugreports the shared folders won't mount manually either which is not the case with me.

    i am handcuffed to 4.2 for the time being and need a workaround, hopefully someone has had the same problem and can advise.....

    thanks in advance

  2. #2

    Default Re: mount shared folder in fstab using Vbox 4.2.18 opensuse 13.1 guest machine = FAIL

    If fstab wont work for you with systemd then you can probably write your own unit file ( files with *.service in it) and run the mount command manually. Since you are stuck with that vbox version then i don't see any other option. Well some folks might know some cool tricks though
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: mount shared folder in fstab using Vbox 4.2.18 opensuse 13.1 guest machine = FAIL

    Quote Originally Posted by jetchisel View Post
    If fstab wont work for you with systemd then you can probably write your own unit file ( files with *.service in it) and run the mount command manually. Since you are stuck with that vbox version then i don't see any other option. Well some folks might know some cool tricks though
    The documentation is obsolete.
    You should never add a shared folder in fstab, you should instead modify the Share Folder properties in the Guest's Settings, check "automount"

    TSU

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •