Results 1 to 8 of 8

Thread: Please Help Install on my new laptop

  1. #1

    Default Please Help Install on my new laptop

    Ok I have used Suse in the past on my old laptop
    now I have a Toshiba S75t-A7220
    Intel Quad Core i7-4700mq CPU's 2.40GHz x2
    12.0 GB Ram
    Full Windows Touch Support with 10 Touch Points
    Video Intel HD 4600 Shared /memory
    1TB HDD
    It has windows 8.1 preinstalled
    I have the drive partitioned with 100gb free for opensuse
    it uses UEFI secure/Boot and I can't lose windows 8
    I have installed Ubuntu 14.1LTS don't care for it any system you need to hack into to gain root is stupid.
    every time I try open suse it just hangs even the live images please help
    It should fly on this system.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,803

    Default Re: Please Help Install on my new laptop

    Could be a a video problem there was a problem with the Intel driver on the 13.1 DVD there is a patch but you got to install first LOL

    At the installer boot screen ( I assume you arrived there) press e then find the line that starts with linux go to the end and enter a space then nomodeset F10 should resume the boot

    This should continue the install using more generic drivers

    You may need to do that again when the system reboots

    Once installed and running do an update which should update the Intel drive among other things that should then correct the problem

  3. #3

    Default Re: Please Help Install on my new laptop

    Thank you
    Yes I have tried this and there is no line that starts with linux
    except linuxefi and this one will not work.
    I have read this in the forums should have stated that i have tried this.
    If I disable secure boot and uefi then it will start with no kms but then i lose windows 8.1.
    Plus it won't load a boot loader unless I format the whole drive allowing a master boot record.
    Is opensuse able to boot with secure boot.
    I would think so since Microsoft is a large contributor to the opensuse project .
    Thanks for any help

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,189
    Blog Entries
    3

    Default Re: Please Help Install on my new laptop

    Quote Originally Posted by mauiredman420 View Post
    Yes I have tried this and there is no line that starts with linux
    except linuxefi and this one will not work.
    Yes, that's the line that you are looking for. Putting "nomodeset" (without the quotes) at the end of that line should do the same thing as the NoKMS with the legacy boot method. So maybe try it again.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5

    Default Re: Please Help Install on my new laptop

    Quote Originally Posted by nrickert View Post
    Yes, that's the line that you are looking for. Putting "nomodeset" (without the quotes) at the end of that line should do the same thing as the NoKMS with the legacy boot method. So maybe try it again.
    Ok thank you I did add it to the end of the linuxefi line with space.
    Then after about an hour I hit ctl alt f4 to see the process if it was not froze.
    I found that it was stuck trying to load usb drivers for my touchscreen and error out and repeated adding inputs over and over.
    Added pic from my facebook finally found a use for facebook lol.

    https://www.facebook.com/photo.php?f...type=1&theater
    This is weird correct?
    any way to prevent this i cant find anything in the bios the kill the touch screen

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,803

    Default Re: Please Help Install on my new laptop

    If you look close the USB addresses are different so I guess there is a defined device for each of the 10 touch points

    So does it then hang after detecting and rejecting the 10 points?

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,189
    Blog Entries
    3

    Default Re: Please Help Install on my new laptop

    Quote Originally Posted by mauiredman420 View Post
    I found that it was stuck trying to load usb drivers for my touchscreen and error out and repeated adding inputs over and over.
    It seems to be timing out on each usb port.

    Hmm, I occasionally have that happen on one computer. Rebooting usually solves it. But maybe you have new hardware that the kernel is not properly recognizing. Ubuntu 14.04 has a newer kernel. Maybe you will need to wait until opensuse 13.2 Milestone 1 is available for testing, as perhaps it will have a kernel that can handle your hardware.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8

    Cool Re: Please Help Install on my new laptop

    Alright solved this it was loading each touch point and fail to load the driver with the usb 3.0 so I dropped my usb 3.0 to 2.0 in bios and dam its fast loves the 8 cores and 12 gig of ram

    I would like to say thanks to every one here who contributed to my love of opensuse. A Big WOOT to
    gogalthorp, nrickert For promptly helping.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •