Results 1 to 4 of 4

Thread: kded4 not running after upgrading from 12.3 to 13.1

  1. #1

    Default kded4 not running after upgrading from 12.3 to 13.1



    Also, Ksnapshot doesn't start after pressing "PrtScrn" key even though it is configured to do so. Not sure if it's related or not.

  2. #2
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: kded4 not running after upgrading from 12.3 to 13.1

    You might try downloading the DVD installer, run it and choose "Upgrade". This will rewrite the system files and possibly replace anything that is missing, fix links, without destroying your current installation. It just writes overtop. This often repairs some missing dependencies, as well.

    After you have done that, you will have to run all updates, as the system will have reverted to the file versions on the DVD. Many updates have been done since then, so you do not want to skip updating after you do this "overlay install".
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  3. #3

    Default Re: kded4 not running after upgrading from 12.3 to 13.1

    Problem resolved. This occurred because I have dual monitors and I am using the nvidia proprietary drivers. I was using the xinerama option, which conflicts with randr. Apparently kded4 or one of its dependents is dependent on randr. Dual monitor support works without xinerama these days. By ditching xinerama, there is no conflict with randr.

  4. #4
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: kded4 not running after upgrading from 12.3 to 13.1

    Quote Originally Posted by dilireus View Post
    Problem resolved. This occurred because I have dual monitors and I am using the nvidia proprietary drivers. I was using the xinerama option, which conflicts with randr. Apparently kded4 or one of its dependents is dependent on randr. Dual monitor support works without xinerama these days. By ditching xinerama, there is no conflict with randr.
    Good to hear you solved the problem. The information might be usefull in the future, as most of my machines run nVIDIA.
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •