Results 1 to 5 of 5

Thread: triple boot "windows 7" "windows 8" opensuse 13.1

  1. #1
    Join Date
    Jun 2010
    Location
    Rouen, Normandy, france
    Posts
    1

    Default triple boot "windows 7" "windows 8" opensuse 13.1

    Hi,

    I had Windows 8.1 dual bboot with Windows 7. All working fine.

    I installed openSUSE 13.1 for two venues this week nui.fr/blog and now has only Windows 8.1 and openSUSE 13.1 in boot menu.

    I checked the web and found many tricks/articles but none came near the actual situation.

    Here are some salient information on the box coming straight from openSUSE 13.1

    http://nui.fr/result.txt

    If you have successfully done that before, you could save my life!

    Cheers,
    Jimmy

  2. #2
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: triple boot "windows 7" "windows 8" opensuse 13.1

    Quote Originally Posted by jimmypierre View Post
    Hi,

    I had Windows 8.1 dual bboot with Windows 7. All working fine.

    I installed openSUSE 13.1 for two venues this week nui.fr/blog and now has only Windows 8.1 and openSUSE 13.1 in boot menu.

    I checked the web and found many tricks/articles but none came near the actual situation.

    Here are some salient information on the box coming straight from openSUSE 13.1

    http://nui.fr/result.txt

    If you have successfully done that before, you could save my life!

    Cheers,
    Jimmy
    Your first problem is going to be with UEFI/EFI. From what I can see is that you currently have that disabled, but I am guessing, since I have not bothered exploring Win8+ (I am sorta-retired) and none of my machines are new enough for UEFI/EFI experience.

    Some of the techs in my friends list have experience with this, so maybe they will spot this post and help out.

    Most important thing to keep things running correctly, as I have gleaned from the W8/Dualboot techs here, is to disable quick or fast boot in W8+, make sure W8+ does a full shutdown.

    The other thing to keep in mind, this from experience, is do not hibernate any version of Windows and expect to multi-boot while Win is hibernated.

    In addition, Win updates will occasionally overwrite the MBR with what MS wants in there, which is not some other operating system.

    Another problem I can see for you at this time is that you are booting from the Extended partition and that you have it set with the Boot or Active flag, while at the same time you have Grub also installed in MBR.

    It really should be one or the other.

    And, I would instead of Extended, install Grub to the /root partition (in your case, a logical partition inside the extended partition), and set the /root partition as Boot or Active, if you wish to go that way.

    But, on that, I am uncertain if you should be installing Grub there on a Win8 system, anyway.

    There are successfull triple-boots in other threads, here. You might try hunting them down for good advice.

    Or wait for some of my friends, who have the W8 and UEFI/EFI knowledge, to chime in.

    Best of Luck. Someone here will get you going, just be patient until they spot this thread.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: triple boot "windows 7" "windows 8" opensuse 13.1

    Looking again, though I am just guessing from what I recall w8-users on this forum, I think on your system sda1 should be set as the Boot or Active partition, and Grub left installed on the MBR, not the extended partition nor the logical partition.

    But, as I said, just a guess while waiting for those with the w8-UEFI/EFI experience to jump in here.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,803

    Default Re: triple boot "windows 7" "windows 8" opensuse 13.1

    ok look in the EFI/boot/ partition and see if there are all 3 OS's represented. Boot control is in the partition now. And you should also be able to choice in the UEFI BIOS which to boot.

    In Linux I think it is mounted as /boot/EFI/boot

  5. #5
    Join Date
    Dec 2008
    Location
    Montana, USA
    Posts
    550

    Default Re: triple boot "windows 7" "windows 8" opensuse 13.1

    Quote Originally Posted by gogalthorp View Post
    ok look in the EFI/boot/ partition and see if there are all 3 OS's represented. Boot control is in the partition now. And you should also be able to choice in the UEFI BIOS which to boot.

    In Linux I think it is mounted as /boot/EFI/boot
    In openSUSE, the EFI directory, in the FAT partition, is mounted as /boot/efi. The EFI directory contains directories created by the os installation process.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •