Results 1 to 4 of 4

Thread: Opensuse on Vmware - Systemd - eme

  1. #1

    Lightbulb Opensuse on Vmware - Systemd - eme

    Hi,

    I've got an error after installing openSUSE 13.1 on VMWARE.

    "piix4_smbus 0000:00:07.3: Host SMBus controller not enabled!"

    but what I find out that VMWARE do not use smbus and error occurs because system automatically start load piix4 module.

    The System Management Bus (abbreviated to SMBus or SMB) is a single-ended simple two-wire bis for the purpose of lightweight communication. Most commonly it is found in computer motherboards for communication with the power source for ON/OFF instructions.
    Soruce: http://en.wikipedia.org/wiki/System_Management_Bus

    To solve this problem I changed the file /etc/modprobe.d/50-blacklist.conf by adding new line

    "blacklist i2c_piix4" (do not force to load the module)

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Opensuse on Vmware - Systemd - eme

    Yeah,
    I've already reported that bug. Seems it hasn't been noticed for many years and versions of openSUSE (I don't have the bug number immediately in front of me, but it can be found easily)
    And, it's a major problem causing an unnecessary delay during bootup.
    I've found it's especially noticeable if you're installing in text mode, and varies in effect with different Desktops.

    I've also determined that the published solutions for Debian guests don't work for openSUSE(Full details reported in the bug).

    Also, AFAIK although it's very noticeable in VMware, AFAIK it's an issue in practically all virtualization technologies.

    Unless more people complain about this, I don't know that this bug will get the visibility and importance to be fixed since AFAIK no "off the shelf" solutions exist.

    I'll take a look at your solution to see if it really works but my attempts to blacklist did not.

    TSU

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Opensuse on Vmware - Systemd - eme

    Congrats.

    I've tested on a few machines and it seems to work.

    If you'd like to take credit for this fix,
    Login and add your fix and any supporting info to this bug
    https://bugzilla.novell.com/show_bug.cgi?id=862163

    Otherwise, let me know and I'll report the bug fixed with solution myself.

    TSU

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Opensuse on Vmware - Systemd - eme

    Until this fix is implanted upstream,
    I have created a little script to make implementation easier...

    Do a "Save Target As" to download the script or copy the code into your own script, then execute once.
    https://github.com/putztzu/public_sc...acklist_smb.sh

    This will likely enable <any> Guest using any virtualization technology to boot up faster, from what I've observed 30 sec- 2min faster

    Enjoy,
    TSU

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •