Results 1 to 5 of 5

Thread: Problems with my NVIDIA GeForce GT 630 on opensuse 13.1

  1. #1

    Default Problems with my NVIDIA GeForce GT 630 on opensuse 13.1

    Hi,


    I'm having problems with my video card in openSUSE 13.1.


    I have a NVIDIA GeForce GT 630 and in the first day that I installed the drivers, everything worked perfectly until I installed steam and played some games.


    But after that I was some time without playing and in the meantime I remember that there was an update from NVIDIA.
    And today when I try to play, a GLX error appeared:


    "OpenGL GLX extention not suported by display"


    I entered the "NVIDIA X Server Settings" and I went in the "OpenGL / GLX Information" tab and the following message appears:


    "Failed to query the GLX server vendor."


    Does anyone know how to solve this problem?


    Anyway, thank you!

  2. #2

    Default Re: Problems with my NVIDIA GeForce GT 630 on opensuse 13.1

    Quote Originally Posted by fabaraujo View Post
    I have a NVIDIA GeForce GT 630 and in the first day that I installed the drivers, everything worked perfectly until I installed steam and played some games.


    But after that I was some time without playing and in the meantime I remember that there was an update from NVIDIA.
    And today when I try to play, a GLX error appeared:


    "OpenGL GLX extention not suported by display"
    So you installed the driver from the nvidia repo, right?

    Please post a list of the nvidia and kernel packages you have installed:
    Code:
    rpm -qa | egrep "nvidia|kernel"
    Which kernel are you actually using?
    Code:
    uname -a
    Please install the package "Mesa-demo-x" and post the output of:
    Code:
    glxinfo | grep render

  3. #3

    Default Re: Problems with my NVIDIA GeForce GT 630 on opensuse 13.1

    Quote Originally Posted by wolfi323 View Post
    So you installed the driver from the nvidia repo, right?

    Yes.




    Please post a list of the nvidia and kernel packages you have installed:
    Code:
    rpm -qa | egrep "nvidia|kernel"
    Result:
    Code:
    kernel-firmware-20130714git-2.13.1.noarchkernel-desktop-devel-3.11.10-7.1.x86_64
    kernel-desktop-3.11.10-7.1.x86_64
    nvidia-computeG02-304.119-34.1.x86_64
    texlive-l3kernel-2013.81.svn_4469svn29409-10.5.3.noarch
    x11-video-nvidiaG02-304.119-34.1.x86_64
    kernel-desktop-3.11.6-4.1.x86_64
    kernel-devel-3.11.10-7.1.noarch
    nvidia-gfxG03-kmp-desktop-331.67_k3.11.6_4-26.1.x86_64
    nvidia-computeG03-331.67-26.1.x86_64
    nvidia-gfxG03-kmp-desktop-331.49_k3.11.6_4-29.1.x86_64
    nvidia-gfxG02-kmp-desktop-304.119_k3.11.6_4-33.1.x86_64
    nvidia-glG03-331.67-26.1.x86_64
    x11-video-nvidiaG03-331.67-26.1.x86_64
    nvidia-gfxG02-kmp-desktop-304.119_k3.11.6_4-30.1.x86_64
    texlive-l3kernel-doc-2013.81.svn_4469svn29409-10.5.3.noarch

    Which kernel are you actually using?
    Code:
    uname -a
    Result:
    Code:
     Linux geeko-13 3.11.10-7-desktop #1 SMP PREEMPT Mon Feb 3 09:41:24 UTC 2014 (750023e) x86_64 x86_64 x86_64 GNU/Linux

    Please install the package "Mesa-demo-x" and post the output of:
    Code:
    glxinfo | grep render
    Result:
    Code:
    (1/1) Installing: Mesa-demo-x-8.1.0-4.1.2 .....................................................................................................................................................................[done]
    :~>glxinfo | grep render
    Error: unable to open display

  4. #4

    Default AW: Re: Problems with my NVIDIA GeForce GT 630 on opensuse 13.1

    Quote Originally Posted by fabaraujo View Post
    Result:
    Code:
    kernel-firmware-20130714git-2.13.1.noarchkernel-desktop-devel-3.11.10-7.1.x86_64
    kernel-desktop-3.11.10-7.1.x86_64
    nvidia-computeG02-304.119-34.1.x86_64
    texlive-l3kernel-2013.81.svn_4469svn29409-10.5.3.noarch
    x11-video-nvidiaG02-304.119-34.1.x86_64
    kernel-desktop-3.11.6-4.1.x86_64
    kernel-devel-3.11.10-7.1.noarch
    nvidia-gfxG03-kmp-desktop-331.67_k3.11.6_4-26.1.x86_64
    nvidia-computeG03-331.67-26.1.x86_64
    nvidia-gfxG03-kmp-desktop-331.49_k3.11.6_4-29.1.x86_64
    nvidia-gfxG02-kmp-desktop-304.119_k3.11.6_4-33.1.x86_64
    nvidia-glG03-331.67-26.1.x86_64
    x11-video-nvidiaG03-331.67-26.1.x86_64
    nvidia-gfxG02-kmp-desktop-304.119_k3.11.6_4-30.1.x86_64
    texlive-l3kernel-doc-2013.81.svn_4469svn29409-10.5.3.noarch
    You have _both_ the G02 and the G03 driver installed, this cannot work.
    And you're the second person this weekend. See also: http://forums.opensuse.org/showthrea...28#post2643828

    Please uninstall all nvidia packages and only install the G03 driver:
    nvidia-gfxG03-kmp-desktop, x11-video-nvidiaG03, nvidia-glG03, nvidia-computeG03

    Then it should work again.

    Result:
    Code:
    (1/1) Installing: Mesa-demo-x-8.1.0-4.1.2 .....................................................................................................................................................................[done]
    :~>glxinfo | grep render
    Error: unable to open display
    I suppose you ran that as root, did you?
    You have to run this inside the graphical session in a terminal window as normal user. Otherwise it won't find the graphical display.
    But it doesn't really matter any more. The reason for your problem is obvious already.

  5. #5

    Default Re: Problems with my NVIDIA GeForce GT 630 on opensuse 13.1

    Really, your solution solved my problem!!


    Thank you very much!!!!!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •