Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Wake on Lan problem

  1. #1
    Join Date
    May 2014
    Location
    Addlestone
    Posts
    12

    Default Wake on Lan problem

    Hi all, I used to be able to wake my HP Proliant server using either Windows or Linux wol clients, however that was when it was running Windows, since installing Linux ( OpenSuse 13.1 ) I can't wake it up , I've tried wakeonlan / etherwake from my Debian box and EMCO tools from a Windows 7 box ( all of which worked before ) and no worky. , I've checked the MAC address and it hasn't changed ( I have known them to change by something cloning them ) so I'm asking the experts.
    _________________

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    17,352

    Default Re: Wake on Lan problem

    Did you use ethtool to check what is supported on the device nd what is switched on?
    Code:
    ethtool <NIC>
    as root, where <NIC> is ofcourse the device name. Is that still eth0 in 12.3, else find out with
    Code:
    ifconfig -a

    When you do not have ethtool, first install with YaST the package with the same name.
    Henk van Velden

  3. #3
    Join Date
    May 2014
    Location
    Addlestone
    Posts
    12

    Default Re: Wake on Lan problem

    Quote Originally Posted by hcvv View Post
    Did you use ethtool to check what is supported on the device nd what is switched on?
    Code:
    ethtool <NIC>
    as root, where <NIC> is ofcourse the device name. Is that still eth0 in 12.3, else find out with
    Code:
    ifconfig -a

    When you do not have ethtool, first install with YaST the package with the same name.
    Hi there, I checked with
    Code:
    ethtool eth0
    and it states wol: g which means wol is supported I believe

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    17,352

    Default Re: Wake on Lan problem

    Well, of course that is in the man page of ethtool. But basicaly you are right, allthough in my 13.1 it says:
    Code:
            Supports Wake-on: g
            Wake-on: g
    which is, strange enough, different from what you have.

    In any case, that is what I wanted to check. In my case, it won't work, because while the NIC does support it, the system (BIOS) doesn't. In your case, you say it worked earlier, thus I assume that hardware and firmware are supporting this.

    BTW I have tested it here on another system (wake from my router) and that worked, thus nasicaly 13.1 is able to do this.

    But at the moment I am out of ideas. Hope others tune in.
    Henk van Velden

  5. #5
    Join Date
    May 2014
    Location
    Addlestone
    Posts
    12

    Default Re: Wake on Lan problem

    I shortened the output for brevity i actually got the same as you - shame you are out of ideas though :-) - thanks for your help

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    17,352

    Default Re: Wake on Lan problem

    Quote Originally Posted by pkfox View Post
    I shortened the output for brevity
    Please refrain from doing this n the future, You will then probably be seen as unreliable. Best is to copy from the terminal the prompt, the command, the output and the next prompt. Copy them between CODE tags in the post. You get the CODE tags by clicking on the # button in the tool bar of the post editor. And when you change anything in what you copied/pasted (e.g. for security reasons), please say so. People here are not clairvoyant and they will take all computer text litteraly (same as the computer does).
    Henk van Velden

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    11,792

    Default Re: Wake on Lan problem

    Quote Originally Posted by pkfox View Post
    I shortened the output for brevity i actually got the same as you - shame you are out of ideas though :-) - thanks for your help
    Hi pkfox

    I've been trying to help you via your other thread on this topic at LXF forums. Anyway, I dug up this thread (post #13 onwards)

    https://forums.opensuse.org/showthre...75#post2554175

    The OP claimed that the NIC was getting powered off completely at shut down, thereby preventing WOL from working as intended. They added added a couple of commands to a systemd file to make sure that it was reactivated and configured to wake up again.
    Code:
    ifconfig eth0 up
    ethtool -s eth0 wol g
    I'm not sure why they chose that particular .shutdown file (and it would probably be better to add via a script using a dedeicated .service file) but it apparently worked for them. I'm sure others could refine this idea if necessary.

  8. #8
    Join Date
    May 2014
    Location
    Addlestone
    Posts
    12

    Default Re: Wake on Lan problem

    Quote Originally Posted by hcvv View Post
    Please refrain from doing this n the future, You will then probably be seen as unreliable. Best is to copy from the terminal the prompt, the command, the output and the next prompt. Copy them between CODE tags in the post. You get the CODE tags by clicking on the # button in the tool bar of the post editor. And when you change anything in what you copied/pasted (e.g. for security reasons), please say so. People here are not clairvoyant and they will take all computer text litteraly (same as the computer does).
    Ok apologies for that
    Last edited by hcvv; 19-May-2014 at 00:45.

  9. #9
    Join Date
    May 2014
    Location
    Addlestone
    Posts
    12

    Default Re: Wake on Lan problem

    Quote Originally Posted by deFerrari, rari View Post
    Hi pkfox

    I've been trying to help you via your other thread on this topic at LXF forums. Anyway, I dug up this thread (post #13 onwards)

    https://forums.opensuse.org/showthre...75#post2554175

    The OP claimed that the NIC was getting powered off completely at shut down, thereby preventing WOL from working as intended. They added added a couple of commands to a systemd file to make sure that it was reactivated and configured to wake up again.
    Code:
    ifconfig eth0 up
    ethtool -s eth0 wol g
    I'm not sure why they chose that particular .shutdown file (and it would probably be better to add via a script using a dedeicated .service file) but it apparently worked for them. I'm sure others could refine this idea if necessary.
    Hi there ferrari, thought I might stand a better chance of help posting here but blow me down I get you again - you certainly get around, I'll try what you suggest tonight as unfortunately I've got to work today - thanks very much for your help - shall I continue here or lxf with this thread ?

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    11,792

    Default Re: Wake on Lan problem

    Quote Originally Posted by pkfox View Post
    Hi there ferrari, thought I might stand a better chance of help posting here but blow me down I get you again - you certainly get around, I'll try what you suggest tonight as unfortunately I've got to work today - thanks very much for your help - shall I continue here or lxf with this thread ?
    Here is good for openSUSE-related help.

    To refine/clarify my last post, it is possible to add a script (located within /usr/lib/systemd/system-shutdown/) that get executed on shut-down. So you could create a custom script, with the required lines to keep the NIC active and WOL enabled.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •