Results 1 to 8 of 8

Thread: $Display not set After upgrade

  1. #1

    Default $Display not set After upgrade

    Long story.

    Last night my opensuse 12.1 said it had a bunch up upgrades available. So I decided to let it do the upgrades. It was taking a while so I walked out and didn't look at things until this morning.

    On re-boot, there were a lot of services that weren't coming up (network, kbd, virtualbox(??) and several others) and I was left at a command line login prompt. Login worked, but that was about it.

    After several hours googling on my phone, I was able to get networking going, but then when I tried starting up the the GUI a new slew of errors.

    Long story short, I tried installing an update to 13.1 (since I suspect that a recent update to nvidia repository settings (to the 13.1 path) caused everything to start falling apart).

    I've installed 13.1, but I'm getting dumped to the command line login.

    I can login, but when I type startkde I get this screen error: $DISPLAY is not set or cannot connect to the X server.

    I can't find much when I google for this error, so I'm not sure where to look next.

    If I run "dmesg | grep -i nvidia" there is one entry that looks suspicious: nvidia: disagrees about version of symbol module_layout
    but I'm not sure if that's significant.

    I CAN start the system in Failsafe mode and it launches into the GUI. So I suspect that the nvidia drivers may be involved somewhere. But, I need some pointers on where to start looking for errors/ how to troubleshoot.

    Any help is appreciated.

    -tomas

  2. #2

    Default Re: $Display not set After upgrade

    Found the solution (I think).

    Came across a page (linked in in the nvidia downloads, I think) that said to run a script named

    nvidia-xconfig

    That seems to have solved things. Everything seems to be where it should (but still adding in some tweaks (VMWare) here and there).

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,804

    Default Re: $Display not set After upgrade

    1) 12.1 has been out of support for some time so not sure where you were getting updates. ie no new patches or changes are being issued

    2) how did you update to 13.1? Online update from 12.1->13.1 is not supported you have to do it via the full DVD

    I suspect that now you have some terrible mix of 12.1 and 13.1 You need to do a DVD update to get to 100% 13.1 before you deal with the NVIDIA problem

  4. #4

    Default Re: $Display not set After upgrade

    Quote Originally Posted by gogalthorp View Post
    1) 12.1 has been out of support for some time so not sure where you were getting updates. ie no new patches or changes are being issued

    2) how did you update to 13.1? Online update from 12.1->13.1 is not supported you have to do it via the full DVD

    I suspect that now you have some terrible mix of 12.1 and 13.1 You need to do a DVD update to get to 100% 13.1 before you deal with the NVIDIA problem
    Replaying things in my mind I suspect that what started things going bad is when I updated the repository path for the nvidia drivers. It had been pointed to a 12.1 path and I set it to 13.1. I suspect this is what caused last night's notification of a lot of updates.

    And yes, the final update was from a DVD. But I did it as an update not a new install. So the confusion left by the bad mix of updates is what was causing the "$Display not set... error".

    Surprisingly, the script from nvidia to update the xconfig file was all that was needed to set things straight.

    I have had to reinstall a few things (VMWare, VLC, Chrome) which has had me looking at the update software screen and almost all things seem up-to-date since the DVD install.

    This machine is primarily a host for a handful of Windows VMs (where I spend my days writing code), so other than Chrome, it doesn't get a lot of work itself. Hopefully, I'll be stable until the next boneheaded update!

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: $Display not set After upgrade

    On 2014-05-18 07:26, dadkind wrote:

    > Replaying things in my mind I suspect that what started things going bad
    > is when I updated the repository path for the nvidia drivers. It had
    > been pointed to a 12.1 path and I set it to 13.1. I suspect this is what
    > caused last night's notification of a lot of updates.


    Never mix repositories for different releases.


    > And yes, the final update was from a DVD. But I did it as an update not
    > a new install. So the confusion left by the bad mix of updates is what
    > was causing the "$Display not set... error".


    Mmm.

    Please post the result of this command:

    Code:
    zypper lr --details
    and paste it all here, and please do so inside code tags (the '#' button
    in the forum editor). See photo


    And, assuming you now are on 13.1, run this query too:

    Code:
    rpm -q -a --queryformat "%{INSTALLTIME}\t%{INSTALLTIME:day} \
    %{BUILDTIME:day} %-30{NAME}\t%15{VERSION}-%-7{RELEASE}\t%{arch} \
    %25{VENDOR}%25{PACKAGER} == %{DISTRIBUTION} %{DISTTAG}\n" \
    | sort | cut --fields="2-" | tee rpmlist \
    | egrep -v "openSUSE.13\.1" | less -S
    which will list all the packages that do not belong to 13.1. Don't paste
    it here if it is long. You could use susepaste.org for a few weeks, or
    just tell here the gist of it.

    (if you see packages not for 13.1 you have to upgrade those: manually,
    or via zypper up, patch, and sometimes, dup).

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  6. #6

    Default Re: $Display not set After upgrade

    Thanks for the help!! I've been using linux on/off since 1994 and I'm STILL a noob!!

    It looks like my repositories are pointed to proper versions. There are a handful of libraries that came from 12.1. There are also some libraries that came from external locations.

    From your statement, I understand that I should update all the libraries that are from 12.1. Any suggestions on the ones that came from external sources? (I don't recall where/when they got installed; some may no longer be needed).

    Please let me know if I'm interpreting things incorrectly.

    Again, thanks for the help.

    Se lo agradezco!

    -tomas

    zypper lr --details
    Code:
    #  | Alias                         | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                     | Service
    ---+-------------------------------+------------------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------+--------
     1 | download.nvidia.com-opensuse  | nVidia Graphics Drivers            | Yes     | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/13.1/                               |        
     2 | download.opensuse.org-non-oss | Main Repository (NON-OSS)          | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/            |        
     3 | download.opensuse.org-oss     | Main Repository (OSS)              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                |        
     4 | ftp.gwdg.de-suse              | Packman Repository                 | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/                |        
     5 | libdvdcss repository          | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.1/                                    |        
     6 | nvidia                        | nvidia                             | Yes     | Yes     |   99     | rpm-md | ftp://download.nvidia.com/opensuse/13.1/                                |        
     7 | openSUSE-13.1-1.10            | openSUSE-13.1-1.10                 | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-ATAPI_iHAS124_B_3524215_2E8112502252 |        
     8 | repo-debug                    | openSUSE-13.1-Debug                | No      | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/13.1/repo/oss/          |        
     9 | repo-debug-update             | openSUSE-13.1-Update-Debug         | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/13.1/                         |        
    10 | repo-debug-update-non-oss     | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/13.1-non-oss/                 |        
    11 | repo-source                   | openSUSE-13.1-Source               | No      | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/13.1/repo/oss/         |        
    12 | repo-update                   | openSUSE-13.1-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                               |        
    13 | repo-update-non-oss           | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                       |
    Packages to be manually updated (not too long)
    Code:
    Thu Nov 10 2011 Wed Nov 02 2011 openSUSE-release-livecd-kde                12.1-1.4     x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.1 (none)
    Thu Nov 10 2011 Sat Oct 29 2011 libcdio12                                  0.82-12.1.2  x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.1 (none)
    Thu Nov 10 2011 Thu Nov 10 2011 gpg-pubkey                             307e3d54-4be01a65        (none)                    (none)                   (none) == (none) (none)
    Thu Nov 10 2011 Thu Nov 10 2011 gpg-pubkey                             3d25d3d9-36e12d04        (none)                    (none)                   (none) == (none) (none)
    Thu Nov 10 2011 Thu Nov 10 2011 gpg-pubkey                             3dbdc284-4be1884d        (none)                    (none)                   (none) == (none) (none)
    Thu Nov 10 2011 Thu Nov 10 2011 gpg-pubkey                             56b4177a-4be18cab        (none)                    (none)                   (none) == (none) (none)
    Thu Nov 10 2011 Thu Nov 10 2011 gpg-pubkey                             9c800aca-4be01999        (none)                    (none)                   (none) == (none) (none)
    Wed Jun 06 2012 Fri Oct 28 2011 libmng-32bit                             1.0.10-103.1.2 x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.1 (none)
    Wed Jun 06 2012 Wed Jun 08 2011 skype                                  2.2.0.35-suse111 i586                    (none)                   (none) == (none) (none)
    Wed Jul 04 2012 Wed Jul 04 2012 gpg-pubkey                             c66b6eae-4491871e        (none)                    (none)                   (none) == (none) (none)
    Sun Aug 26 2012 Sun Aug 26 2012 gpg-pubkey                             2080a7b1-4ed2584c        (none)                    (none)                   (none) == (none) (none)
    Wed Dec 26 2012 Wed Jul 25 2012 libpng14-14                              1.4.11-3.12.1  x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.1 (none)
    Wed Dec 26 2012 Fri Oct 28 2011 libHX27-32bit                              3.11-5.1.2   x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.1 (none)
    Wed Dec 26 2012 Wed Dec 26 2012 gpg-pubkey                             7fac5991-4615767f        (none)                    (none)                   (none) == (none) (none)
    Mon Jan 21 2013 Sat Jan 12 2013 jre                                    1.7.0_11-fcs     x86_64    Sun Microsystems, Inc.Java Software <jre-comments@java.sun.com> == (none) (none)
    Mon Jan 21 2013 Sat Jan 12 2013 jdk                                    1.7.0_11-fcs     x86_64    Sun Microsystems, Inc.Java Software <jre-comments@java.sun.com> == (none) (none)
    Sun Apr 14 2013 Sun Apr 14 2013 gpg-pubkey                             c8da93d2-4eb7ace1        (none)                    (none)                   (none) == (none) (none)
    Sun Apr 14 2013 Sat Oct 29 2011 libvpx0                                   0.9.7-5.1.3   x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.1 (none)
    Sun Apr 14 2013 Mon Feb 04 2013 libavutil51                               1.0.1-1.1     x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 12.1 (none)
    Sun Apr 14 2013 Sun Aug 05 2012 libx264-125                               0.125-1.1     x86_64 VideoLAN Project (http://www.videolan.org)Dominique Leuenberger <dominique-rpm@leuenberger.net> == SuSE / 12.1 (none)
    Sun Apr 14 2013 Mon Feb 04 2013 libavcodec54                              1.0.1-1.1     x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 12.1 (none)
    Sun Apr 14 2013 Mon Feb 04 2013 libavformat54                             1.0.1-1.1     x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 12.1 (none)
    Sun May 19 2013 Tue Nov 27 2012 pencil                                    2.0.3-1.fc17  noarch                    (none)                   (none) == (none) (none)
    Sat Jun 29 2013 Mon Feb 04 2013 libavfilter3                              1.0.1-1.1     x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 12.1 (none)
    Sat Jun 29 2013 Mon Feb 04 2013 libavdevice54                             1.0.1-1.1     x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 12.1 (none)
    Sat Nov 30 2013 Thu Nov 14 2013 python-zm_database_init                   2.1.0-1.1     noarch                    (none)                   (none) == (none) (none)
    Sun Dec 08 2013 Sat Jan 26 2013 libpng15-15                              1.5.13-3.1.1   x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.3 (none)
    Mon Dec 23 2013 Sat Jan 26 2013 libpng15-15-32bit                        1.5.13-3.1.1   x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.3 (none)
    Fri May 16 2014 Sun Jan 27 2013 libbluedevil1                             1.9.2-4.1.1   x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.3 (none)
    Fri May 16 2014 Sat Jan 26 2013 libebml3                                  1.2.2-8.1.2   x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.3 (none)
    Fri May 16 2014 Sat Jan 26 2013 libmatroska5                              1.3.0-8.1.1   x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.3 (none)
    Fri May 16 2014 Sat Jan 26 2013 microcode_ctl                              1.17-142.1.1 x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.3 (none)
    Fri May 16 2014 Fri Mar 01 2013 kernel-devel                             3.7.10-1.1.1   noarch                  openSUSE http://bugs.opensuse.org == openSUSE 12.3 (none)
    Fri May 16 2014 Fri Mar 01 2013 kernel-desktop-devel                     3.7.10-1.1.1   x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.3 (none)
    Fri May 16 2014 Fri Mar 01 2013 kernel-default-devel                     3.7.10-1.1.1   x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.3 (none)
    Fri May 16 2014 Sun Sep 29 2013 liba52-0                                  0.7.4-13.2    x86_64 VideoLAN Project (http://www.videolan.org)Dominique Leuenberger <dominique-rpm@leuenberger.net> == SuSE / 13.1 (none)
    Fri May 16 2014 Sun Sep 29 2013 libdca0                                0.0.5.90-5.2     x86_64 VideoLAN Project (http://www.videolan.org)Dominique Leuenberger <dominique-rpm@leuenberger.net> == SuSE / 13.1 (none)
    Fri May 16 2014 Mon Jul 23 2012 libfaad2                                    2.7-8.15    x86_64 VideoLAN Project (http://www.videolan.org)Dominique Leuenberger <dominique-rpm@leuenberger.net> == SuSE / 12.2 (none)
    Fri May 16 2014 Sat Apr 05 2014 libx264-142                               0.142-1.1     x86_64 VideoLAN Project (http://www.videolan.org)Dominique Leuenberger <dominique-rpm@leuenberger.net> == SuSE / 13.1 (none)
    Fri May 16 2014 Sun Sep 29 2013 libfaac0                                   1.28-3.2     x86_64 VideoLAN Project (http://www.videolan.org)Dominique Leuenberger <dominique-rpm@leuenberger.net> == SuSE / 13.1 (none)
    Fri May 16 2014 Mon Jul 23 2012 libmad0                                 0.15.1b-9.14    x86_64 VideoLAN Project (http://www.videolan.org)Dominique Leuenberger <dominique-rpm@leuenberger.net> == SuSE / 12.2 (none)
    Fri May 16 2014 Mon Jul 23 2012 libmpeg2-0                                0.5.1-7.14    x86_64 VideoLAN Project (http://www.videolan.org)Dominique Leuenberger <dominique-rpm@leuenberger.net> == SuSE / 12.2 (none)
    Fri May 16 2014 Mon Jul 23 2012 libopencore-amrnb0                        0.1.3-1.14    x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 12.2 (none)
    Fri May 16 2014 Mon Jul 23 2012 libopencore-amrwb0                        0.1.3-1.14    x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 12.2 (none)
    Fri May 16 2014 Mon Jul 23 2012 libtwolame0                              0.3.13-1.14    x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 12.2 (none)
    Fri May 16 2014 Mon Jul 23 2012 libxvidcore4                              1.3.2-1.14    x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 12.2 (none)
    Fri May 16 2014 Sat Apr 05 2014 libswresample0                              2.2-2.1     x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 12.2 (none)
    Fri May 16 2014 Thu Nov 21 2013 libmp3lame0                              3.99.5-1.12    x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 12.2 (none)
    Fri May 16 2014 Sat Apr 05 2014 libpostproc52                               2.2-2.1     x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 12.2 (none)
    Fri May 16 2014 Fri Mar 01 2013 kernel-desktop                           3.7.10-1.1.1   x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.3 (none)
    Fri May 16 2014 Tue Feb 05 2013 vmware-guest-kmp-desktop        9.2.0_k3.7.6_1.2-2.1.4          x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.3 (none)
    Fri May 16 2014 Sat Feb 16 2013 virtualbox-guest-kmp-desktop    4.2.6_k3.7.7_1.2-3.1.8          x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.3 (none)
    Fri May 16 2014 Tue Feb 05 2013 ndiswrapper-kmp-desktop         1.57.99_k3.7.6_1.2-5.1.2        x86_64                  openSUSE http://bugs.opensuse.org == openSUSE 12.3 (none)
    Fri May 16 2014 Sat Apr 05 2014 libavcodec55                                2.2-2.1     x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 13.1 (none)
    Fri May 16 2014 Sat Apr 05 2014 libavdevice55                               2.2-2.1     x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 13.1 (none)
    Fri May 16 2014 Sat Apr 05 2014 libavfilter4                                2.2-2.1     x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 13.1 (none)
    Fri May 16 2014 Sat Apr 05 2014 libavformat55                               2.2-2.1     x86_64 VideoLAN Project (http://www.videolan.org)                   (none) == SuSE / 13.1 (none)
    Sat May 17 2014 Mon Sep 20 2010 gpg-pubkey                             1abd1afb-4c97c60c        (none)                    (none)PackMan Project (signing key) <packman@links2linux.de> == (none) (none)
    Sat May 17 2014 Wed May 07 2014 google-chrome-stable              34.0.1847.137-1       x86_64               Google Inc.Chrome Linux Team <chromium-dev@chromium.org> == (none) (none)
    Sat May 17 2014 Wed Mar 09 2011 gpg-pubkey                             6867f5be-4d77cecd        (none)                    (none)Martin Schlander (cb400f) <martin.schlander@gmail.com> == (none) (none)
    Sat May 17 2014 Sun Sep 29 2013 libdvdcss2                               1.2.13-5.2     x86_64 VideoLAN Project (http://www.videolan.org)Dominique Leuenberger <dominique-rpm@leuenberger.net> == SuSE / 13.1 (none)

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: $Display not set After upgrade

    On 18/05/2014 16:06, dadkind wrote:

    > From your statement, I understand that I should update all the libraries
    > that are from 12.1. Any suggestions on the ones that came from external
    > sources? (I don't recall where/when they got installed; some may no
    > longer be needed).


    Several come from packman. One of the fields identify the repo.


    What I would do is (from memory, I'm on Windows this instant):

    On yast package manager (QT flavour), select view by repository. Then on
    left panel, select the packman repo, and on the right hand panel, right
    click, all in this list,, update if newer version available.

    Then on left side panel select "@system" (the first entry), and in the
    sort filter below select "display unmantained packages". Try to upgrade
    each one of them (there is a version tab where you can choose an
    appropriate version if it exists), and if not, try to delete them. If it
    says there are dependencies, there are to roads: check to find out if
    there is a package of the same name, but different version: for
    instance, libavutil51 may not exist, but perhaps libavutil54 does.

    This will solve most of the packages listed in the query I asked you to do.

    I see in that list that many of those come from videolan: notice that
    videolan and packman repos often conflict, it is problematic to use
    both, so choose one.

    One of the packages is the oracle jre. You will need to manually
    download the package from their site (I suggest the rpm version), then
    upgrade it with the rpm command manually. Or put it on a directory, and
    add that directory as a local repo to yast, which is easier.

    Or instead, stick to one of the java alternatives offered by openSUSE.

    --
    Cheers,
    Carlos E. R.
    (W7 - minas-morgul)

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,804

    Default Re: $Display not set After upgrade

    You have the NVIDIA repo twice remove one of them

    remove or disable number 7 that is the CD/DVD so you don't need or want that active

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •