Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: QtCreator has black widgets

  1. #1
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default QtCreator has black widgets

    For some reason QtCreator and the applications I build have these widgets with the black background instead of the correct white backgrounds. Screenshots: http://paste.opensuse.org/view/raw/52115248 and http://paste.opensuse.org/view/raw/33763749

    I initially noticed this when I installed qtcreator from the repos so I tried it with the download from the qt community site but I still get this issue. Any ideas on what is causing this? I am using the nvidia drivers ("easy way") but this happens with nouveau too.
    openSUSE Leap (42.1) 64 bit
    Plasma 5.4

  2. #2

    Default Re: QtCreator has black widgets

    Quote Originally Posted by alanbortu View Post
    For some reason QtCreator and the applications I build have these widgets with the black background instead of the correct white backgrounds. Screenshots: http://paste.opensuse.org/view/raw/52115248 and http://paste.opensuse.org/view/raw/33763749

    I initially noticed this when I installed qtcreator from the repos so I tried it with the download from the qt community site but I still get this issue. Any ideas on what is causing this? I am using the nvidia drivers ("easy way") but this happens with nouveau too.
    I don't see that here.
    Is this the Qt4 or Qt5 version of qt-creator?

    Please check your color settings in KDE's "Configure Desktop" (systemsettings)->"Application Appearance"->Colors. Maybe try to set a different color scheme.
    And GUI style have you configured? (look in "qtconfig" and in KDE's "Configure Desktop" (systemsettings)->"Application Appearance"->Style if the former one is set to "Desktop Settings")
    The Gtk+ Style can cause strange color issues, so change it to something else if that is set.

    Try to remove the file ~/.config/Trolltech.conf .

  3. #3
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: QtCreator has black widgets

    On 05/17/2014 04:16 PM, wolfi323 wrote:
    > I don't see that here.
    > Is this the Qt4 or Qt5 version of qt-creator?


    Qt 5.2.1 (Qt Creator 3.1.0)

    > Please check your color settings in KDE's "Configure Desktop"
    > (systemsettings)->"Application Appearance"->Colors. Maybe try to set a
    > different color scheme.
    > And GUI style have you configured? (look in "qtconfig" and in KDE's
    > "Configure Desktop" (systemsettings)->"Application Appearance"->Style if
    > the former one is set to "Desktop Settings")
    > The Gtk+ Style can cause strange color issues, so change it to something
    > else if that is set.


    Set KDE color scheme to default, set qtconfig style to oxygen, set gtk2
    style to oxygen and gtk3 to default. Issue is still there.

    >
    > Try to remove the file ~/.config/Trolltech.conf .


    Removed it, didnt fix the issue. Any other ideas?

    Here is another screenshot, see how its only happening in some widgets?
    http://paste.opensuse.org/view/simple/78462513

  4. #4

    Default Re: QtCreator has black widgets

    Quote Originally Posted by alanbortu View Post
    On 05/17/2014 04:16 PM, wolfi323 wrote:
    > I don't see that here.
    > Is this the Qt4 or Qt5 version of qt-creator?


    Qt 5.2.1 (Qt Creator 3.1.0)
    Well, everything I wrote applied to the Qt4 version.

    > Please check your color settings in KDE's "Configure Desktop"
    > (systemsettings)->"Application Appearance"->Colors. Maybe try to set a
    > different color scheme.
    > And GUI style have you configured? (look in "qtconfig" and in KDE's
    > "Configure Desktop" (systemsettings)->"Application Appearance"->Style if
    > the former one is set to "Desktop Settings")
    > The Gtk+ Style can cause strange color issues, so change it to something
    > else if that is set.


    Set KDE color scheme to default, set qtconfig style to oxygen, set gtk2
    style to oxygen and gtk3 to default. Issue is still there.
    The GTK2/GTK3 settings apply only to GTK applications obviously.
    And changing the KDE4 settings has no influence on Qt5 applications either, only on apps using Qt4.


    >
    > Try to remove the file ~/.config/Trolltech.conf .


    Removed it, didnt fix the issue. Any other ideas?
    Of course, again that is the Qt4 configuration.
    Qt5 stores the configuration in ~/.config/QtProject/ I think, so try to remove/rename that.

    You would need to use KDE5's systemsettings (which you probably don't have installed).

    Does it work as a new user?

    Does it help if you run it like this?
    Code:
    QT_STYLE_OVERRIDE=oxygen qtcreator
    Or just install/use the Qt4 version instead. (package qt-creator)

  5. #5
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: QtCreator has black widgets

    On 05/17/2014 05:36 PM, wolfi323 wrote:
    > Or just install/use the Qt4 version instead. (package qt-creator)


    Already tried, didnt help with the programs I built.

    > Qt5 stores the configuration in ~/.config/QtProject/ I think, so try to
    > remove/rename that.


    I removed ~/.config/QtProject/QtCreator.conf but it did nothing.

    > And changing the KDE4 settings has no influence on Qt5 applications
    > either, only on apps using Qt4.


    Ah okay, did not know that.

    >QT_STYLE_OVERRIDE=oxygen qtcreator


    Works for QtCreator but when I build the application it uses the CDE
    theme and still has the black areas.

    > Does it work as a new user?


    Yes it does, I created a new user and built the application and it works
    fine. But I still cannot get it to work on my user (tried adding it as a
    brand new project but no good).

  6. #6

    Default Re: QtCreator has black widgets

    Quote Originally Posted by alanbortu View Post
    On 05/17/2014 05:36 PM, wolfi323 wrote:
    > Or just install/use the Qt4 version instead. (package qt-creator)


    Already tried, didnt help with the programs I built.
    I thought you only have this problem in qtcreator.
    Using the Qt4 version of qtcreator should fix it for qtcreator itself.

    The programs you are building still use Qt5 of course, if they are built against Qt5.

    > Qt5 stores the configuration in ~/.config/QtProject/ I think, so try to
    > remove/rename that.


    I removed ~/.config/QtProject/QtCreator.conf but it did nothing.
    Try to remove/rename the whole directory ~/.config/QtProject/.
    I'm not sure at the moment where Qt5 stores its settings, but it seems to be ~/.config/QtProject.conf, so remove that as well if it is there.

    Also try to remove ~/.config/kdeglobals if it exists.

    As it is working with a new user, it has to be caused by some user setting.

  7. #7
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: QtCreator has black widgets

    On 05/17/2014 06:36 PM, wolfi323 wrote:
    > Try to remove/rename the whole directory ~/.config/QtProject/.
    > I'm not sure at the moment where Qt5 stores its settings, but it seems
    > to be ~/.config/QtProject.conf, so remove that as well if it is there.


    Removed them, opened qtcreator (for qt4), imported the project, still
    get the issue. I just noticed this in the Application Output though.

    Code:
    "Qt Warning - invalid keysym: dead_actute"
    libGL error: failed to load driver: swrast
    libGL error: Try again with LIBGL_DEBUG=verbose for more details.
    libpng warning: iCCP: known incorrect sRGB profile
    libpng warning: iCCP: known incorrect sRGB profile
    libpng warning: iCCP: known incorrect sRGB profile
    libpng warning: iCCP: known incorrect sRGB profile
    As I said before I am using the nvidia drivers that were installed the
    easy way so not sure why I get a libGL error. I installed Mesa-demo-x
    and glxinfo | grep direct shows direct rendering: yes. hwinfo --gfx card
    says nvidia is active.

    According to mesa3d.org swrast is the legacy rasterizer so why is it
    being used?

    > Also try to remove ~/.config/kdeglobals if it exists.


    Did not exist on my system.




  8. #8
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: QtCreator has black widgets

    Output of glxinfo | grep render
    Code:
    $ glxinfo | grep render                                   
    direct rendering: Yes
    OpenGL renderer string: GeForce GTX 560 Ti/PCIe/SSE2
        GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
        GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image, 
        GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
        GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
        GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image, 
        GL_NV_parameter_buffer_object2, GL_NV_path_rendering,
    Read this and it gets rid of the first line in the error but I still get (ran form zsh just to debug)

    Code:
    $ ./editor                                          
    libpng warning: iCCP: known incorrect sRGB profile
    libpng warning: iCCP: known incorrect sRGB profile
    libpng warning: iCCP: known incorrect sRGB profile
    libpng warning: iCCP: known incorrect sRGB profile
    openSUSE Leap (42.1) 64 bit
    Plasma 5.4

  9. #9
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: QtCreator has black widgets

    Sorry for the triple posting, seems qtcreator gives additional output:

    Code:
    Debugging starts
     &"warning: GDB: Failed to set controlling terminal: Inappropriate ioctl for device\n"
     Temporarily disabling breakpoints for unloaded shared library "/usr/lib64/libLLVMRuntimeDyld.so"
     libGL error: failed to load driver: swrast
     libGL error: Try again with LIBGL_DEBUG=verbose for more details.
     libpng warning: iCCP: known incorrect sRGB profile
     libpng warning: iCCP: known incorrect sRGB profile
     libpng warning: iCCP: known incorrect sRGB profile
     libpng warning: iCCP: known incorrect sRGB profile
    openSUSE Leap (42.1) 64 bit
    Plasma 5.4

  10. #10

    Default Re: QtCreator has black widgets

    Quote Originally Posted by alanbortu View Post
    On 05/17/2014 06:36 PM, wolfi323 wrote:
    > Try to remove/rename the whole directory ~/.config/QtProject/.
    > I'm not sure at the moment where Qt5 stores its settings, but it seems
    > to be ~/.config/QtProject.conf, so remove that as well if it is there.


    Removed them, opened qtcreator (for qt4), imported the project, still
    get the issue. I just noticed this in the Application Output though.
    You installed the Qt4 version of qt-creator now?
    So it is fixed for qtcreator, but you still have the problems with the applications you build, right?

    As I wrote already, this is normal of course. If you build a Qt5 application, it uses Qt5 no matter whether you run it inside Qt4-qtcreator or Qt5-qtcreator.

    And you prabably will have the same problem with any other Qt5 application, like assistant-qt5 f.e.

    According to mesa3d.org swrast is the legacy rasterizer so why is it
    being used?
    It isn't used. The message actually says that the software rasterizer cannot be loaded (probably because you have the nvidia driver installed which breaks Mesa).

    That's just debug output from Qt5 which can be ignored.

    > Also try to remove ~/.config/kdeglobals if it exists.

    Did not exist on my system.
    I thought so, as KDE5 would create that, but I wanted to mention it.

    The other two "errors" you got can be ignored as well. You already fixed the first one (it is fixed in Factory as well already).

    So which qt-creator are you using now? Qt4 or Qt5? Which package did you install?

    Again, it must be some user setting, since it works fine with a new user.
    And forcing the style to oxygen with "QT_STYLE_OVERRIDE=oxygen qtcreator" fixed it as well. But I still have no idea where libqt5 would store the style.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •