Results 1 to 4 of 4

Thread: yast2 - power off during installation - problem

  1. #1
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default yast2 - power off during installation - problem

    Hi
    I was updating some software via yast2. Unfortunately power went off during installation.
    Now the system (yast2 with verification mode) tells me I have problem with 3 programs: xvidcore, libvlccore7, libxine2-pulse.
    I tried to remove them via yast, via zypper, manually as a root from disk.
    Yast still tells me there's a problem and each time wants to remove them. When I click ok, then it says it cannot be done.
    At the same time it says it is both installed and not installed.
    I try installing, uninstalling, updating - nothing.
    In the yast2 window (tab Versions) it says it has 2 or 3 the same versions installed. But physically on the disk there is one version.
    So I guess yast remembers somewhere updating list from before the power went off and tries to 'finish' it.
    Restarting computer and refreshing repos does not help.

    Are we able to solve it?
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: yast2 - power off during installation - problem

    Please try

    Code:
    su -
    zypper clean -a
    Code:
    zypper ref
    Code:
    zypper up
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: yast2 - power off during installation - problem

    And also try to rebuild your RPM database, as it seems corrupted:
    Code:
    sudo rpm --rebuilddb

  4. #4
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: yast2 - power off during installation - problem

    Thank you for your responses.

    First run of these commands gave nothing.
    I had to do it that way:
    Code:
    zypper clean -a
    then in yast2 remove problematic programs/libraries
    Code:
    zypper ref
    in yast2 install those programs/libraries

    and at the moment it seems to be solved

    I did logout and log in and right now yast2 does not report any problem
    thanks
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •