Results 1 to 6 of 6

Thread: Dual monitors: Default not so default

  1. #1
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Dual monitors: Default not so default

    I have just attached my new monitor in DVI-0, while my old monitor is on DVI-1. I have configured my new montor to be the default one and it works most of the times.

    Something when I start a new application it starts in my old/secondary monitor. How can I make sure that all new applications are started in the main monitor?

    Clicking on Kmix in the system tray opens kmix audio setting not in the monitor that has the system tray, but the secondary one. This is a bit strange. Same goes for my KDE Display Configuration lying in the system tray.

    Somehow it seems setting a screen as default only has effect on where the panels are placed.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Dual monitors: Default not so default

    Might want to mention the video card and what driver.

  3. #3
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: Dual monitors: Default not so default

    In KDE4.12 system-settings, the Screen & Monitor module let you choose the primary display (click the star at the bottom of the display so it turns yellow).

    Alternatively, for each window you can set the screen or position in the advanced settings - right click the title bar>more actions>special window configurations. For example, setting "position" to "remember" or "screen" to "X", X being your screen number, probably 0 or 1.

    One of these should fix your problem, IF you have the system/hardware I'm assuming you have. Next time you may want to inform your oS and DE version, as well as the (relevant to the issue) hardware/driver info as gogalthorp requested. That way we can better help you.

    Good luck.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,395
    Blog Entries
    1

    Default Re: Dual monitors: Default not so default

    Quote Originally Posted by brunomcl View Post
    Alternatively, for each window you can set the screen or position in the advanced settings - right click the title bar>more actions>special window configurations. For example, setting "position" to "remember" or "screen" to "X", X being your screen number, probably 0 or 1.
    Good suggestion brunomcl. I recall playing with these settings while having access to dual monitor configuration at work once, but it was months ago. Usually, I just drag what I want manually, since I tend to operate with a single display (too lazy to attach standalone monitor), unless the tasks at hand are too tedious to cope with one display.

    Anyway, hope it works for the OP's purpose.

  5. #5
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: Dual monitors: Default not so default

    Forgot these:
    Opensuse 13.1
    KDE 4.13.1
    NVidia Geforce 650 Ti using NVidia own drivers

    As i wrote in the OP i have already set my new monitor as default (Star icon). The only default is mostly where the panel is placed. Most of the times applications are opened in the main monitor, but something it opens in the secondary monitor.

  6. #6
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: Dual monitors: Default not so default

    Lately now when I open up a video in MPlayer it places itself between both monitors. VLC places itself always in the primary monitor.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •