Results 1 to 7 of 7

Thread: FreeNX Server on 12.3

  1. #1
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    974

    Default FreeNX Server on 12.3

    Has anyone been successful bringing up FreeNX Server on 12.3?

    I tried using PTA's method HERE, but get the same "not ready yet" message as recently reported in that thread.
    Thanks
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  2. #2

    Default Re: FreeNX Server on 12.3

    Quote Originally Posted by cmcgrath5035 View Post
    Has anyone been successful bringing up FreeNX Server on 12.3?

    I tried using PTA's method HERE, but get the same "not ready yet" message as recently reported in that thread.
    Thanks
    The reason causing this bug and the fix (for freenx-setup and nomachine-setup) are described in this thread Since 12.3, LSB distributor id is now "openSUSE project" and not "SUSE LINUX". However this will only fix this bug, which prevents the script from running, not other bugs which might occure later in FreeNX or Nomachine NX configuration under 12.3*, since I could not find the time to create a 12.3 repo and work on it.

    You might want to try the 12.2 repo and see if it works (or not) - after editing the script as described in the thread linked above.

    * most likely openssh issues.

  3. #3
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    974

    Default Re: FreeNX Server on 12.3

    Thanks, PTA, I know you are busy.
    Hopefully for you that is a good thing

    I will give a try and report results when I can get to it.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  4. #4
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    974

    Default Re: FreeNX Server on 12.3

    Hmmm
    I made the suggested updates to nomachine-setup and ran as root user.
    It exits with some warnings, but reviewing the logfile they appear to be informational(Some complaints about cups, etc)
    I installed on the remote 12.3/KDE machine via ssh (PAM) from my primary desktop (12.2/KDE), so sshd is up and running.

    On the remote computer, both nxserver and nxsensor are now running.

    However attempts to start an NX session from the local machine fail
    Here is the log in the details window

    Code:
    NX> 203 NXSSH running with pid: 3843
    NX> 285 Enabling check on switch command
    NX> 285 Enabling skip of SSH config files
    NX> 285 Setting the preferred NX options
    NX> 200 Connected to address: 192.168.10.41 on port: 22
    NX> 202 Authenticating user: nx
    NX> 208 Using auth method: publickey
    NX> 204 Authentication failed.
    Server and client are installed with the default keys and look to be the same both ends.

    I'll keep digging
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  5. #5
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    974

    Default Re: FreeNX Server on 12.3 (Solved)

    My bad, in another tab I actually had the answer staring at me.

    The sshd authentication keys "issue" discussed HERE for 12.2 is still here with 12.3.
    I commented out the problematic line in /etc/ssh/sshd_config, restarted sshd and NoMachine now running!
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  6. #6

    Default Re: FreeNX Server on 12.3 (Solved)

    Quote Originally Posted by cmcgrath5035 View Post
    My bad, in another tab I actually had the answer staring at me.

    The sshd authentication keys "issue" discussed HERE for 12.2 is still here with 12.3.
    I commented out the problematic line in /etc/ssh/sshd_config, restarted sshd and NoMachine now running!

    I suspected something like that. I'm glad you opened this thread because I received a PM last week describing exactly the same problem. Your thread now describes and shows how to solve the 2 issues:

    • The one preventing the script (as well as other scripts from running) due to a change in openSUSE LSB distributor ID. See the solution HERE.
    • The one causing the NX authentication failure, due to a change - a while ago - in openSSH defaults. See the solution HERE.

  7. #7

    Default Re: FreeNX Server on 12.3

    Hi,

    I am also trying to setup a free-nx server on OpenSuSe 12.3 - so far no success.
    Which packages do I have to install and where to download them ?

    I tried the packages for Suse 12.2, but it complains about libpng and libjpeg.

    Thanks for any advice !

    Wolfgang

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •