Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: NFS server setup error

  1. #1

    Default NFS server setup error

    I am attempting to set up NFS file sharing between two PCs, each running suse 13.1. Previously, the two PCs were connected with Samba, as one was running Windows XP.

    When I attempt to start the NFS Server from Yast (running openSuse 13.1), I receive the following error:

    "Unable to start idmapd. Check your domain setting."

    "Enable NFSv4" is checked in the configuration panel and the domain is "localdomain."

    If I uncheck "Enable NFSv4," I then get the error: "Unable to stop idmapd"

    All suggestions welcome. Thanks.

  2. #2
    Join Date
    Dec 2008
    Location
    Chicago
    Posts
    12

    Default Re: NFS server setup error

    Quote Originally Posted by w2tq View Post
    I am attempting to set up NFS file sharing between two PCs, each running suse 13.1. Previously, the two PCs were connected with Samba, as one was running Windows XP.

    When I attempt to start the NFS Server from Yast (running openSuse 13.1), I receive the following error:

    "Unable to start idmapd. Check your domain setting."

    "Enable NFSv4" is checked in the configuration panel and the domain is "localdomain."

    If I uncheck "Enable NFSv4," I then get the error: "Unable to stop idmapd"

    All suggestions welcome. Thanks.
    Similar issue here

  3. #3
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: NFS server setup error

    Hello.

    NFS works fine here on two different computers running 13.1 servers; tested it just earlier today in fact (if any upgrade should have done anything negatively to it); I do also run an NFS server on an old SuSE 9.1 computer, which works just as fine with 13.1 clients.
    I mount manually though, but that should not have any implications on the server set-up.

    Please elaborate on the set-up procedure, I have seen references to NFS problems here earlier but not experienced any myself.


    PS
    One of the clients are running WinXP, sharing on an NFS network using Windows is no problem.

    Olav
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  4. #4

    Default Re: NFS server setup error

    I have somehow overcome the problem - I don't recall exactly how - perhaps by simply ignoring the warning.

    Also, as mentioned in the original post, this is not a Samba installation.

  5. #5
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: NFS server setup error

    OK.

    Sorry if I was ambiguous, meant to say that a NFS share was/is available as an alternative to what you previously had set up as a share server (SAMBA).


    Olav
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  6. #6
    Join Date
    Dec 2008
    Location
    Chicago
    Posts
    12

    Default Re: NFS server setup error

    Quote Originally Posted by F_Sauce View Post
    Hello.
    Please elaborate on the set-up procedure, I have seen references to NFS problems here earlier but not experienced any myself.
    Olav
    yeah, I have run NFS on opensuse for the last ten years. Never ran into this error before. The way I learned to setup NFS was to set my network static, setup my hosts file, and run a local DNS(with just forwarders and the default .arpa master zone.

    I have a brand new install, in fact, I even re-installed because my initial network setup was sloppy. I also have a new 13.1 install that will be the client system and on that machine it produced the same error.

    So, a brand new install. I set up my network, Hosts file, DNS - I setup my folders to export in the Yast NFS Server applet. upon saving the exports I get the error like the OP, "Unable to start idmapd. Check your domain setting." But in fact, idmapd does start, I watched it start in the process viewer.

    Still the Yast NFS Client cannot see any NFS server on the network, from any machine.

    as well like the OP I have tried unchecking the v4 box and got the same error "Unable to stop idmapd"

    I am not a sophisticated command line linux user, but I read up on manually configuring fstab, exports, idmapd and the NFS server and it seems to me that everything was in the right place. I have also looked around for a NEW NFS How To but not really found anything; I looked around in case there was really anything that new in the 13.1 setup process.

    I would really appreciate any help to get this working, tell me what info you need from me to get the details you need to better understand the errors.

    NFS is so much nicer than samba for linux.

  7. #7
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: NFS server setup error

    The way I learned to setup NFS was to set my network static, setup my hosts file, and run a local DNS(with just forwarders and the default .arpa master zone.
    Aha, I have never had to go through all that, but some kind of static set-up makes things easier.

    What you could try is to ignore somehow the error message, hope that the server will automatically start on a reboot and then try to mount manually:
    Code:
    mount 10.0.0.1: /mnt/nfs/a
    Change the IP and create a directory where you wish to mount it; mount as root.


    My two server machines running OS 13.1 are set up straight forwards through the YaST module 'NFS server', I have not added any extra parameters for security etc., they are just open for the LAN; but I do have firewalls running on them, remember to open port.

    These links might provide some useful information; and the man pages are useful, though might be a bit exhaustive and difficult to read.
    http://en.opensuse.org/SDB:Network_file_system
    http://users.suse.com/~sjayaraman/nfs4_howto.txt (probably a bit old?)


    NB
    NFSv4 is enabled.
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  8. #8
    Join Date
    Dec 2008
    Location
    Chicago
    Posts
    12

    Default Re: NFS server setup error

    Quote Originally Posted by F_Sauce View Post
    Aha, I have never had to go through all that, but some kind of static set-up makes things easier.

    What you could try is to ignore somehow the error message, hope that the server will automatically start on a reboot and then try to mount manually:

    My two server machines running OS 13.1 are set up straight forwards through the YaST module 'NFS server', I have not added any extra parameters for security etc., they are just open for the LAN; but I do have firewalls running on them, remember to open port.
    sorry it took so long to reply....

    I do have nfs working - not optimally though - the nfs server is not discoverable via the "choose" button.
    because I fill in my hosts file, I can simply add the alias for the NFS server and then sellect the mounts I want.

    I have not tried to find out why the NFS server is not discoverable, It is a project for another day.
    I think I have to work on my DNS settings which would be fodder for it's own thread.

  9. #9

    Default Re: NFS server setup error

    On my second nfs server in the same network, I got this error. I have not fixed it yet, but...

    one CAN edit the /etc/exports file manually

    and restart with

    systemctl start rpcbind.service

    just an idea.

  10. #10

    Default Re: NFS server setup error

    I think the NFS server, before 13.1 had a separate support daemon called idmapd. I believe they have now made idmapd part of the nfsserver. (No idmap package, or files can be found in 13.1, but a idmaplib does exists.) The YAST tool seams to be writing the config file correctly for the latest nfsserver. But the script has not been updated when you exit/finish, so it first tries to start the idmapd, and when that fails, exits without starting the nfsserver.

    I have had the same issue with the YAST tool. Use:

    systemctl start nfsserver.service

    Once I did this, everything worked.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •