Results 1 to 9 of 9

Thread: LaTeX package: scrlayer-scrpage missing on openSUSE 13.1

  1. #1
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    503

    Default LaTeX package: scrlayer-scrpage missing on openSUSE 13.1

    Hi,
    i just noticed, that in the current version of openSUSE 13.1 the LaTeX package: scrlayer-scrpage is not included. This is a package for creating stuff like custom headers and footers, much like the fancyhdr package (which is kind of old and should not be used with KOMA document classes).
    Currently i can avoid the scrlayer-scrpage package by using the old srcpage2 package but i noticed that the scrlayer-scrpage package is already available on other distributions (like ubuntu 14.04).

    I just have the following simple questions:
    1. do i maybe just overlooked the package in yast? If yes, what is the name of the yast package?
    2. Can i expect that the missing package maybe got added to the default repository of opensuse 13.1 eventually or do i definitely have to wait for openSUSE 13.2 for that to happen?

    thanks

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,470
    Blog Entries
    2

    Default Re: LaTeX package: scrlayer-scrpage missing on openSUSE 13.1

    Don't know if this will do it,
    When I run
    Code:
    zypper se --provides scrpage
    it returns a package called

    texlive-koma-script

    I recommend you install that,

    Code:
    zypper in texlive-koma-script
    then run the following to see what you have
    Code:
    rpm -ql texlive-koma-script
    HTH,
    TSU

  3. #3

    Default Re: LaTeX package: scrlayer-scrpage missing on openSUSE 13.1

    On 2014-05-14, tsu2 <tsu2@no-mx.forums.opensuse.org> wrote:
    > Code:
    > --------------------
    > rpm -ql texlive-koma-script
    > --------------------


    I think the OP already has srcpage2 provided the texlive-koma-script, which has been replaced with something newer in
    other distributions.

  4. #4
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,454

    Default Re: LaTeX package: scrlayer-scrpage missing on openSUSE 13.1

    13.1 comes with TeXLive 2013 and so the version of KOMA-Script shipped with it does not include scrlayer-scrpage which comes with the 2014 release. That is why distros released more recently will have it.

  5. #5
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    503

    Default Re: LaTeX package: scrlayer-scrpage missing on openSUSE 13.1

    I see, so there is definitely not going to be an update within the openSUSE 13.1 repositorys?

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: LaTeX package: scrlayer-scrpage missing on openSUSE 13.1

    On 2014-05-15 10:56, sabo007 wrote:
    >
    > I see, so there is definitely not going to be an update within the
    > openSUSE 13.1 repositorys?


    For a "definite" answer, you have to ask the people maintaining those
    packages. My guess is that you will not see that on the "official"
    repos, but you might on the "non official" repos.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  7. #7

    Default Re: LaTeX package: scrlayer-scrpage missing on openSUSE 13.1

    Quote Originally Posted by sabo007 View Post
    I see, so there is definitely not going to be an update within the openSUSE 13.1 repositorys?
    A new version of the KOMAscript bundle has been published some weeks ago, as well as a large number of other packages. Please have a look here, this is the page where new packages usually are announced: http://www.mail-archive.com/ctan-ann@dante.de/

    As you probably know, packages on CTAN are not rpm packages. openSuse would have to update its TeX-sytem every week to stay on top of development.

    Usually I'd suggest to install texlive (http://tug.org/texlive/) instead of the openSuse packages, I choose /local/ as path on my system. There is even a dummy package for openSuse, so that there is no need to maintain both installations or getting messages about unsolved dependencies. texlive comes with an update system. But texlive 2013 is frozen and I'm not sure whether it contains the new version of KOMAscript (probably yes).

    So the easiest thing is to install a new version of KOMAscript on a local TDS-tree, and leave the openSuse installation as it is. If you don't know how to do that, there is much documentation out there, in English as well as in many other languages. But I recommend to install texlive, and if you are brave, take texlive 2014, which is beta but should work on Linux.

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: LaTeX package: scrlayer-scrpage missing on openSUSE 13.1

    On 2014-05-14 22:56, john hudson wrote:
    >
    > 13.1 comes with TeXLive 2013 and so the version of KOMA-Script shipped
    > with it does not include scrlayer-scrpage which comes with the 2014
    > release. That is why distros released more recently will have it.


    Even our factory has only 2013.20130620 version.

    http://software.opensuse.org/package...=%22texlive%22

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  9. #9
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    503

    Default Re: LaTeX package: scrlayer-scrpage missing on openSUSE 13.1

    Thank you all, i think i will stay with the scrpage2 package then, it is as easy as commenting out "\usepackage"{scrlayer-scrpage}" and using "\usepackage{scrpage2}"
    instead, at least in my case there is no additional modification of my tex file needed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •