Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Broadcom BCM4352 802.11ac not working! 13.1

  1. #1

    Default Broadcom BCM4352 802.11ac not working! 13.1

    Hi,

    my Broadcom Wireless Network Adapter is not working.
    I have tried this https://forums.opensuse.org/showthre...ierwork-around
    and I'm getting this output:
    Code:
    Extracting b43 firmware
    This file is recognised as:
      filename   :  wl_apsta.o
      version    :  666.2
      MD5        :  e1b05e268bcdbfef3560c28fc161f30e
    Extracting b43/lp0initvals14.fw
    ...
    
    b43 firmware successfully installed.
    
    Extracting b43legacy firmware
    This file is recognised as:
      filename   :  wl_apsta.o
      version    :  295.14
      MD5        :  e08665c5c5b66beb9c3b2dd54aa80cb3
    Extracting b43legacy/ucode2.fw
    ...
    b43legacy firmware successfully installed.
    You may want to reboot now to allow the driver to access the new firmware
    but it doesn't work. After I restart the computer it doesn't recognize my card. (can't configure it)
    I've tried the 'b43-firmware' and this doesn't work either. I don't know what I did wrong.
    This worked before.

    Please help.

  2. #2

    Default Re: Broadcom BCM4352 802.11ac not working! 13.1

    Quote Originally Posted by X_Men View Post
    Hi,

    my Broadcom Wireless Network Adapter is not working.
    I have tried this https://forums.opensuse.org/showthre...ierwork-around
    and I'm getting this output:
    Code:
    Extracting b43 firmware
    This file is recognised as:
      filename   :  wl_apsta.o
      version    :  666.2
      MD5        :  e1b05e268bcdbfef3560c28fc161f30e
    Extracting b43/lp0initvals14.fw
    ...
    
    b43 firmware successfully installed.
    
    Extracting b43legacy firmware
    This file is recognised as:
      filename   :  wl_apsta.o
      version    :  295.14
      MD5        :  e08665c5c5b66beb9c3b2dd54aa80cb3
    Extracting b43legacy/ucode2.fw
    ...
    b43legacy firmware successfully installed.
    You may want to reboot now to allow the driver to access the new firmware
    but it doesn't work. After I restart the computer it doesn't recognize my card. (can't configure it)
    I've tried the 'b43-firmware' and this doesn't work either. I don't know what I did wrong.
    This worked before.
    The b43 firmware is only used by the b43 driver (and the b43legacy firmware by the b43legacy driver) obviously.

    But the BCM4352 is _not_ supported by either of them, according to http://wireless.kernel.org/en/users/...=%28BCM4352%29 .

    The "broadcom-wl" driver should work though, this is available at Packman f.e.
    http://packman.links2linux.de/package/broadcom-wl
    (you need "broadcom-wl" and one of the "broadcom-wl-kmp-xxx" packages that matches your kernel)

    See also http://forums.opensuse.org/showthrea...-OpenSuse-13-1

  3. #3

    Default Re: Broadcom BCM4352 802.11ac not working! 13.1

    Thanks for your fast reply!

    But unfortunately this doesn't work. I have installed
    'broadcom-wl' and 'broadcom-wl-kmp-desktop'.
    Code:
    Linux G750JX.site 3.11.10-7-desktop #1 SMP PREEMPT Mon Feb 3 09:41:24 UTC 2014 (750023e) x86_64 x86_64 x86_64 GNU/Linux
    But again after a restart it doesn't recognize my card /can't configure it.
    (Maby because I have installed the nvidia driver?)

  4. #4

    Default Re: Broadcom BCM4352 802.11ac not working! 13.1

    Quote Originally Posted by X_Men View Post
    Thanks for your fast reply!

    But unfortunately this doesn't work. I have installed
    'broadcom-wl' and 'broadcom-wl-kmp-desktop'.
    I hope you installed the 64bit version of 'broadcom-wl-kmp-desktop'.

    But again after a restart it doesn't recognize my card /can't configure it.
    (Maby because I have installed the nvidia driver?)
    No, why should the nvidia driver have something to do with it?

    Could you please post the output of:
    Code:
    /sbin/lspci -nnk

  5. #5

    Default Re: Broadcom BCM4352 802.11ac not working! 13.1

    Code:
    00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller [8086:0c04] (rev 06)
        Subsystem: ASUSTeK Computer Inc. Device [1043:119d]
    00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller [8086:0c01] (rev 06)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
    00:14.0 USB controller [0c03]: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI [8086:8c31] (rev 04)
        Subsystem: ASUSTeK Computer Inc. Device [1043:201f]
        Kernel driver in use: xhci_hcd
        Kernel modules: xhci_hcd
    00:16.0 Communication controller [0780]: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 [8086:8c3a] (rev 04)
        Subsystem: ASUSTeK Computer Inc. Device [1043:119d]
        Kernel driver in use: mei_me
        Kernel modules: mei_me
    00:1a.0 USB controller [0c03]: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 [8086:8c2d] (rev 04)
        Subsystem: ASUSTeK Computer Inc. Device [1043:201f]
        Kernel driver in use: ehci-pci
    00:1b.0 Audio device [0403]: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller [8086:8c20] (rev 04)
        Subsystem: ASUSTeK Computer Inc. Device [1043:119d]
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
    00:1c.0 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 [8086:8c10] (rev d4)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
    00:1c.2 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 [8086:8c14] (rev d4)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
    00:1c.3 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #4 [8086:8c16] (rev d4)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
    00:1c.4 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #5 [8086:8c18] (rev d4)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
    00:1d.0 USB controller [0c03]: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 [8086:8c26] (rev 04)
        Subsystem: ASUSTeK Computer Inc. Device [1043:201f]
        Kernel driver in use: ehci-pci
    00:1f.0 ISA bridge [0601]: Intel Corporation HM87 Express LPC Controller [8086:8c4b] (rev 04)
        Subsystem: ASUSTeK Computer Inc. Device [1043:119d]
        Kernel driver in use: lpc_ich
        Kernel modules: lpc_ich
    00:1f.2 SATA controller [0106]: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] [8086:8c03] (rev 04)
        Subsystem: ASUSTeK Computer Inc. Device [1043:119d]
        Kernel driver in use: ahci
    00:1f.3 SMBus [0c05]: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller [8086:8c22] (rev 04)
        Subsystem: ASUSTeK Computer Inc. Device [1043:119d]
        Kernel modules: i2c_i801
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK106M [GeForce GTX 770M] [10de:11e0] (rev a1)
        Subsystem: ASUSTeK Computer Inc. Device [1043:213e]
        Kernel driver in use: nvidia
        Kernel modules: nvidiafb, nouveau, nvidia
    01:00.1 Audio device [0403]: NVIDIA Corporation GK106 HDMI Audio Controller [10de:0e0b] (rev a1)
        Subsystem: NVIDIA Corporation GK106 HDMI Audio Controller [10de:0e0b]
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
    03:00.0 Network controller [0280]: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)
        Subsystem: AzureWave Device [1a3b:2123]
    04:00.0 Ethernet controller [0200]: Qualcomm Atheros QCA8171 Gigabit Ethernet [1969:10a1] (rev 10)
        Subsystem: ASUSTeK Computer Inc. Device [1043:200f]
        Kernel driver in use: alx
        Kernel modules: alx

  6. #6

    Default Re: Broadcom BCM4352 802.11ac not working! 13.1

    HTML Code:
    I hope you installed the 64bit version of 'broadcom-wl-kmp-desktop'.
    Of course.

  7. #7

    Default Re: Broadcom BCM4352 802.11ac not working! 13.1

    Quote Originally Posted by X_Men View Post
    Code:
    03:00.0 Network controller [0280]: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)
        Subsystem: AzureWave Device [1a3b:2123]
    Ok, so the driver is not loaded.
    You did reboot after installing it, right?

    Please try to load it manually and post the last messages in the kernel log:
    Code:
    sudo /sbin/modprobe -v wl
    dmesg | tail

  8. #8

    Default Re: Broadcom BCM4352 802.11ac not working! 13.1

    Quote Originally Posted by wolfi323 View Post
    Ok, so the driver is not loaded.
    You did reboot after installing it, right?
    Yes

    Quote Originally Posted by wolfi323 View Post
    Please try to load it manually and post the last messages in the kernel log:
    Code:
    sudo /sbin/modprobe -v wl
    dmesg | tail
    No need. I fixed it. The packman repository wasn't updated.

    Thank you very much for your help!

    And for others with the same problem:
    You need the packman repository http://en.opensuse.org/Additional_pa...tories#Packman and
    Quote Originally Posted by wolfi323 View Post
    you need "broadcom-wl" and one of the "broadcom-wl-kmp-xxx" packages that matches your kernel

  9. #9

    Default Re: Broadcom BCM4352 802.11ac not working! 13.1

    Quote Originally Posted by X_Men View Post
    No need. I fixed it. The packman repository wasn't updated.
    You mean you installed the version for 12.3 or similar? Then the current kernel cannot find it of course.

    Thank you very much for your help!
    Glad to here it's working now!

    And for others with the same problem:
    You need the packman repository http://en.opensuse.org/Additional_pa...tories#Packman and
    Or enter YaST->Software Repositories, click on "Add" and select "Community Repositories". It should be there in that list as well.

    This only helps if you have another way to connect to the Internet of course (i.e. wired f.e.).
    If not, you can download the packages here:
    http://packman.links2linux.de/package/broadcom-wl

    Download the ones you need on a different PC and/or operating system, copy them to an USB stick or similar and install them either with "sudo rpm -i xxx.rpm" or by just opening them in a file manager.

  10. #10

    Default Re: Broadcom BCM4352 802.11ac not working! 13.1

    Quote Originally Posted by wolfi323 View Post
    You mean you installed the version for 12.3 or similar?
    No I had a repository(13.1) with a previous version of the broadcom-wl. But this doesn't matter now.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •