Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: KMail has vanished! Unable re-open after crash. Akonadi, Nepomuk not registered at D-Bus.

  1. #1
    Join Date
    Sep 2012
    Location
    Ireland
    Posts
    29

    Post KMail has vanished! Unable re-open after crash. Akonadi, Nepomuk not registered at D-Bus.

    Hi, folks! Our KMail has crashed disastrously during requisite reconfiguration and tweaking of one of our existing webmail accounts. We use KMail 4.4.10-3.2-x86_64 as packaged within openSuSE 11.4. I have tried several times to reopen it via the application launcher, but receive only a KDE Crash Handler notification, which reports as follows:─

    Code:
    
    Details: 
    Executable: kmail PID: 11458 Signal: Segmentation fault (11)
    Developer information:
    The generated crash information is useful:─
    Application: KMail (kmail), signal: Segmentation fault
    [KCrash Handler]
    #6 0x00007f3e4f678199 in KMailICalIfaceImpl::readConfig (this=0x6a77f0) at /usr/src/debug/kdepim-4.4.10/kmail/kmailicalifaceimpl.cpp:1785
    #7 0x00007f3e4f575ade in KMKernel::setupDBus (this=0x7fff0fa563a0) at /usr/src/debug/kdepim-4.4.10/kmail/kmkernel.cpp:227
    #8 0x00000000004033a8 in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdepim-4.4.10/kmail/main.cpp:141

    My attempting to restart from the Crash Handler merely triggers a KMail warning message: “
    KMail seems already to be running on another display on this machine. Running KMail more than once can cause the loss of mail. You should not start KMail unless you are sure that it is not running already.”

    Absolutely certain it is not running already, I press Start KMail, but immediately I am back again to the selfsame KDE Crash Handler notification!

    Thus, in a quick follow-up to this posting (on account of this site's 15,000-character posting restriction), I shall be appending an Akonadi Server Self-Test Report, which I trust will provide sufficient information to enable some kind knowledgeable folks to please guide me step-by-step in my endeavour restore our crashed KMail programme. I have been using Linux for seven years, but realise full well I have yet much to learn; and am most keen so to do! Many thanks, fellow penguins!

    MagnifiKat


    -------------

    Siemens “Esprimo” P5616 desktop | Fujitsu D2461-A12 micro-BTX mobo |
    KDE 4.6.00 (4.6.0) "release 6" | Linux 2.6.37.6-24-desktop x86_64 |

    AMD Athlon 64 X2 4600+ 2·4GHz dual-core CPU | DVD SuperMulti |
    8GB DDR2-800MHz dual-channel RAM | nVidia MCP51 Ethernet |
    nVidia GeForce 7300LE 256MB TrueMemory | openSuSE 11.4 (X86-64) |

  2. #2

    Default Re: KMail has vanished! Unable re-open after crash. Akonadi, Nepomuk not registered at D-Bus.

    Quote Originally Posted by MagnifiKat View Post

    Code:
    
    Details: 
    Executable: kmail PID: 11458 Signal: Segmentation fault (11)
    Developer information:
    The generated crash information is useful:─
    Application: KMail (kmail), signal: Segmentation fault
    [KCrash Handler]
    #6 0x00007f3e4f678199 in KMailICalIfaceImpl::readConfig (this=0x6a77f0) at /usr/src/debug/kdepim-4.4.10/kmail/kmailicalifaceimpl.cpp:1785
    #7 0x00007f3e4f575ade in KMKernel::setupDBus (this=0x7fff0fa563a0) at /usr/src/debug/kdepim-4.4.10/kmail/kmkernel.cpp:227
    #8 0x00000000004033a8 in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdepim-4.4.10/kmail/main.cpp:141
    Apparently it crashes in KMailICalIfaceImpl::readConfig, so it seems your configuration has been corrupted.

    I would first try to start it as a new user to rule out any installation problem. (should work I suppose)

    Then we have to find out which file is corrupted and fix it if possible or remove it.
    But try as a new user first.

    My attempting to restart from the Crash Handler merely triggers a KMail warning message: “[/FONT][/SIZE]KMail seems already to be running on another display on this machine. Running KMail more than once can cause the loss of mail. You should not start KMail unless you are sure that it is not running already.”

    Absolutely certain it is not running already, I press Start KMail, but immediately I am back again to the selfsame KDE Crash Handler notification!

    Of course it is running already, as the crash reporter captures it running in gdb to present you the backtrace.

    Thus, in a quick follow-up to this posting (on account of this site's 15,000-character posting restriction), I shall be appending an Akonadi Server Self-Test Report, which I trust will provide sufficient information to enable some kind knowledgeable folks to please guide me step-by-step in my endeavour restore our crashed KMail programme.
    No, that wouldn't help at all.
    KMail 4.4.10 as included in openSUSE 11.4 did not use Akonadi yet.

    But hasn't there been an update to 4.4.11.1 for 11.4?
    (I seem to remember that, or was that for 12.1? It has been a while... )

  3. #3
    Join Date
    Sep 2012
    Location
    Ireland
    Posts
    29

    Default Re: KMail has vanished! Unable re-open after crash. Akonadi, Nepomuk not registered at D-Bus.

    Hi, wolfi323. Thank you for your prompt, kind and helpful response.

    Quote Originally Posted by wolfi323 View Post
    Apparently it crashes in KMailICalIfaceImpl::readConfig, so it seems your configuration has been corrupted.
    Yes, most likely cause of this crash was my having erroneously changed .maildir to .mbox setting (as a test) when reconfiguring a particularly problematic webmail account within KMail. Unfortunately, I cannot remember in which of four possible system settings ── Appearance, Composer, Security, Miscellaneous ── my wrongly-set .maildir or .mbox options were located; and, of course, I have no way presently of opening KMail in order to check!

    I would first try to start it as a new user to rule out any installation problem. (should work I suppose)
    Yes, this I shall do if need be; but, given that KMail has been running well since I installed openSuSE 11.4 in November 2011, installation, clearly, is not a problem.

    Thus, in a quick follow-up to this posting (on account of this site's 15,000-character posting restriction), I shall be appending an Akonadi Server Self-Test Report, which I trust will provide sufficient information to enable some kind knowledgeable folks to please guide me step-by-step in my endeavour restore our crashed KMail programme.

    No, that wouldn't help at all.
    KMail 4.4.10 as included in openSUSE 11.4 did not use Akonadi yet.
    Er, what?!! Then how come I have before me an A4 printout of a post-crash Akonadi Server Self-Test Report? Test #9, in particular, reads as follows:─

    Code:
      Test 9:  SUCCESS
      -----------------
      akonadictl found and usable
      Details: The program '/usr/bin/akonadictl' to control the Akonadi server was found
      and could be executed successfully.
      Result:
      Akonadi 1.5.0
    Referring again to my post-crash Akonadi printout, errors show up on Tests #2, 10, 11, 12, 14, 15 and 16. I am puzzled especially by Test #2, which states that Akonadi was started as root! Whereas, BEFORE the KMail crash, earlier Akonadi printouts show clearly that Akonadi was NOT then running as root! Very strange indeed!

  4. #4

    Default Re: KMail has vanished! Unable re-open after crash. Akonadi, Nepomuk not registered at D-Bus.

    Quote Originally Posted by MagnifiKat View Post
    Er, what?!! Then how come I have before me an A4 printout of a post-crash Akonadi Server Self-Test Report? Test #9, in particular, reads as follows:─

    Code:
      Test 9:  SUCCESS
      -----------------
      akonadictl found and usable
      Details: The program '/usr/bin/akonadictl' to control the Akonadi server was found
      and could be executed successfully.
      Result:
      Akonadi 1.5.0
    Referring again to my post-crash Akonadi printout, errors show up on Tests #2, 10, 11, 12, 14, 15 and 16. I am puzzled especially by Test #2, which states that Akonadi was started as root! Whereas, BEFORE the KMail crash, earlier Akonadi printouts show clearly that Akonadi was NOT then running as root! Very strange indeed!
    Again, KMail 4.4.10 DOES NOT use Akonadi yet! That doesn't mean that Akonadi is not installed/running of course.
    Akonadi was already part of 11.4, and KAddressbook already used it in 11.4.

    But your problem is definitely not related to Akonadi.

    Well, if you rename the KMail configuration (~/.kde4/share/config/kmailrc) it should start again.
    But you would have to reconfigure everything from scratch then (your accounts, all filters, maybe the folder where your EMail is located).

    According to your crash report, KMail apparently crashes when it tries to read in the accounts settings, so have a look at those.
    Maybe post the file (you can omit the passwords of course, but they should be unreadable anyway), perhaps I can spot the problem.
    Last edited by wolfi323; 13-May-2014 at 07:02.

  5. #5
    Join Date
    Sep 2012
    Location
    Ireland
    Posts
    29

    Default Re: KMail has vanished! Unable re-open after crash. Akonadi, Nepomuk not registered at D-Bus.

    Quote Originally Posted by wolfi323 View Post
    Well, if you rename the KMail configuration (~/.kde4/share/config/kmailrc) it should start again. But you would have to reconfigure everything from scratch then (your accounts, all filters, maybe the folder where your EMail is located).
    Obviously, since this would be immensely time-consuming, and before so doing, I would prefer firstly to consider any and all other possible options!

    According to your crash report, KMail apparently crashes when it tries to read in the accounts settings, so have a look at those. Maybe post the file (you can omit the passwords of course, but they should be unreadable anyway), perhaps I can spot the problem.
    Carefully, on-screen, I have looked through the 104 pages of ~/.kde4/share/config/kmailrc, as per your kind suggestion, in search of a likely configuration error. I have copied just TWO tiny sections which may or may not be of help to you in your diagnosis.

    Thus, in the panel below, in red, I have highlighted a possible error ── default-mailbox-format=0 ── which surely instead should read: default-mailbox-format=1 ??? Could this be the problem area, I wonder? The consequence of my having erroneously changed the .maildir to .mbox (or vice versa??) setting, perhaps? Please advise.

    Code:
    ~/.kde4/share/config/kmailrc
    [ kmailrc – Kwrite ]
    
    [$Version]
    update_info=mailtransports.upd:initial-kmail-migration,kmail.upd:1,kmail.upd:4,kmail.upd:5,kmail.upd:6,kmail.upd:7,kmail.upd:8,kmail.upd:9,kmail.upd:3.1-update-identities,kmail.upd:3.1-use-identity-uoids,kmail.upd:3.1-new-mail-notification,kmail.upd:3.2-update-loop-on-goto-unread-settings,kmail.upd:3.1.4-dont-use-UOID-0-for-any-identity,kmail.upd:3.2-misc,kmail.upd:3.2-moves,kmail.upd:3.3-use-ID-for-accounts,kmail.upd:3.3-update-filter-rules,kmail.upd:3.3-move-identities-to-own-file,kmail.upd:3.3-misc,kmail.upd:3.3b1-misc,kmail.upd:3.4,kmail.upd:3.4a,kmail.upd:3.4b,kmail.upd:3.4.1,kmail.upd:3.5.4,kmail.upd:3.5.7-imap-flag-migration,kmail.upd:4.0-misc,kmail.upd:4.2,kmail.upd:3.3-aegypten-kpgprc-to-kmailrc
    
     [General]
     Default domain=
     Recent Addresses= (A very long and confidential list which is irrelevant for this posting)
     SystemTrayEnabled=true
     SystemTrayPolicy=ShowAlways
     beep-on-mail=true
     checkmail-startup=true
     confirm-before-empty=true
     customDateFormat=ddd-dd-MMM-yyyy     hh:mm     Z
     dateFormat=5
     default-mailbox-format=0
     empty-trash-on-exit=false
     filters=13
     first-start=false
     folders[$e]=$HOME/.kde4/share/apps/kmail/mail
     messagetags=3
     mime-header-count=0
     myMessageIdSuffix=
     popfilters=0
     popshowDLmsgs=false
     previous-version=1.13.6
     startupFolder=inbox
     useCustomMessageIdSuffix=false
     
    
     [Geometry]
    Your kind help in this matter is very, very much appreciated.

  6. #6

    Default Re: KMail has vanished! Unable re-open after crash. Akonadi, Nepomuk not registered at D-Bus.

    Quote Originally Posted by MagnifiKat View Post
    Thus, in the panel below, in red, I have highlighted a possible error ── default-mailbox-format=0 ── which surely instead should read: default-mailbox-format=1 ??? Could this be the problem area, I wonder? The consequence of my having erroneously changed the .maildir to .mbox (or vice versa??) setting, perhaps? Please advise.
    Yes, "default-mailbox-format=1" sets the default format to maildir.
    So try to change that back. But I'm not sure whether this could cause the crash. (obviously is _shouldn't_, but maybe 4.4.10 had a bug regarding this, who knows? I don't have KMail 4.4 here any more)

    I will have to take a deeper look at the source code to get a better idea what could cause this crash, but that might take a while.

  7. #7
    Join Date
    Sep 2012
    Location
    Ireland
    Posts
    29

    Default Re: KMail has vanished! Unable re-open after crash. Akonadi, Nepomuk not registered at D-Bus.

    Quote Originally Posted by wolfi323 View Post
    Yes, "default-mailbox-format=1" sets the default format to maildir. So try to change that back. But I'm not sure whether this could cause the crash. (obviously is _shouldn't_, but maybe 4.4.10 had a bug regarding this, who knows? I don't have KMail 4.4 here any more)

    I will have to take a deeper look at the source code to get a better idea what could cause this crash, but that might take a while.
    Thank you for confirming my belief that default-mailbox-format=1 sets the default format to maildir. I am most hopeful therefore that, if I change the “=0” to read “=1”, as per your kind suggestion, KMail may reappear magically ... just as it was before it crashed.

    Perhaps, wolfi323 ── to safeguard against any likelihood of my making an horrendous mistake in the Konsole terminal ── you will be so kind as to advise the exact command-line coding I should enter to enable me do this successfully. Many thanks indeed. --- MagnifiKat.

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,698

    Default Re: KMail has vanished! Unable re-open after crash. Akonadi, Nepomuk not registered at D-Bus.

    make a backup of the file just in case you need to revert

  9. #9
    Join Date
    Sep 2012
    Location
    Ireland
    Posts
    29

    Default Re: KMail has vanished! Unable re-open after crash. Akonadi, Nepomuk not registered at D-Bus.

    Quote Originally Posted by gogalthorp View Post
    make a backup of the file just in case you need to revert
    Hi, gogalthorp! As per your wise suggestion, and lest I have need to undo upcoming action, I have copied successfully the ~/.kde4/share/config/kmailrc file to another temporary location (Documents), pending my being provided, please, needful command-line coding guidance as requested in my post #7. Many thanks.

    MagnifiKat

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,698

    Default Re: KMail has vanished! Unable re-open after crash. Akonadi, Nepomuk not registered at D-Bus.

    Sorry can't help with that just wanted to make sure you had you life vest on

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •