Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: error download from download.opensuse.org via teminal

  1. #1

    Question error download from download.opensuse.org via teminal

    Dear All,

    please help about this issue
    everytime i try to update or install aplication it's always get connection error (see below)

    ===================================================================
    #zypper update kaffeine
    Retrieving repository 'openSUSE-13.1-Non-Oss' metadata ----------------[\]
    Download (curl) error for 'http://download.opensuse.org/distribution/13.1/repo/non-oss/repodata/repomd.xml':
    Error code: Connection failed
    Error message: Failed connect to download.opensuse.org:80; Network is unreachable

    Abort, retry, ignore? [a/r/i/? shows all options] (a):

    ===================================================================

    my internet connection using proxy

    thanks for somebody want to help

  2. #2

    Default Re: error download from download.opensuse.org via teminal

    Quote Originally Posted by gozarudin View Post
    my internet connection using proxy
    I think that's your problem.

    Have you configured your proxy in /etc/syconfig/proxy or YaST->Network Services->Proxy?
    zypper DOES NOT use your desktop's proxy settings. (although YaST does I think)

    And also definitely not your Webbrowser's proxy settings of course.

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: error download from download.opensuse.org via teminal

    On 2014-05-12 12:36, wolfi323 wrote:

    > zypper DOES NOT use your desktop's proxy settings. (although YaST does I
    > think)


    No, I think it doesn't. At least it did not, years ago.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  4. #4

    Default Re: error download from download.opensuse.org via teminal

    Quote Originally Posted by robin_listas View Post
    On 2014-05-12 12:36, wolfi323 wrote:

    > zypper DOES NOT use your desktop's proxy settings. (although YaST does I
    > think)


    No, I think it doesn't. At least it did not, years ago.
    AFAIK YaST uses libproxy1 (actually libzypp apparently does according to the dependencies, so zypper should use libproxy1 as well), which has plugins for reading KDE4's and GNOME's proxy settings.

    Maybe this doesn't work because they are started as root? Or maybe because the OP started zypper with sudo so libproxy1 cannot see the current KDE/GNOME session?

    I thought that only YaST uses libproxy1, because having libproxy1-config-kde4 installed in Factory makes YaST crash at the moment, wheras zypper works fine. But on second thought, zypper doesn't use libqt5 anyway so it is to be expected that is doesn't crash even when libproxy1 loads libqt4. (the crash in Factory is caused by YaST loading libqt4 via libproxy1-config-kde4 _and_ libqt5 via libyui-qt)

    Anyway, setting the proxy in YaST as mentioned should fix the problem.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: error download from download.opensuse.org via teminal

    On 2014-05-12 15:06, wolfi323 wrote:

    >>

    > AFAIK YaST uses libproxy1 (actually libzypp apparently does according to

    ....
    > loading libqt4 via libproxy1-config-kde4 _and_ libqt5 via libyui-qt)


    Thanks for the explanation, I'm saving it :-)

    >
    > Anyway, setting the proxy in YaST as mentioned should fix the problem.


    Yep. It has done for years, at least...

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  6. #6

    Default Re: error download from download.opensuse.org via teminal

    Quote Originally Posted by robin_listas View Post
    On 2014-05-12 15:06, wolfi323 wrote:

    >>

    > AFAIK YaST uses libproxy1 (actually libzypp apparently does according to

    ....
    > loading libqt4 via libproxy1-config-kde4 _and_ libqt5 via libyui-qt)


    Thanks for the explanation, I'm saving it :-)
    FYI, here's the bug I reported, that's why I know this:
    https://bugzilla.novell.com/show_bug.cgi?id=866692

  7. #7

    Default Re: error download from download.opensuse.org via teminal

    Quote Originally Posted by wolfi323 View Post
    AFAIK YaST uses libproxy1 (actually libzypp apparently does according to the dependencies, so zypper should use libproxy1 as well), which has plugins for reading KDE4's and GNOME's proxy settings.

    Maybe this doesn't work because they are started as root? Or maybe because the OP started zypper with sudo so libproxy1 cannot see the current KDE/GNOME session?

    I thought that only YaST uses libproxy1, because having libproxy1-config-kde4 installed in Factory makes YaST crash at the moment, wheras zypper works fine. But on second thought, zypper doesn't use libqt5 anyway so it is to be expected that is doesn't crash even when libproxy1 loads libqt4. (the crash in Factory is caused by YaST loading libqt4 via libproxy1-config-kde4 _and_ libqt5 via libyui-qt)

    Anyway, setting the proxy in YaST as mentioned should fix the problem.


    i already setting the proxy in YaST but it's still don't fix the problem.

  8. #8

    Default Re: error download from download.opensuse.org via teminal

    Quote Originally Posted by gozarudin View Post
    i already setting the proxy in YaST but it's still don't fix the problem.
    TBH, I never used a proxy myself.

    Did you reboot after setting this? (not sure if that's necessary)

    Does your Internet connection work otherwise?
    Can you reach http://download.opensuse.org/distrib.../repo/non-oss/ in a web browser?

    Can you please post /etc/sysconfig/proxy?

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: error download from download.opensuse.org via teminal

    On 2014-05-13 11:46, wolfi323 wrote:

    > Does your Internet connection work otherwise?
    > Can you reach
    > http://download.opensuse.org/distrib.../repo/non-oss/ in a web
    > browser?
    >
    > Can you please post /etc/sysconfig/proxy?



    Have a look at yast/zypper logs after it tries to connect.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  10. #10

    Default Re: error download from download.opensuse.org via teminal

    Quote Originally Posted by wolfi323 View Post
    TBH, I never used a proxy myself.

    Did you reboot after setting this? (not sure if that's necessary)

    Does your Internet connection work otherwise?
    Can you reach http://download.opensuse.org/distrib.../repo/non-oss/ in a web browser?

    Can you please post /etc/sysconfig/proxy?

    yes i reboot it and my internet access work very well
    and i reach http://download.opensuse.org/distrib.../repo/non-oss/ in a web browser very well too

    this is my /etc/sysconfig/proxy

    ## Path: Network/Proxy
    ## Description:
    ## Type: yesno
    ## Default: no
    ## Config: kde,profiles
    #
    # Enable a generation of the proxy settings to the profile.
    # This setting allows to turn the proxy on and off while
    # preserving the particular proxy setup.
    #
    PROXY_ENABLED="no"

    ## Type: string
    ## Default: ""
    #
    # Some programs (e.g. lynx, arena and wget) support proxies, if set in
    # the environment.
    # Example: HTTP_PROXY="http://proxy.provider.de:3128/"
    HTTP_PROXY="http://10.1.200.16"

    ## Type: string
    ## Default: ""
    #
    # Some programs (e.g. lynx, arena and wget) support proxies, if set in
    # the environment.
    # This setting is for https connections
    HTTPS_PROXY="http://10.1.200.16"

    ## Type: string
    ## Default: ""
    #
    # Example: FTP_PROXY="http://proxy.provider.de:3128/"
    #
    FTP_PROXY="http://10.1.200.16"

    ## Type: string
    ## Default: ""
    #
    # Example: GOPHER_PROXY="http://proxy.provider.de:3128/"
    #
    GOPHER_PROXY=""

    ## Type: string(localhost)
    ## Default: localhost
    #
    # Example: NO_PROXY="www.me.de, do.main, localhost"
    #

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •