Results 1 to 8 of 8

Thread: Digikam 4.0.0

  1. #1

    Question Digikam 4.0.0

    Digikam has issue a new expected release 4.0.0.
    I tried to install in opensuse 13.1 but I got an error about libdkcraw.so.23 not available.

    Is it any solution to this problem?

  2. #2

    Default Re: Digikam 4.0.0

    Quote Originally Posted by antoniolivella View Post
    Digikam has issue a new expected release 4.0.0.
    I tried to install in opensuse 13.1 but I got an error about libdkcraw.so.23 not available.

    Is it any solution to this problem?
    And _how_ exactly did you try to install it?

    I have installed it from KDE:Extra and do have libkdcraw23 here as well (this is in the KDE:Current repo).
    But the version for standard openSUSE 13.1 DOES NOT require libkdcraw23, but libkdcraw22, which is of course included in the standard repo.

    Maybe you try to install the version for KDE:Current (KDE 4.13) on standard openSUSE 13.1 (KDE 4.11)?
    Please post your repo list:
    Code:
    zypper lr -d

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,670
    Blog Entries
    1

    Default Re: Digikam 4.0.0

    Quote Originally Posted by antoniolivella View Post
    Digikam has issue a new expected release 4.0.0.
    I tried to install in opensuse 13.1 but I got an error about libdkcraw.so.23 not available.

    Is it any solution to this problem?
    How did you try to install it? The package manager should have taken care of any dependencies for you. BTW, I think you mean 'libkdcraw23'

    I have digikam-4.0.0-8.2.x86_64 installed, and it installed as part of a recent update via
    Code:
    zypper up

  4. #4
    Join Date
    Oct 2009
    Location
    Sweden
    Posts
    1,015

    Default Re: Digikam 4.0.0

    I installed Digikam 4.0.0 on my 13.1 64-bit trow zypper dup (have extra KDE repos added).

    I used http://software.opensuse.org/package/digikam for my standard LXDE 13.1 32-bit pc, was only asked to break one dependency.

    Working fine on both pc .


    Regards
    I'm shameless like others in the forum -was I to any help or made sense? If yes: click the on the star below to the left. Written whit a ;-) in my eye.

  5. #5

    Default Re: Digikam 4.0.0

    Quote Originally Posted by deano_ferrari View Post
    How did you try to install it? The package manager should have taken care of any dependencies for you. BTW, I think you mean 'libkdcraw23'

    I have digikam-4.0.0-8.2.x86_64 installed, and it installed as part of a recent update via
    Code:
    zypper up
    I have downloaded from Digikam opensuse: digikam 4.0.0-rc 1.1 x86_64.rpm

    antoni@localhost:~> zypper up
    Root privileges are required for updating packages.
    antoni@localhost:~> sudo zypper up
    root's password:
    Retrieving repository 'devel:ARM:13.1' metadata ...................................................................................................................[error]
    Repository 'devel:ARM:13.1' is invalid.
    [|] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Disabling repository 'devel:ARM:13.1'.
    Retrieving repository 'devel:ARM:13.1:Contrib' metadata ...........................................................................................................[error]
    Repository 'devel:ARM:13.1:Contrib' is invalid.
    [|] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Disabling repository 'devel:ARM:13.1:Contrib'.
    Loading repository data...
    Reading installed packages...

    The following 122 package updates will NOT be installed:
    acpica amarok android-tools apper apper-lang appmenu-qt bluedevil choqok cln crda digikam digikam-doc exiftool gd gegl-0_2 graphviz graphviz-gd graphviz-gnome
    gstreamer gstreamer-0_10 gstreamer-0_10-plugin-esd gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good gstreamer-plugins-base gtk2-engine-oxygen gtk2-theme-oxygen
    hugin icoutils ImageMagick k3b kaffeine kde-gtk-config kde-gtk-config-lang kio_iso kipi-plugins kipi-plugins-acquireimage kipi-plugins-geolocation konversation
    konversation-lang ksshaskpass ktorrent kvkbd lcms2 lensfun-data libavutil52 libbabl-0_1-0 libbluedevil2 libdjvulibre21 libFLAC++6 libFLAC8 libfreebl3 libgegl-0_2-0
    libgstapp-0_10-0 libgstapp-1_0-0 libgstaudio-1_0-0 libgstinterfaces-0_10-0 libgstpbutils-1_0-0 libgstreamer-0_10-0 libgstreamer-1_0-0 libgstriff-1_0-0 libgsttag-1_0-0
    libgstvideo-1_0-0 libhdf5-8 libhdf5_hl8 libiw30 libixion-0_6-0 libjbig2 libjbig2-32bit libjpeg8 libjpeg8-32bit libjpeg-turbo libkface2 libkgeomap1 liblcms2-2
    liblensfun0 libmediastreamer_base3 libmediastreamer_voip3 libmediawiki1 libmjpegutils-2_0-0 libmysqlcppconn6 libopencv2_4 libopenjpeg1 liborcus-0_6-0 libpano13-2
    libpgf6 libqalculate5 libquicktime0 libsoftokn3 libsox2 libstrigi0 libtag-extras1 libts-1_0-0 libusb-0_1-4 libusb-1_0-0 libusbmuxd2 libvpx1 libxine2 libxine2-pulse
    mjpegtools moodbar MozillaFirefox MozillaFirefox-branding-openSUSE MozillaFirefox-translations-common mozilla-kde4-integration mozilla-nspr mozilla-nss
    mozilla-nss-certs perl-File-RandomAccess perl-Image-ExifTool python-numpy python-setuptools skanlite skanlite-doc skanlite-lang smartmontools sox strigi synaptiks
    usbmuxd wireless-regdb wireless-tools wpa_supplicant

    The following NEW package is going to be installed:
    yast2-inetd-doc

    1 new package to install.
    Overall download size: 301,2 KiB. After the operation, additional 1,3 MiB will be used.
    Voleu continuar? [y/n/? shows all options] (y): y
    Retrieving package yast2-inetd-doc-3.0.0-2.1.4.noarch (1/1), 301,2 KiB ( 1,3 MiB unpacked)
    Retrieving: yast2-inetd-doc-3.0.0-2.1.4.noarch.rpm ..................................................................................................................[fet]
    (1/1) Installing: yast2-inetd-doc-3.0.0-2.1.4 .......................................................................................................................[fet]

  6. #6

    Default Re: Digikam 4.0.0

    Quote Originally Posted by wolfi323 View Post
    And _how_ exactly did you try to install it?

    I have installed it from KDE:Extra and do have libkdcraw23 here as well (this is in the KDE:Current repo).
    But the version for standard openSUSE 13.1 DOES NOT require libkdcraw23, but libkdcraw22, which is of course included in the standard repo.

    Maybe you try to install the version for KDE:Current (KDE 4.13) on standard openSUSE 13.1 (KDE 4.11)?
    Please post your repo list:
    Code:
    zypper lr -d
    I downloaded from Digikam opensuse: digikam 4.0.0-rc-1.1x86_64.rpm

    antoni@localhost:~> zypper lr -d
    # | Àlies | Nom | Habilitat | Refresca | Priority | Tipus | URI | Service
    ---+-------------------------------+----------------------------------------------+-----------+----------+----------+--------+-------------------------------------------------------------------------------------------------+--------
    1 | devel:ARM:13.1 | devel:ARM:13.1 | Sí | Sí | 99 | NONE | http://download.opensuse.org/reposit...M:/13.1/ports/ |
    2 | devel:ARM:13.1:Contrib | devel:ARM:13.1:Contrib | Sí | Sí | 99 | NONE | http://download.opensuse.org/reposit...trib/standard/ |
    3 | download.opensuse.org-Extra | openSUSE BuildService - KDE:Extra | Sí | Sí | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    4 | download.opensuse.org-Stable | openSUSE BuildService - LibreOffice | Sí | Sí | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    5 | download.opensuse.org-mozilla | openSUSE BuildService - Mozilla | Sí | Sí | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    6 | ftp.gwdg.de-suse | Packman Repository | Sí | Sí | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman...openSUSE_13.1/ |
    7 | graphics | graphics | Sí | Sí | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    8 | hardware | hardware | Sí | Sí | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    9 | home:tarkane | home:tarkane | Sí | Sí | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    10 | home_tarkane | Tarkan Erimer's Home Project (openSUSE_13.1) | Sí | No | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    11 | openSUSE-13.1-1.10 | openSUSE-13.1-1.10 | Sí | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-VMware_Virtual_IDE_CDROM_Drive_10000000000000000001,/dev/sr0 |
    12 | repo-debug | openSUSE-13.1-Debug | No | Sí | 99 | NONE | http://download.opensuse.org/debug/d...13.1/repo/oss/ |
    13 | repo-debug-update | openSUSE-13.1-Update-Debug | No | Sí | 99 | NONE | http://download.opensuse.org/debug/update/13.1/ |
    14 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No | Sí | 99 | NONE | http://download.opensuse.org/debug/update/13.1-non-oss/ |
    15 | repo-non-oss | openSUSE-13.1-Non-Oss | Sí | Sí | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    16 | repo-oss | openSUSE-13.1-Oss | Sí | Sí | 99 | yast2 | http://download.opensuse.org/distrib...13.1/repo/oss/ |
    17 | repo-source | openSUSE-13.1-Source | No | Sí | 99 | NONE | http://download.opensuse.org/source/...13.1/repo/oss/ |
    18 | repo-update | openSUSE-13.1-Update | Sí | Sí | 99 | rpm-md | http://download.opensuse.org/update/13.1/ |
    19 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Sí | Sí | 99 | rpm-md | http://download.opensuse.org/update/13.1-non-oss/

  7. #7

    Default Re: Digikam 4.0.0

    Quote Originally Posted by antoniolivella View Post
    I downloaded from Digikam opensuse: digikam 4.0.0-rc-1.1x86_64.rpm
    Where did you download it from? (exact link)
    First, this is 4.0.0-rc1, not the final 4.0.0.
    Second, as I already mentioned, this is most probably the package for KDE SC 4.13 (as mentioned, KDE:Current does contain libkdcraw23 as well, so the digikam package requires this).

    Forget about that, see below.

    antoni@localhost:~> zypper lr -d
    # | Àlies | Nom | Habilitat | Refresca | Priority | Tipus | URI | Service
    ---+-------------------------------+----------------------------------------------+-----------+----------+----------+--------+-------------------------------------------------------------------------------------------------+--------
    ...
    3 | download.opensuse.org-Extra | openSUSE BuildService - KDE:Extra | Sí | Sí | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    This repo does contain a digikam-4.0.0 that should work on your system. Install that instead of the one you downloaded:
    Code:
    sudo zypper in -f digikam-4.0.0
    Or enter YaST->Software Management, search for "digikam", select the package, click on "Versions" below the package list and install the 4.0.0 version there.
    Last edited by wolfi323; 15-May-2014 at 12:17.

  8. #8

    Default Re: Digikam 4.0.0

    Quote Originally Posted by wolfi323 View Post
    Where did you download it from? (exact link)
    First, this is 4.0.0-rc1, not the final 4.0.0.
    Second, as I already mentioned, this is most probably the package for KDE SC 4.13 (as mentioned, KDE:Current does contain libkdcraw23 as well, so the digikam package requires this).

    Forget about that, see below.


    This repo does contain a digikam-4.0.0 that should work on your system. Install that instead of the one you downloaded:
    Code:
    sudo zypper in -f digikam-4.0.0
    Or enter YaST->Software Management, search for "digikam", select the package, click on "Versions" below the package list and install the 4.0.0 version there.
    It works, thank you.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •